BGP Peer Groups on Cisco IOS

Hi Adiel,

These two lessons might help to understand what is going on:

BGP Neighbor Adjacency States

Troubleshooting BGP Neighbor Adjacency

Is your router able to reach 2.2.2.2, 3.3.3.3 or 4.4.4.4? Are R2, R3 and R4 able to reach 1.1.1.1? That’s something to check. Make sure the BGP configuration on R2, R3 and R4 is also using the loopback address as the source of the connection and that multihop is configured.

Rene

sir i did exactly as u did i didn’t work until i added a static route and i have to specify the neighbors manually on R1 for all it worked

 network 1.1.1.0 mask 255.255.255.0
 neighbor R2_R3_R4 peer-group
 neighbor R2_R3_R4 ebgp-multihop 2
 neighbor R2_R3_R4 update-source Loopback0
 neighbor 2.2.2.2 remote-as 2
 neighbor 2.2.2.2 peer-group R2_R3_R4
 neighbor 3.3.3.3 remote-as 3
 neighbor 3.3.3.3 peer-group R2_R3_R4
 neighbor 4.4.4.4 remote-as 4
 neighbor 4.4.4.4 peer-group R2_R3_R4
 neighbor 12.0.0.2 remote-as 2
 neighbor 13.0.0.3 remote-as 3
 neighbor 14.0.0.4 remote-as 4

so i went and i removed all of these peer group commands

 neighbor R2_R3_R4 peer-group
 neighbor R2_R3_R4 ebgp-multihop 2
 neighbor R2_R3_R4 update-source Loopback0
 neighbor 2.2.2.2 remote-as 2
 neighbor 2.2.2.2 peer-group R2_R3_R4
 neighbor 3.3.3.3 remote-as 3
 neighbor 3.3.3.3 peer-group R2_R3_R4
 neighbor 4.4.4.4 remote-as 4
 neighbor 4.4.4.4 peer-group R2_R3_R4

and still working . So my question is why do we use peer group when even if we don’t configure it it’s working as well and it didn’t save us some time

Hi Zeko,

I just added the static routes to the post, those are indeed required.

Which exact commands did you remove? Do you still have your final config?

still not working how can they become ebgp nei if R1 using his src ip add as its loopack and R2,R3 n R4 using their src ip add as their physical interfaces …

and by the way u added the static route for R 3 wd wrong next hop maybe
R3(config)#ip route 1.1.1.1 255.255.255.255 192.168.13.3 the next hope must be 192.168.13.1

Hi Zeko,

I see it now, the final configs of R2, R3, and R4 were wrong. They have to use 1.1.1.1 as the destination and source BGP from their own loopbacks. Just fixed this. Sorry for the confusion!

Rene

1 Like

A post was merged into an existing topic: Introduction to BGP

Hello Rene,
I see that the route-map SET_MED is called in the example(BGP Peer Groups Lesson) but it is not configured. I believe that configuration is missing.Also I would like to know what were we trying to achieve with that route-map

R1(config)#router bgp 1
R1(config-router)#neighbor 2.2.2.2 remote-as 2
R1(config-router)#neighbor 3.3.3.3 remote-as 3
R1(config-router)#neighbor 4.4.4.4 remote-as 4
R1(config-router)#neighbor 2.2.2.2 update-source loopback 0
R1(config-router)#neighbor 3.3.3.3 update-source loopback 0
R1(config-router)#neighbor 4.4.4.4 update-source loopback 0
R1(config-router)#neighbor 2.2.2.2 ebgp-multihop 2
R1(config-router)#neighbor 3.3.3.3 ebgp-multihop 2
R1(config-router)#neighbor 4.4.4.4 ebgp-multihop 2
R1(config-router)#neighbor 2.2.2.2 route-map SET_MED out
R1(config-router)#neighbor 3.3.3.3 route-map SET_MED out
R1(config-router)#neighbor 4.4.4.4 route-map SET_MED out

Regards
Shriya

Hi Shriya,

You are right, I didn’t add that route-map which is a bit confusing. I just added it to the lesson.

I’m only using the route-map to show how you can apply a route-map to all neighbors with the peer group.

Rene

Static routes or IGP would suffice

That’s right, an IGP would work but since we use eBGP, it’s unlikely to use :slight_smile:

Is there any possibility to take PDF format of QoS and other items from the site (excluding video) as it would be more useful for us for preparation of exams and perusal

Hi Rene,
Nice explaination,
Just wanted to mention a small typo on the Peer groups name.
it’s not R2-R3 but R2_R3_R4

image

thierry

Thanks Thierry! Just fixed this.

Hi

next-hop-self
R2(config)#ip route 1.1.1.1 255.255.255.255 192.168.12.1
R3(config)#ip route 1.1.1.1 255.255.255.255 192.168.12.1
R4(config)#ip route 1.1.1.1 255.255.255.255 192.168.12.1

we need Next-hop-self command

Hello Bahri

Yes you are correct, that in order for the routes to show up correctly in the various Autonomous Systems, it is necessary to use the next-hop self command. However, for this lesson, the focus was on the BGP peer group mechanism, and for this reason the next-hop self command was not included.

I hope this has been helpful!

Laz

thank you very much your reply

1 Like

Hi Rene/Laz,

Do you recommend to use this particular course (link below) for my CCNP studies or it goes way beyond, and therefore I should just the one mapped to CCNP Route course?

Hello sales2161

The courses on Networklessons are organized by either certification or topic. All the courses that are organized by topic include all of the information for that particular topic that is needed for certifications up to and including CCIE.

If you’re studying specifically for a particular certification, it’s best to use the course of that particular certification. If you just want to learn about a particular topic in depth, then go for the topical courses.

For this particular case, the BGP course goes beyond what is needed for CCNP. If you’re focusing on the CCNP certification, i would recommend using the CCNP courses (ROUTE, SWITCH, TSHOOT) on the site to focus on the required content.

I hope this has been helpful!

Laz

1 Like

it will be possible to use a peer-group for neighbours in different vrfs?
I have to set the same configuration for various neighbours in different vrf.