EIGRP Configuration for CCNA Students

I really like the time you took to explain this to me.
Thank you!!

1 Like

Thanks for letting me know, just fixed this.

I think it should say “No auto-summary is the default”

1 Like

Hello Everyone,

I have configured 2 Routers with 4 parallel links. Each router has a loopback address. I have advertised loopback addresses of the loopbacks in EIGRP. The FD is equal on all the links. I see 4 paths in the routing table of each router for a given loopback address. According to my understanding there should be load balancing between all the 4 links. But I see load balancing between only 2 links. All 4 are not participating in the load balancing.

I have captured the packets on all the 4 links. I see packets are transferred through only 2 links. I am using ping to send the traffic.

Configuration on R1:

router eigrp 1
 maximum-paths 6
 network 1.1.1.1 0.0.0.0
 network 100.10.10.0 0.0.0.255
 network 100.10.20.0 0.0.0.255
 network 100.20.10.0 0.0.0.255
 network 100.100.100.0 0.0.0.255

Configuration on R2.

router eigrp 1
 maximum-paths 6
 network 2.2.2.2 0.0.0.0
 network 100.10.10.0 0.0.0.255
 network 100.10.20.0 0.0.0.255
 network 100.20.10.0 0.0.0.255
 network 100.100.100.0 0.0.0.255

Thanks,
Sachin

Hello Sachin

EIGRP by default supports four equal cost load balancing routes when the metrics are the same. Your configuration should be showing traffic going over all four links. However, keep in mind that depending on how it is configured, the algorithm for load balancing may vary. If process switching is enabled, load balancing is on a per-packet basis. If fast switching is enabled, load balancing is on a per destination basis. This process is described in more detail in the following Cisco documentation which describes load balancing for various dynamic routing protocols:

Some commands that might help you further troubleshoot the issue include the show ip route X.X.X.X Y.Y.Y.Y command where the X and Y placeholders indicate the destination subnet of the load balanced route. The output of this command will show information in the form of:

Route metric is N, traffic share count is M

where N is the metric of the route, and M is the number of packets that have been routed via this particular route. Check out the value of M for each of the routes indicated in the output, and see if the numbers are going up evenly over time.

Also, using ping to test load balancing may not be the best. Ping sends very few packets, so unless you are pinging thousands of packets, the load balancing may not be very efficient. I suggest you try to send some FTP traffic over the links to see if you get a more evenly distributed load balancing.

I hope this has been helpful!

Laz

Hello sir ! let me know about EIGRP protocol what routes will be selected if both routes have same metric value to get the destination.

Hello Fargham

EIGRP is a protocol that can perform Equal Cost Load Balancing (ECLB). If a particular destination has two routes that are learned via EIGRP, both routes will be placed within the routing table, and load balancing will be performed between those two paths by default. EIGRP will load balance up to four equal cost paths by default, but can be configured to load balance between up to 16 equal cost paths.

By default, the load balancing algorithm that will be used works on a per destination basis. This means that one destination IP will be always be routed via the same route. The more destination IP addresses contained within the sum of traffic traversing the router at any one time will result in more effective load balancing. These algorithms can be changed however, to function on a per-packet algorithm if you choose to. More about such load balancing algorithms can be found here:

With EIGRP, it is also possible to load balance between routes that have a different metric value. This is called unequal cost load balancing, and you can find out more about it at the following lesson:

I hope this has been helpful!

Laz

Hi Rene/Laz

In order to set the speed of the R1-R2 link to 10Mb/s I used the bandwidth 10000 command under the interface configuration. A show interface f0/0 on the router then shows BW 10000 Kbit and Full-Duplex, 100Mb/s. My questions are:

  1. Does this mean the interface is actually running at 100Mb/s
  2. in its metric calculation, does EIGRP use the BW figure or the speed (in this case 100) figure?

Thanks,
Phil

Hello Philip

On each interface you can configure speed and bandwidth.

The speed parameter is used to configure an Ethernet interface to function at a particular compatible speed that corresponds to the various types of Ethernet. Specifically, Ethernet, FastEthernet, GigabitEthernet, 10GigEthernet, 40GigEthernet and so on. So the options available for this command depend on the port itself. If it is a GigabitEthernet port, then the options are 10, 100, or 1000 Mbps, as seen below:

Router(config-if)#speed ?
  10    Force 10 Mbps operation
  100   Force 100 Mbps operation
  1000  Force 1000 Mbps operation
  auto  Enable AUTO speed configuration

You also have the option of auto which negotiates the highest commonly supported speed. Now these commands change the actual speed at which a port will function. This in turn will also change the default value of the bandwidth (BW) to the value which corresponds to that speed. Notice below the output of a GigabitEthernet port that has been configured with a speed of 100:

image

The BW, which is in Kbps, is at 100000 which corresponds to 100 Mbps.

Now the BW can be changed from the default value to anything you want within the available range (the range depends on the platform), but such a change will not affect the actual speed of the interface. The BW value only affects the cost that a particular routing protocol will assign to that link.

So to summarize, changing the speed will change the actual physical throughput of an interface, and will also change the default BW value. The BW value can be adjusted to any value, but will not affect the actual throughput of the interface. It will however affect the metric calculation of the routing protocol in operation.

I hope this has been helpful!

Laz

Hi Rene,
In the example in R4 you mention the ip for the L0 4.4.4.0/24 and when you configure in eigrp you wrote “network 4.0.0.0” , so as I understand when we configure the eigrp we have to mention the wild card “network 4.0.0.0 0.0.0.2555” otherwise it will be the default “network 4.0.0.0 0.255.255.255” since it’s class A

Hello Sameh

When configuring the network command for EIGRP, you can either input a particular address without a wildcard mask, or include the wildcard mask. If you don’t include a wildcard mask, the classful subnet will be used. If you do use a wildcard mask, only the networks within the specified range will be used.

In this particular case, the loopback has an IP address of 4.4.4.4 255.255.255.0. In order to specify this network in EIGRP, Rene could have used network 4.4.4.0 0.0.0.255 which would have specified the network exactly. However, he chose to use network 4.0.0.0 which assumes a wildcard mask of 0.255.255.255.

In this particular topology, the result is the same, because the network of the loopback falls into both ranges. However, it would make a difference if there were other Class A networks starting with 4 such as 4.5.0.0/16 or 4.122.15.0/24.

I hope this has been helpful!

Laz

1 Like

Thanks Lazaroz , it’s really helpful answer

1 Like

Hi Laz / Team ,

Question 1:-

Please confirm while check show ip eigrp topology table , we see that there is best and back path to reach a destination Network 4.4.4.0/24 , why it not show back up path for other networks i.e 192.168.24.0/24 & 192.168 .34.0/24 . As in show route table , to reach Network 24 & 34 we only consider next hop ip address 192.168.13.3 , i think it is best path for 4.4.4.0/24 that why it show in routing table for other Network but at the topology table it should be present as a backup path to reach both Network (24 & 34 Network ) vai 12.2 (Back up Next hop ip addesss)

#show ip route eigrp 
     4.0.0.0/24 is sub-netted, 1 sub nets
**D       4.4.4.0 [90/158720] via 192.168.13.3, 00:21:48, Fast Ethernet/0 ( Best path** )
D    192.168.24.0/24 [90/33280] via 192.168.13.3, 00:21:53, Fast Ethernet/0
D    192.168.34.0/24 [90/30720] via 192.168.13.3, 00:21:50, Fast Ethernet 0/0
R1#show ip eigrp topology
IP-EIGRP Topology Table for AS(1)/ID(192.168.12.1)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status

P 4.4.4.0/24, 1 successors, FD is 158720
**via 192.168.13.3 (158720/156160), FastEthernet0/0 (Best Path )**
**via 192.168.12.2 (412160/156160), Ethernet1/0        (Back -path)**

Question 2 -

If a condition is somehow generate that in eigrp network is not decide to find feasible successor then what happen if best path is down ? advertised distance is lower than the feasible distance of the successor (Condition Not Matched to decide Feasible successor because AD > FD of successor )

Question 3 -

As thoroughly read the article , every-time you consider a destination Network (Loopback ) and due to this you analysis change in toplogy and routing table w.r.t to Router . Suppose if we don 't decided a destination in a network then what happen , please let me know

In above figure , please dont consider loopback 4.4.4.0/24 which is directly connected to R4

Question 4:-

In above figure ,I am easily understand to find successor but while deciding Feasible successor


AD is not lower than the FD of succesor ,
My question what it will be shown in topology table and routing table because in route table entry there is only best path which is successor but what will be shown in topology table

Question 5 :-

As we know by default split horizon is enabled due to which routing loop is not created , I want to disbale it and find what changes reflect in topology , routing and debug table . Please share the command and on which interface split horizon should be disabled …I want to apply to disable split horizon on below toplogy and find the changes in network .

Question 6 -

Please confirm is there any possibility that we have only successor entry , suppose , we have 3 path as a best path in toplogy table , then what it will be choose for routing table and if they don’t have any backup (Feasible successor ) ,then what will be shown in both table (topology and routing table ) .

Question 7-

By apply variance command , we want feasible successor reflect in routing table , why others network not shown in toplogy table and routing table .Please explain .

Request you to please a deep context on above question for better understanding.

Thank you
Shivam Chahal

image

Hi Laz ,

I am doing some configuration and disable split horizon on highlighted interfaces after doing this I have check route and topology table w.R.T to router 2 . I analyze and found that there is no change in both table means there is no formation of routing loop but by definition of split-horizon it means no advertize send back where it learn from the interface (directly connected ) . I am disable split horizon to check route loop . Please give me overall picture of disabling split horizonfor better understanding .Why it not affect r.T & t.P .

any scenerio in this topology where by disabling split horizon, we can found changes in both table .

ROUTE TABLE :
image

TOPOLOGY TABLE

image

Case 2-
image

In attached topology , the route table show best path to reach 24 &34 nw via 12.1 &13.4 as next hop address , as by definition route table contain successor as a best path , why topology table not contain feasible successor for 24 & 34 nw , is it because it not fullfill the condition of feasible successor or may be feasible succesor is same for both route please confirm.

D 192.168.24.0/24 [90/30720] via 192.168.12.1, 00:10:44, FastEthernet0/0
D 192.168.34.0/24 [90/30720] via 192.168.13.4, 00:10:44, FastEthernet1/0

But while shutdown the interface of router 2 , this change comes in topology table and route table ,what was the reason behind this any relation to successor or feasible successor

Regards
Shivam Chahal

Hello Shivam,

This happens because these routes probably don’t meet the FS successor rule. If you want to see this in action, take a look at the show ip eigrp topology output on R1 for 192.168.24.0/24 and 192.168.34.0/24.

When there are no feasible successors and the successor route is gone, EIGRP will have to look for a new successor route. It’s the same process as if you look for a successor the first time. It’s best to see this in action. You can try these debug commands and the router will show you its decisions when it looks for a new successor:

  • debug ip eigrp summary
  • debug ip eigrp notifications
  • debug ip routing

Could you elaborate this a bit? I’m not sure I exactly understand what you mean :slight_smile:

In the example above, there is only a successor route. There is no feasible successor because the FD has to be lower than the AD of the successor.

If you want to test this, you can use the same debug commands I mentioned above:

  • debug ip eigrp summary
  • debug ip eigrp notifications
  • debug ip routing

I would try this on a hub and spoke topology though. I have an example for this in the EIGRP troubleshooting lesson. Look for “EIGRP Split Horizon” in that lesson and you’ll find it.

In the topology you mentioned, each router still has a single neighbor per interface. You need to have more than one neighbor per interface.

I would suggest trying this in action as well. Configure two routers with two links in between and advertise a loopback on one router. If the two links have the same metric, you’ll have two successor routes. These two will have the same information in the topology and routing table. If there are no feasible successors, you won’t see them in the topology table but you can see them with the show ip eigrp topology all-links command. This might be helpful.

Hi Lazaros,

For the new CCNA 200-301 how much EIGRP do we need to study. I have learned about its admin cost and super basic configuration, how its metrics work on a basic level and how it appears in a routing table under d. Will that be sufficient for the test? Also, do we need to know about MPLS as well for the test? Just trying to figure out where to focus my time effectively in order to pass then I will come back and learn the more advanced topics

Hi Daniel

The best source to determine what is on the exam is always the official Cisco CCNA blueprint found below:
https://learningnetwork.cisco.com/s/ccna-exam-topics
The interesting thing is that even though dynamic routing protocols are part of the exam, EIGRP doesn’t explicitly appear anywhere on the blueprint! Now that doesn’t mean that it won’t be on the exam, because Cisco always has this disclaimer on the same page:

The following topics are general guidelines for the content likely to be included on the exam. However, other related topics may also appear on any specific delivery of the exam.

Now based on this, EIGRP can indeed appear, but you will definately see more OSPF than EIGRP in the exam, since this protocol is actually referenced.

So to answer your question, yes, I believe that what you described about EIGRP is enough for the exam, but always keep in mind the above thoughts.

As for MPLS, it’s unlikely you will see MPLS on the exam, as it too is not explicitly stated, but there are topics about VPNs and WANs, which are related, so you may find a question concerning concepts, but it is unlikely to see anything with MPLS that has to do with configurations.

I hope this has been helpful!

Laz

Hi Laz,

I really like your very effective lessons, and I am just going through carefully Cisco documentation, which said, " Six different paths configured is the maximum number’; But you just in the above replied post that , “you can configure up to 16 paths into the routing table”. Could the discrepancy be attributable to whether or not you have Per-Destination Load Balancing, or Per-Packet Load Balancing ? Many Thanks, you guys are awesome !!

Hello Jenny

The maximum number of paths when employing load balancing for routing depends firstly on the routing protocol being used. For example:

  • The maximum number of paths that OSPF allows for load balancing is 16.
  • Similarly, the maximum number of paths allowed for EIGRP load balancing is 32.
  • For BGP, it depends on the IOS version, and can be anywhere between 8 paths and 32 paths.

These are the maximum values based on the capabilities of the routing protocols themselves. However, there may be additional limitations that the IOS version and the platforms being used impose on the maximum. I find it strange that this particular Cisco documentation states this limitation of 6 paths because this is not the case. It is actually different for each routing protocol.

The only way to determine the maximum allowed is to actually attempt to configure it in a particular IOS/platform and see what maximum values are allowed to be used.

I’m very happy to hear that you find the site useful! We do our best, and such comments give us the drive to do even better!

I hope this has been helpful!

Laz

1 Like

Thank you Laz, I understand now !!
Things I need to watch out for, when I do purchase for network equipments.

You guys have the incredible abilities to teach newbies … I know who to thank in my CCNA graduation speech :slight_smile:

1 Like