EIGRP Router ID

This topic is to discuss the following lesson:

Great stuff Rene,

This tshoot is the ones to push our hairs out. Is very hard to spot. But on the other hand is very hard for 2 neighbors to have the same ID. But the debug was a Abracadabra on this story. Nice article. Will wait for more on eigrp if there is more. :slight_smile:

Mauro P

Hi Mauro,

This is indeed a pain to troubleshoot, it’s not the first thing you would think of. There’s a small chance that you would encounter this on a production network…it’s a typical troubleshooting scenario for a lab.

More EIGRP material is on the way…

Rene

Hello Rene,

Can you please elaborate, what does this command do

redistribute connected metric 1 1 1 1 1

Hi Sahil,

This redistributes directly connected interfaces into EIGRP. When you configure redistribution, you have to manually configure the metric that you want to use.

These examples might be helpful:

Introduction to redistribution

Redistribution between EIGRP and RIP

Rene

Great lesson. Until now I always assumed that EIGRP router IDs had to be unique.
And that it blocks redistributed routes is something that has to be seen to understand.

Just ran through the lab in GNS 3 and it seams that in IOS 15.x the show ip eigrp events command is no longer “hidden”.

This is why I signed up for this site. “show ip eigrp events” is very useful.
Thanks Rene and Laz for your contents

1 Like

Hi Rene,

I did a Lab, and configured the same Router ID on both routers, I ran “clear ip eigrp neig”, but the srouters continue to learn routes with same router ID in both.

Thx…

Hello Fabio

This is expected behaviour. Like Rene mentioned in the lab, unlike OSPF, EIGRP doesn’t care if it the router ID is the same or not. It will still exchange routes normally and will function correctly.

The only exception to this rule is when we have an external or redistributed route. If R1 for example receives such an external route from R2 (which is running a second routing protocol such as OSPF for example), and if R1 and R2 have the same router ID, only then will R1 reject the route from R2.

I hope this has been helpful!

Laz

Hello @fabio.hperez85, to test the issue of having same router IDs, you can create a loopback1 on R1 and redistribute it into eigrp (not advertising it):

int lo1
ip add 11.11.11.11 255.255.255.0
exit

router eigrp 1
redistribute connected
exit

If you run **show ip route eigrp** on R2, you won’t see this loopback 1 installed.

Hi,

In the lesson, you stated that this issue is seen with redistribution but at lab I used only ‘network 2.2.2.2 0.0.0.0’ not redistribution and R1 again can not learn the route? Can we say when the eigrp router ids’ are same, there is no way to learn a route from the neigbor router?

Router2#sh run | s r ei
router eigrp 12
network 2.2.2.2 0.0.0.0
network 192.168.12.0
eigrp router-id 192.168.12.1
Router2#
Router2#sh ip ei
Router2#sh ip eigrp topo
EIGRP-IPv4 Topology Table for AS(12)/ID(192.168.12.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status

P 192.168.12.0/24, 1 successors, FD is 281600
via Connected, Ethernet0/0
P 2.2.2.0/24, 1 successors, FD is 128256
via Connected, Loopback0

Router1#sh run | s r ei
router eigrp 12
network 192.168.12.0
Router1#
Router1#sh ip ei
Router1#sh ip eigrp topo
EIGRP-IPv4 Topology Table for AS(12)/ID(192.168.12.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status

P 192.168.12.0/24, 1 successors, FD is 281600
via Connected, Ethernet0/0

Router1#
Router1#sh ip rou ei
Router1#sh ip rou eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override

Gateway of last resort is not set

Router1#

regards,

Hello Murat

I believe that the problem here is the wording used. When Rene says that

“…if you don’t have access to the router that is doing the redistribution then you are out of luck.”

he is not referring to redistribution from one routing protocol to another. You are right that there is no redistribution here. What he means here is that if you are not looking at the specific router that is the original source of the information about that particular network, namely 2.2.2.2/32, which redistributes, or informs other routers about its existence, then you are out of luck.

I hope this has been helpful!

Laz