How to configure EIGRP Summarization

Hello Rene,

Can you show us more examples using summarization? it’s an easy topic but I would like to see another scenarios :slight_smile:

Thanks!!!

Hi Diana,

Sure, anything particular you would like to see?

Rene

Hey Rene,

I am alittle confused with summarization over here. So taking your example over here, when we want to summarize subnets we used /23 subnet mask that is shared by all the subnets that we want to summarize and use it on interface level. But in your next lesson “no auto summarization” when we disable the “no auto summarization” we use wild card mask under eigrp configuration, what is the difference, why didn’t we use wild card mask over here ?

Best,

Tooryalai

Hi Tooryalai,

This can be confusing yes. Cisco isn’t very consistent with their usage of wildcards, subnet masks and CIDR notation. Sometimes it doesn’t make much sense :slight_smile:

Rene

Hi Rene,

I have a doubt , how does summarization prevents the SIA issue ?
or in other words how does the neighbor knows not to send the query packet to this neighbor which is summarizing addresses to me !

thanks,

Amit,
Only on the router where the summarization is configured does the Query process stop–not on the router that originates the Query. So for example, if you have three routers A, B, and C with a topology of A—B---C. B has created a summary, say 10.10.0.0/16. Suppose Router A has a route 10.10.10.0/24 that goes active. Router A will still send the Query message to B, but B will see that 10.10.10.0/24 is contained within its own configured summary of 10.10.0.0/16. This will cause Router B to stop propagation of the Query to router C. Additionally, Router B will reply immediately back to A’s Query saying “Unreachable”

Hey,

Has anyone tested this in GNS3?
Can’t seem to get it working

R1
interface Loopback0
 ip address 192.168.1.1 255.255.255.0
!
interface Loopback1
 ip address 192.168.2.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 1.1.1.1 255.255.255.252
 ip summary-address eigrp 1 192.168.0.0 255.255.252.0 5
 duplex auto
 speed auto

router eigrp 1
 network 1.1.1.0 0.0.0.3
 no auto-summary

-

R2
interface FastEthernet0/0
 ip address 1.1.1.2 255.255.255.252
 duplex auto
 speed auto

router eigrp 1
 network 1.1.1.0 0.0.0.3
 no auto-summary

R2#show ip route
     1.0.0.0/30 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, FastEthernet0/0
R2#

Hello Ryan

I notice that in your show IP route command, no EIRGP routes show up. This tells me that for some reason, no EIGRP neighbours have been created. You should at least see the 192.168.1.0 and 192.168.2.0 subnets separately show up. Check the neighbour table to see that they have successfully created an adjacancy. Before you configure any EIGRP summarization, try to get EIGRP alone to function correctly. Then you can add the summarization commands.

I hope this has been helpful.

Laz

If the network is summarized, should not have an A.D of 5 in the neighbor routing table???

Hector,
No, it should not. The Administrative Distance of 5 for an EIGRP summary route is local only on the router that does the summarizing. When that summary is then advertised to a neighbor, the neighbor installs the summary with the regular AD of 90.

Hi Andrew,

Then, based on the exercise, it is in R1 where the route should appear with A.D. of 5.

R1#show ip route eigrp 
     172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
D       172.16.0.0/23 is a summary, 00:01:38, Null0

where we can check the A.D.?? Since it does not appear.

And thanks for ur reply :slight_smile:

Hector,
To check the AD of the route, issue:
#show ip route 172.16.0.0 255.255.254.0

Thanks Andrew! now i see it.

R2#sh ip route 172.16.0.0 255.255.254.0
Routing entry for 172.16.0.0/23
  Known via "eigrp 1", <strong>distance 5</strong>, metric 28160, type internal
  Redistributing via eigrp 1
  Routing Descriptor Blocks:
  * directly connected, via Null0
      Route metric is 28160, traffic share count is 1
      Total delay is 100 microseconds, minimum bandwidth is 100000 Kbit
      Reliability 255/255, minimum MTU 1500 bytes
      Loading 1/255, Hops 0

19 posts were merged into an existing topic: How to configure EIGRP Summarization

Hello Rene,
I did not understand why we used .254.0
is it possible to do another example please?
Thanks in advance.

R1(config)#interface fastEthernet 2/0
R1(config-if)#ip summary-address eigrp 1 172.16.0.0 255.255.254.0

Hi ,
Great explanation . but have one doubt can you explain below subnetting

R1(config)#interface fastEthernet 2/0
R1(config-if)#ip summary-address eigrp 1 172.16.0.0 255.255.254.0

we used /24 on loopback so how did you get this mask /23 by subnetting. can you please explain

We have these two networks:

R2#show ip route eigrp 
     172.16.0.0/24 is subnetted, 2 subnets
D       172.16.0.0 [90/30720] via 192.168.12.1, 00:02:28, FastEthernet0/0
D       172.16.1.0 [90/30720] via 192.168.12.1, 00:02:28, FastEthernet0/0

The most optimal summary rounte for 172.16.0.0/24 and 172.16.1.0/24 is 172.16.0.0/23.

In binary, these two look like this:

* 10101100 00010000 00000000 00000000
* 10101100 00010000 00000001 00000000

Above you can see that the first 23 bits are the same, that’s why we use the /23 summary.

Rene

1 Like

Sorry, I have solved it.

1 Like

Why is the summarisation being applied to int ?fa0/2

Hi Andrew,

In EIGRP, the summary is sent OUTbound on the interface that you configure it on.

Rene