How to configure Frame-Relay Point-to-Point

(Rene Molenaar) #21

You only need the broadcast keyword for frame-relay maps on multipoint interfaces. Point-to-point sub-interfaces don’t need this, they will forward multicast/broadcast traffic on the PVC.

(deep t) #22

which method is more common point to point or point to multi point?

 

would point to point be better, because of different subnets it would not have the split horizon issue?

(Rene Molenaar) #23

Frame relay is quite old so you won’t see it much nowadays.

Point-to-point is your best choice, you don’t have to worry about split horizon and it’s also easier if you want to run OSPF.

(Yoni G) #24

Hi. I’m looking for information on the differences between the LMI types. Can you explain those differences?

One more thing, when i use the “encapsulation frame-relay” command, I have an option to use “ietf”. Please provide more info on that as well.

Thanks.

(Rene Molenaar) #25

Hi Yoni,

There aren’t any major differences between the LMI types. They use some different headers/fields. You can see them here:

LMI Cisco

LMI ANSI

LMI Q933A

By default, your router will automatically select the correct LMI protocol depending on which one it receives from the frame-relay switch so you don’t really have to worry about it.

The encapsulation type is a different story. You need to make sure you configure the correct type yourself. The two headers used some different fields, the Cisco header has some more overhead:

IETF Encapsulation

Cisco Encapsulation

Rene

(oscar s) #26

Hi Rene ,

Why don’t we use the frame-relay map command for point-to-point sub-interfaces ? what will happen if we turn off IARP .? what about the keyword broadcast ?

(Hoan N) #27

can you have lesson how to configure frame relay back to back? I have two Cisco routers 2800 each with a T1 card.

Thank you

(Rene Molenaar) #28

Hi Hoan,

Here’s an example:

R1#show run int s0/0/0
Building configuration...

Current configuration : 141 bytes
!
interface Serial0/0/0
 ip address 192.168.12.1 255.255.255.0
 encapsulation frame-relay
 no keepalive
 frame-relay interface-dlci 201
end
R2#show run int s0/0/0
Building configuration...

Current configuration : 159 bytes
!
interface Serial0/0/0
 ip address 192.168.12.2 255.255.255.0
 encapsulation frame-relay
 no keepalive
 clock rate 64000
 frame-relay interface-dlci 201
end
R1#show frame-relay pvc | include PVC
PVC Statistics for interface Serial0/0/0 (Frame Relay DTE)
DLCI = 201, DLCI USAGE = LOCAL, PVC STATUS = STATIC, INTERFACE = Serial0/0/0
R2#show frame-relay pvc | include PVC
PVC Statistics for interface Serial0/0/0 (Frame Relay DTE)
DLCI = 201, DLCI USAGE = LOCAL, PVC STATUS = STATIC, INTERFACE = Serial0/0/0
R1#ping 192.168.12.2                 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.12.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/32 ms

Rene

(Shantel - Networklessons.com) split this topic #29

19 posts were merged into an existing topic: How to configure Frame-Relay Point-to-Point

(sims) #30

Hi,
We are using the same topology with one difference. Point-to-point links require an IP Subnet per PVC:
Why is that one subnet per pvc ?
Thanks

(Lazaros Agapides) #31

Hello Sims

There are a couple of options for creating a frame relay topology.

If you have multiple sites, you can place all routers from all the sites on one subnet like so:

Notice that all serial interfaces are on the same subnet of 10.1.1.0/24. This topology does not require a separate subnet for each link, but one subnet for all routers. This requires the employment of a static frame relay map to map between a next hop protocol address and a DLCI destination address. This is done using the frame-relay map protocol protocol-address dlci [broadcast] command. Notice the broadcast keyword at the end of the command which indicates that this is a pseudo-broadcast implementation because frame-relay does not natively support broadcasts.

Concerning point to point links in frame relay, each link MUST have a separate subnet. This is the case in the following diagram:

In this case, one subinterface is created for each point to point link and each link between two subinterfaces has a separate subnet. The advantage of this is that routing protocols such as OSPF can function without the need for specialised commands such as removing split-horizon rules and such.

I hope this has been helpful!

Laz

(shiva r) #32

why we need IGP protocols like eigrp and ospf in Frame relay ?

(Rene Molenaar) #33

Hi Shiva,

By default, routers will only know networks on their directly connected interfaces so if you want to reach any other network, you’ll need routing.

For example, let’s say we have a hub and two spoke routers that use a serial 0/0 interface and the 192.168.123.0/24 network.

On the spoke1 router, we also have a Gigabit 0/0 interface with network 192.168.1.0/24. If you want the hub or spoke2 router to reach this network, they’ll need to know how to get there. You can achieve this by configuring a static route on the hub and spoke2 router or you configure a routing protocol to advertise the network.

Rene

(Trust_the P) #34

Hello Rene, I am having issue to set up ospf on my frame relay in GNS3. Below is my configs and topology:

HQ#show run int s2/0
Building configuration...

Current configuration : 263 bytes
!
interface Serial2/0
 ip address 192.168.123.1 255.255.255.0
 encapsulation frame-relay
 ip ospf 1 area 0
 serial restart-delay 0
 frame-relay map ip 192.168.123.3 103 broadcast
 frame-relay map ip 192.168.123.2 102 broadcast
 no frame-relay inverse-arp
 !
end

HQ#show ip protocols
Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 192.168.123.1
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
  Routing on Interfaces Configured Explicitly (Area 0):
    Serial2/0
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 110)

HQ#ping 192.168.123.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.123.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/44/52 ms

Site_2#show run int s2/2
Building configuration...

Current configuration : 215 bytes
!
interface Serial2/2
 ip address 192.168.123.3 255.255.255.0
 encapsulation frame-relay
 ip ospf 1 area 0
 serial restart-delay 0
 frame-relay map ip 192.168.123.1 301 broadcast
 no frame-relay inverse-arp
 !
end

Site_2#show ip protocols
Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 192.168.123.3
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
  Routing on Interfaces Configured Explicitly (Area 0):
    Serial2/2
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 110)

Site_2#ping 192.168.123.1
Sending 5, 100-byte ICMP Echos to 192.168.123.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/51/80 ms
(Lazaros Agapides) #35

Hello sales2161

Frame-relay can be tricky when implemented with OSPF. Can you tell us a little bit more about your configuration? Please specify in more detail the problem that you’re facing so that we can address it more effectively.

Thanks!

Laz

1 Like
(Trust_the P) #37

@lagapides - HQ and Site_2 can’t form adjacencies.

(Trust_the P) #38

Can you please reply to my query? I am still having issues with forming adjacency. Thanks

(Lazaros Agapides) #39

Hello sales2161

If you look at this lesson, you will find information concerning the implementation of OSPF in a frame relay environment:

Now based on your configuration, what I do see immediately is that in your frame relay interfaces, you are missing the ip ospf network broadcast command. This changes the default OSPF network type to allow for broadcasts to be sent over non broadcast topologies such as frame relay and to allow them to create OSPF adjacencies.

Take a look at the lesson and see if this command solves your problem.

I hope this has been helpful!

Laz

1 Like
(Trust_the P) #40

Hello @lagapides, it worked thanks! but I was thinking when we add the “broadcast” keyword at the end of frame-relay mapping, it was going to do the same thing as “ip ospf network broadcast command”?

(Lazaros Agapides) #41

Hello sales2161

In order for OSPF to function, you require the broadcast keyword for both the frame-relay map command and the ip ospf network command. If you don’t do this, you can always make OSPF work by manually configuring the neighbors.

I hope this has been helpful!

Laz

1 Like