How to configure Redistribution between EIGRP and RIP

Hello Sachin,
in your lab redistribution does not work because you are trying to redistribute between different VRFs. If you want redistribution to take place, then routes have to be in same VRF.

If you want to redistribute between VRFs it is called route leaking and you can learn it in this lesson.

https://networklessons.com/mpls/vrf-lite-route-leaking

You can achieve route leaking by using static routes or MP-BGP VPNv4 address-family.

To make you lab work you can apply a bit of configuration on R2.

Create VRFs and configure Route Distinguishers (RD) and Route Targets (RT). RD is used to make routes unique based on VRF they belong to. RT is used to import and export routes with specific extended community tag. These tags are controlled using route-target commands.

vrf definition vrf1
 rd 65000:1
 address-family ipv4
  route-target export 65000:1
  route-target import 65000:2

vrf definition vrf2
 rd 65000:2
 address-family ipv4
  route-target export 65000:2
  route-target import 65000:1  

Create BGP process, give it BGP router-id. Create BGP address-family that belongs to specific VRF and redistribute specific EIGRP AS into it.

router bgp 65000
 bgp router-id 2.2.2.2

 address-family ipv4 vrf vrf1
  redistribute eigrp 1

 address-family ipv4 vrf vrf2
  redistribute eigrp 2

Now you have routes from both VRFs in BGP VPNv4 address family table, you can check it using command “show bgp vpnv4 unicast all”.

Last, but not least, you have to redistribute routes from BGP into EIGRP. In your case it would look like this.

router eigrp 10

 address-family ipv4 vrf vrf1 autonomous-system 1
  redistribute bgp 65000 metric 1000 10 255 1 1500

 address-family ipv4 vrf vrf2 autonomous-system 2
  redistribute bgp 65000 metric 1000 10 255 1 1500

On R1 and R3 you should now see redistributed routes as “D EX”, these are leaked routes from the other VRF.

1 Like

Hello Sachin

@fugazz has got it right. Let me just add that the two options that can be used for route leaking between VRFs involve:

  1. Redistributing static routes from one VRF to the other via the global routing table. This solution avoids the use of BGP.
  2. The use of Multiprotocol BGP (MP-BGP) which essentially allows different address families to be redistributed between VRFs, which is the solution described by @fugazz above.

For an additional solution, take a look at this solution from the Cisco Support community:

I hope this has been helpful!

Laz

1 Like

Hi Guys,

Happy New Year! Quick question… any ideas why the order of K values when setting the EIGRP seed metric doesn’t run in sequential K value order? Seems illogical to me unless there is a reason?

router eigrp 100
default-metric ‘K1’ ‘K3’ ‘K4’ ‘K2’ ‘K5’

K1 - Bandwidth
K2 - Load
K3 - Delay
K4 - Reliability
K5 - MTU

Thanks,

Gareth.

Hello Gareth

That’s an interesting question. After doing some research I was unable to find any information that answers this question. The only thing I can offer as a partial explanation is that by default, K1 and K3 are taken into account while K2, K4, and K5 are not. So having K1 and K3 first, may have something to do with this. Secondly, K4 and K2 are load and reliability, which both are calculated on a scale of 0 to 255 and are seen as values determined within the interface of a network device. The fact that they are similar may have some logic in how they are grouped. Finally, K5 is MTU which is a parameter different from the rest, and is thus put in last.

Note also that in any Cisco IOS command reference, the command parameters are not referred to with their K values but with their names. There doesn’t seem to have been any correlation between the actual order of the K values and the order of the parameters.

Beyond this inference based on the nature of the parameters themselves, I haven’t been able to find any particular reason for the order of entry.

I hope this has been helpful!

Laz

Great answer Laz. I guess it makes sense that the two K values used by default are listed first and second.

It’s interesting to learn about the logic that goes into the design of the software…

Much appreciated!

1 Like