How to configure trunk on Cisco Catalyst Switch

Rene, question, on your last compare example, its static access and static trunk, the result was trunk on both sides, so its a working trunk port? but on your table that you created, the Static Trunk and Static Access has a “Limited” value. care to explain why its Limited? and what does it do on the switch?

Hi John,

When you mix access and trunk mode, we get to see this message:

SwitchA#
%SPANTREE-7-RECV_1Q_NON_TRUNK: Received 802.1Q BPDU on non trunk FastEthernet0/14 VLAN1.
%SPANTREE-7-BLOCK_PORT_TYPE: Blocking FastEthernet0/14 on VLAN0001. Inconsistent port type.
%SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking FastEthernet0/14 on VLAN0001. Port consistency restored.

The trunk will send BPDUs for each VLAN, our access mode interface only sends one BPDU so that’s why CDP reports this error. This won’t be a working trunk but I think the access mode VLAN (VLAN1) will work.

I’d have to give this a try to see if it works.

Rene

Thanks .

It’s awesome.

Rene

how do you turn trunk negotiation back on?

Hi Donald,

“switchport nonegotiate” disabled it and “no switchport nonegotiate” enables it again.

Rene

Hi Rene

Please can you advise what I can do, I am trying to create vlan 50 on this switch and keep getting following

SW1(config)#vlan 50
VTP VLAN configuration not allowed when device is not the primary server for vlan database.
SW1#sh vtp status
VTP Version : 3 (capable)
VTP version running : 3
VTP Domain Name : CCIE-domain
VTP Pruning Mode : Disabled (Operationally Disabled)
VTP Traps Generation : Disabled
Device ID : aabb.cc00.0700

Feature VLAN:
--------------
VTP Operating Mode : Server
Number of existing VLANs : 8
Number of existing extended VLANs : 0
Configuration Revision : 0
Primary ID : 0000.0000.0000
Primary Description :
MD5 digest : 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00
0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00
Feature MST:
--------------
VTP Operating Mode : Transparent
Feature UNKNOWN:
--------------
VTP Operating Mode : Transparent

 

I tried deleting vlan.dat but to no avail

 

Thanks

 

 

 

You are running VTP version 3 but it seems this switch is not the primary switch so you can’t make any changes to the VLAN database. Here’s an example how to configure VTPv3:

Or you can switch back to VTP version 2.

Dear Rene

i’m new here i finished before some week from CCNA I want to study CCNP with you the explanation is very good.this command:

switchport trunk encapsulation dot1q

Is not working in my packet tracer how can I make a switching lab ??

Hi Mohamed,

There are two trunking protocols, 802.1q and ISL. Some newer switches only support 802.1Q and in that case this command will be unavailable.

It’s also possible that packet tracer doesn’t support it, it’s a simulator after all. It doesn’t matter too much though…when this command doesn’t work then the switch will use 802.1Q when you configure the interface as a trunk.

Rene

what type of switches are you suggesting we use

Dear Rene

what about gns3 with IOU and virtual box if I can’t buy real switch?

BR;

Mohamed Khalil

Hi Mohamed,

IOU will work, the L2 image supports most of the switching commands. VLANs and trunking is no problem.

Rene

Hi Jeffery,

I would suggest the Cisco Catalyst 2950, 2960, 3550, 3560 and 3750 switches for CCNA/CCNP. You can find the differences between these switches here:

Recommended lab equipment for CCNA

Cisco CCNP SWITCH Lab Equipment

Rene

Glad you made a video for this topic. Your classes are a life saver.

This was one of the best explanations i saw online! Thanks a lot!

Watching you configure a link with all combinations of access/trunk/dynamic auto/dynamic desirable and fill in the chart was extremely helpful. That chart is a great study tool and reminder, in case I forget. Thanks!

Good to hear it was useful Teressa!

Rene

Hi Rene,

I have 2 doubts:

  1. I tried this on Packet Tracer.

One side of the link between the 2 switches, I set one side as TRUNK and other side as ACCESS.
Wen I do show trunk, it does show me a trunk on one side and not on the other.
Also I didnt see any port inconsistent state message.
What must be the error

  1. If one side is set to manual TRUNK and the other side to AUTO, how does the trunk link even form ? who is sending out negotiation packets in this case ???

Hi Vikas,

If one side is set to trunk and the other as access then you do have a mismatch. It’s possible that packet tracer doesn’t report this, it’s an emulator after all.

Even if you use static trunk or access mode, negotiation still takes place. This is done by DTP. Take a look at this lesson:

Cisco DTP (Dynamic Trunking Protocol)

Rene

Nicholas,
Your left hand side description is correct. Since the incoming tag matches the native vlan of the trunk, the tag gets discarded. I suspect, however, that your scenario would break if you told your switch “switchport trunk native vlan tag” which means that even the native vlan keeps the tag. Since almost all PCs have no idea what a vlan tag is, it would discard the packet.

For your right hand side, I suspect the problem is not knowing what the access port VLAN is for connection from Switch 5 to Switch 6. If it is not vlan 10, this would explain the failure.