Introduction to PPP on Cisco IOS Router

CHAP should be Challenge-Handshake Authentication Protocol, not only Challenge Authentication Protocol as mentioned in the article.

Hello Patrik

Thanks for pointing that out, I’ll let Rene know to make the change…

Laz

I fully agree @patrik.milat. I just fixed this.

Rene

Hello Rene

I have seen below lines in some DSL (PPPoE/PPPoA) configurations:

controller VDSL Slot/Subslot/Port
operating-mode auto
interface ATM Slot/Subslot/Port
no ip address
no atm ilmi-keepalive
no shut
!
interface  ATM Slot/Subslot/Port.Subinterface point-to-point
pvc VPI/VCI
pppoe-client dial-pool-number 1
!
interface Dialer1
ip address negotiated
mtu 1442
encapsulation ppp
dialer pool 1
dialer persistent
ppp authentication pap callin
ppp pap sent-username qwerty password qwerty
ppp chap refuse


Q1. Can you please explain what is the use of controller VDSL command? What is its requirement when we are already configuring the physical interface (ATM).
Q2. If I wish to apply QoS settings on this DSL link, where should the service-policy be attached, Dialer or ATM subinterface?
Q3. The username password for pap in this configuration is not the local username password configured for VTY etc. right?

Hello Payal

The configuration of the controller and the ATM interface are two different things with very different purposes.

The controller vdsl command allows you to enter the VDSL configuration mode. Within this mode you are able to configure various parameters such as the operating mode. The operating mode enables the device to choose what type of VDSL will be used including parameters such as VDSL or VDSL2, or even older ADSL profiles, and what annex will be used. In the above output, it looks like the router is set to automatically negotiate the best possible DSL parameters based on what it detects on the other end.

The ATM interface configuration configures parameters pertaining to the interface itself. Parameters include IP address, and PVC information among others.

Some additional information on these parameters for both VDSL controller and ATM interface configuration can be found here:

There are several ways to achieve this. These include:

Yes, that is correct. the sent-username keyword specifies the username and password to be used for this particular PPP connection.

I hope this has been helpful!

Laz

1 Like

Thanks a lot Laz for your answer. It helped me to understand the concept. I have another query regarding the controller VDSL command. If I wish to remove itsconfiguration and wish to bring to its default state (like ‘default interface ATM 0’ command), the ‘no controller VDSL’ command doesn’t work. Why is that? Is it not necessary? Any work-around?

Hello Payal

The controller vdsl command simply enters the controller configuration mode which looks like this:

router(config-controller)#

The command itself doesn’t actually do anything. Once you’re in controller mode you can then apply controller commands such as operating mode and others.

If you want to revert all controller commands to their defaults, then you should take a look at the running configuration file, and see what commands are under the controller vdsl configuration section. Any commands that you find there, you can simply add no to at the beginning to remove them and revert to the default. Keep in mind that there can be multiple controllers, so there is a controller section in the configuration file for each VDSL controller that has been configured.

I hope this has been helpful!

Laz

Hello community,

i’m new on the group and I already need your Help here is my problem:
I work in service provider and we have access over 4G:
CPE(ISR 1117)–>Box 4G–>mobile network–> LNS entreprise so the goal is to make UP a ppp session over L2TP
Configuration:

vlan 4090
 name BackToBack4G
!
ip vrf 4G
 rd 65000:4090
!
l2tp-class PW
 hostname 3G_DOLMEN
!
pseudowire-class L2TP
 encapsulation l2tpv2
 protocol l2tpv2 PW
 ip local interface Vlan4090
!
default interface GigabitEthernet0/1/1
interface GigabitEthernet0/1/1
 description vers Box 4G
 switchport access vlan 4090
 speed auto
 duplex auto
interface Virtual-PPP1
 ip address negotiated
 ip verify unicast reverse-path
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 no ip virtual-reassembly
 ip mtu 1300
 ip tcp adjust-mss 1200
 load-interval 30
 ppp chap hostname Grrioland.1.015b@acces3g.bytel.dop
 ppp chap password ar7QDn+HN
 ppp ipcp dns request
 pseudowire X.X.X.X 1 encapsulation l2tpv2 pw-class L2TP
 service-policy input WANinQoS
!
interface Vlan4090
 description vers Box 4G
 ip vrf forwarding 4G
 ip address dhcp

ip route X.X.X.X 255.255.255.255 Vlan4090 dhcp

I can ping the LNS (L2TP tunnel end point) but sometimes the ppp session stay down we need to reboot or delete the configuration and put it back.
//////////////////////////////////////////////////////////////////
here is the debug when it work correctly:
000751: *Dec 11 16:31:53.013 GMT: ppp0 PPP: Phase is ESTABLISHING
000752: *Dec 11 16:31:53.013 GMT: Vp1 PPP: Using default call direction
000753: *Dec 11 16:31:53.013 GMT: Vp1 PPP: Treating connection as a dedicated line
000754: *Dec 11 16:31:53.013 GMT: Vp1 PPP: Session handle[6400001C] Session id[0]
000755: *Dec 11 16:31:53.013 GMT: Vp1 LCP: Event[OPEN] State[Initial to Starting]
000756: *Dec 11 16:31:53.014 GMT: Vp1 LCP: O CONFREQ [Starting] id 1 len 10
000757: *Dec 11 16:31:53.014 GMT: Vp1 LCP:    MagicNumber 0x942E0726 (0x0506942E0726)
000758: *Dec 11 16:31:53.014 GMT: Vp1 LCP: Event[UP] State[Starting to REQsent]
000759: *Dec 11 16:31:53.060 GMT: Vp1 LCP: I CONFREQ [REQsent] id 162 len 19
000760: *Dec 11 16:31:53.060 GMT: Vp1 LCP:    MRU 1300 (0x01040514)
000761: *Dec 11 16:31:53.060 GMT: Vp1 LCP:    AuthProto CHAP (0x0305C22305)
000762: *Dec 11 16:31:53.060 GMT: Vp1 LCP:    MagicNumber 0x51E8A97A (0x050651E8A97A)
000763: *Dec 11 16:31:53.060 GMT: Vp1 LCP: O CONFNAK [REQsent] id 162 len 8
000764: *Dec 11 16:31:53.060 GMT: Vp1 LCP:    MRU 1500 (0x010405DC)
000765: *Dec 11 16:31:53.060 GMT: Vp1 LCP: Event[Receive ConfReq-] State[REQsent to REQsent]
000766: *Dec 11 16:31:53.060 GMT: Vp1 LCP: I CONFACK [REQsent] id 1 len 10
000767: *Dec 11 16:31:53.060 GMT: Vp1 LCP:    MagicNumber 0x942E0726 (0x0506942E0726)
000768: *Dec 11 16:31:53.060 GMT: Vp1 LCP: Event[Receive ConfAck] State[REQsent to ACKrcvd]
000769: *Dec 11 16:31:53.090 GMT: Vp1 LCP: I CONFREQ [ACKrcvd] id 163 len 19
000770: *Dec 11 16:31:53.090 GMT: Vp1 LCP:    MRU 1300 (0x01040514)
000771: *Dec 11 16:31:53.090 GMT: Vp1 LCP:    AuthProto CHAP (0x0305C22305)
000772: *Dec 11 16:31:53.090 GMT: Vp1 LCP:    MagicNumber 0x51E8A97A (0x050651E8A97A)
000773: *Dec 11 16:31:53.090 GMT: Vp1 LCP: O CONFNAK [ACKrcvd] id 163 len 8
000774: *Dec 11 16:31:53.090 GMT: Vp1 LCP:    MRU 1500 (0x010405DC)
000775: *Dec 11 16:31:53.090 GMT: Vp1 LCP: Event[Receive ConfReq-] State[ACKrcvd to ACKrcvd]
000776: *Dec 11 16:31:53.121 GMT: Vp1 LCP: I CONFREQ [ACKrcvd] id 164 len 19
000777: *Dec 11 16:31:53.121 GMT: Vp1 LCP:    MRU 1300 (0x01040514)
000778: *Dec 11 16:31:53.121 GMT: Vp1 LCP:    AuthProto CHAP (0x0305C22305)
000779: *Dec 11 16:31:53.121 GMT: Vp1 LCP:    MagicNumber 0x51E8A97A (0x050651E8A97A)
000780: *Dec 11 16:31:53.121 GMT: Vp1 LCP: O CONFNAK [ACKrcvd] id 164 len 8
000781: *Dec 11 16:31:53.121 GMT: Vp1 LCP:    MRU 1500 (0x010405DC)
000782: *Dec 11 16:31:53.121 GMT: Vp1 LCP: Event[Receive ConfReq-] State[ACKrcvd to ACKrcvd]
000783: *Dec 11 16:31:53.160 GMT: Vp1 LCP: I CONFREQ [ACKrcvd] id 165 len 19
000784: *Dec 11 16:31:53.160 GMT: Vp1 LCP:    MRU 1300 (0x01040514)
000785: *Dec 11 16:31:53.160 GMT: Vp1 LCP:    AuthProto CHAP (0x0305C22305)
000786: *Dec 11 16:31:53.160 GMT: Vp1 LCP:    MagicNumber 0x51E8A97A (0x050651E8A97A)
000787: *Dec 11 16:31:53.160 GMT: Vp1 LCP: O CONFNAK [ACKrcvd] id 165 len 8
000788: *Dec 11 16:31:53.160 GMT: Vp1 LCP:    MRU 1500 (0x010405DC)
000789: *Dec 11 16:31:53.160 GMT: Vp1 LCP: Event[Receive ConfReq-] State[ACKrcvd to ACKrcvd]
000790: *Dec 11 16:31:53.191 GMT: Vp1 LCP: I CONFREQ [ACKrcvd] id 166 len 19
000791: *Dec 11 16:31:53.191 GMT: Vp1 LCP:    MRU 1300 (0x01040514)
000792: *Dec 11 16:31:53.191 GMT: Vp1 LCP:    AuthProto CHAP (0x0305C22305)
000793: *Dec 11 16:31:53.191 GMT: Vp1 LCP:    MagicNumber 0x51E8A97A (0x050651E8A97A)
000794: *Dec 11 16:31:53.191 GMT: Vp1 LCP: O CONFNAK [ACKrcvd] id 166 len 8
000795: *Dec 11 16:31:53.192 GMT: Vp1 LCP:    MRU 1500 (0x010405DC)
000796: *Dec 11 16:31:53.192 GMT: Vp1 LCP: Event[Receive ConfReq-] State[ACKrcvd to ACKrcvd]
000797: *Dec 11 16:31:53.230 GMT: Vp1 LCP: I CONFREQ [ACKrcvd] id 167 len 19
000798: *Dec 11 16:31:53.230 GMT: Vp1 LCP:    MRU 1300 (0x01040514)
000799: *Dec 11 16:31:53.230 GMT: Vp1 LCP:    AuthProto CHAP (0x0305C22305)
000800: *Dec 11 16:31:53.230 GMT: Vp1 LCP:    MagicNumber 0x51E8A97A (0x050651E8A97A)
000801: *Dec 11 16:31:53.230 GMT: Vp1 LCP: Sent too many CONFNAKs.  Switch to CONFREJ
000802: *Dec 11 16:31:53.230 GMT: Vp1 LCP: O CONFREJ [ACKrcvd] id 167 len 8
000803: *Dec 11 16:31:53.230 GMT: Vp1 LCP:    MRU 1300 (0x01040514)
000804: *Dec 11 16:31:53.230 GMT: Vp1 LCP: Event[Receive ConfReq-] State[ACKrcvd to ACKrcvd]
000805: *Dec 11 16:31:53.260 GMT: Vp1 LCP: I CONFREQ [ACKrcvd] id 168 len 15
000806: *Dec 11 16:31:53.260 GMT: Vp1 LCP:    AuthProto CHAP (0x0305C22305)
000807: *Dec 11 16:31:53.260 GMT: Vp1 LCP:    MagicNumber 0x51E8A97A (0x050651E8A97A)
000808: *Dec 11 16:31:53.260 GMT: Vp1 LCP: O CONFACK [ACKrcvd] id 168 len 15
000809: *Dec 11 16:31:53.260 GMT: Vp1 LCP:    AuthProto CHAP (0x0305C22305)
000810: *Dec 11 16:31:53.260 GMT: Vp1 LCP:    MagicNumber 0x51E8A97A (0x050651E8A97A)
000811: *Dec 11 16:31:53.260 GMT: Vp1 LCP: Event[Receive ConfReq+] State[ACKrcvd to Open]
000812: *Dec 11 16:31:53.269 GMT: Vp1 PPP: Phase is AUTHENTICATING, by the peer
000813: *Dec 11 16:31:53.269 GMT: Vp1 LCP: State is Open
000814: *Dec 11 16:31:53.290 GMT: Vp1 CHAP: I CHALLENGE id 1 len 55 from "LNE01-TH2"
000815: *Dec 11 16:31:53.290 GMT: Vp1 CHAP: Using hostname from interface CHAP
000816: *Dec 11 16:31:53.290 GMT: Vp1 CHAP: Using password from interface CHAP
000817: *Dec 11 16:31:53.290 GMT: Vp1 CHAP: O RESPONSE id 1 len 55 from "Carriere02.1.005@acces3g.bytel.dop"
000818: *Dec 11 16:31:53.413 GMT: Vp1 CHAP: I SUCCESS id 1 len 31 msg is "CHAP authentication success"
000819: *Dec 11 16:31:53.413 GMT: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-PPP1, changed state to up
000820: *Dec 11 16:31:53.416 GMT: Vp1 PPP: No AAA accounting method list
000821: *Dec 11 16:31:53.416 GMT: Vp1 PPP: Phase is UP
000822: *Dec 11 16:31:53.416 GMT: Vp1 IPCP: Protocol configured, start CP. state[Initial]
000823: *Dec 11 16:31:53.416 GMT: Vp1 IPCP: Event[OPEN] State[Initial to Starting]
000824: *Dec 11 16:31:53.416 GMT: Vp1 IPCP: O CONFREQ [Starting] id 1 len 22
000825: *Dec 11 16:31:53.416 GMT: Vp1 IPCP:    Address 0.0.0.0 (0x030600000000)
000826: *Dec 11 16:31:53.417 GMT: Vp1 IPCP:    PrimaryDNS 0.0.0.0 (0x810600000000)
000827: *Dec 11 16:31:53.417 GMT: Vp1 IPCP:    SecondaryDNS 0.0.0.0 (0x830600000000)
000828: *Dec 11 16:31:53.417 GMT: Vp1 IPCP: Event[UP] State[Starting to REQsent]

//////////////////////////////////////////////////////////////////
Here the debug when it's not working : 
Carriere02.1.005#debug ppp nego
PPP protocol negotiation debugging is on
Carriere02.1.005#
000616: *Dec 11 16:29:47.222 GMT: Vp1 LCP: O CONFREQ [REQsent] id 2 len 10
000617: *Dec 11 16:29:47.222 GMT: Vp1 LCP:    MagicNumber 0x942C13F6 (0x0506942C13F6)
000618: *Dec 11 16:29:47.223 GMT: Vp1 LCP: Event[Timeout+] State[REQsent to REQsent]
000619: *Dec 11 16:29:48.142 GMT: Vp1 LCP: I CONFREQ [REQsent] id 242 len 19
000620: *Dec 11 16:29:48.142 GMT: Vp1 LCP:    MRU 1300 (0x01040514)
000621: *Dec 11 16:29:48.142 GMT: Vp1 LCP:    AuthProto CHAP (0x0305C22305)
000622: *Dec 11 16:29:48.142 GMT: Vp1 LCP:    MagicNumber 0x3271E5EF (0x05063271E5EF)
000623: *Dec 11 16:29:48.142 GMT: Vp1 LCP: O CONFNAK [REQsent] id 242 len 8
Carriere02.1.005#
000624: *Dec 11 16:29:48.142 GMT: Vp1 LCP:    MRU 1500 (0x010405DC)
000625: *Dec 11 16:29:48.142 GMT: Vp1 LCP: Event[Receive ConfReq-] State[REQsent to REQsent]
000626: *Dec 11 16:29:49.238 GMT: Vp1 LCP: O CONFREQ [REQsent] id 3 len 10
000627: *Dec 11 16:29:49.238 GMT: Vp1 LCP:    MagicNumber 0x942C13F6 (0x0506942C13F6)
000628: *Dec 11 16:29:49.238 GMT: Vp1 LCP: Event[Timeout+] State[REQsent to REQsent]
000629: *Dec 11 16:29:51.255 GMT: Vp1 LCP: O CONFREQ [REQsent] id 4 len 10
000630: *Dec 11 16:29:51.255 GMT: Vp1 LCP:    MagicNumber 0x942C13F6 (0x0506942C13F6)
000631: *Dec 11 16:29:51.255 GMT: Vp1 LCP: Event[Timeout+] State[REQsent to REQsent]
000632: *Dec 11 16:29:51.442 GMT: Vp1 LCP: I CONFREQ [REQsent] id 242 len 19
000633: *Dec 11 16:29:51.442 GMT: Vp1 LCP:    MRU 1300 (0x01040514)
000634: *Dec 11 16:29:51.442 GMT: Vp1 LCP:    AuthProto CHAP (0x0305C22305)
000635: *Dec 11 16:29:51.442 GMT: Vp1 LCP:    MagicNumber 0x3271E5EF (0x05063271E5EF)
000636: *Dec 11 16:29:51.442 GMT: Vp1 LCP: O CONFNAK [REQsent] id 242 len 8
000637: *Dec 11 16:29:51.442 GMT: Vp1 LCP:    MRU 1500 (0x010405DC)
000638: *Dec 11 16:29:51.442 GMT: Vp1 LCP: Event[Receive ConfReq-] State[REQsent to REQsent]
000639: *Dec 11 16:29:53.269 GMT: Vp1 LCP: O CONFREQ [REQsent] id 5 len 10
000640: *Dec 11 16:29:53.270 GMT: Vp1 LCP:    MagicNumber 0x942C13F6 (0x0506942C13F6)
000641: *Dec 11 16:29:53.270 GMT: Vp1 LCP: Event[Timeout+] State[REQsent to REQsent]
000642: *Dec 11 16:29:54.543 GMT: Vp1 LCP: I CONFREQ [REQsent] id 242 len 19
000643: *Dec 11 16:29:54.543 GMT: Vp1 LCP:    MRU 1300 (0x01040514)
000644: *Dec 11 16:29:54.543 GMT: Vp1 LCP:    AuthProto CHAP (0x0305C22305)
000645: *Dec 11 16:29:54.543 GMT: Vp1 LCP:    MagicNumber 0x3271E5EF (0x05063271E5EF)
000646: *Dec 11 16:29:54.543 GMT: Vp1 LCP: O CONFNAK [REQsent] id 242 len 8
000647: *Dec 11 16:29:54.543 GMT: Vp1 LCP:    MRU 1500 (0x010405DC)
000648: *Dec 11 16:29:54.543 GMT: Vp1 LCP: Event[Receive ConfReq-] State[REQsent to REQsent]
000649: *Dec 11 16:29:55.285 GMT: Vp1 LCP: O CONFREQ [REQsent] id 6 len 10
000650: *Dec 11 16:29:55.285 GMT: Vp1 LCP:    MagicNumber 0x942C13F6 (0x0506942C13F6)
000651: *Dec 11 16:29:55.285 GMT: Vp1 LCP: Event[Timeout+] State[REQsent to REQsent]
000652: *Dec 11 16:29:57.301 GMT: Vp1 LCP: O CONFREQ [REQsent] id 7 len 10
000653: *Dec 11 16:29:57.301 GMT: Vp1 LCP:    MagicNumber 0x942C13F6 (0x0506942C13F6)
000654: *Dec 11 16:29:57.301 GMT: Vp1 LCP: Event[Timeout+] State[REQsent to REQsent]
000655: *Dec 11 16:29:57.541 GMT: Vp1 LCP: I CONFREQ [REQsent] id 242 len 19
000656: *Dec 11 16:29:57.542 GMT: Vp1 LCP:    MRU 1300 (0x01040514)
000657: *Dec 11 16:29:57.542 GMT: Vp1 LCP:    AuthProto CHAP (0x0305C22305)
000658: *Dec 11 16:29:57.542 GMT: Vp1 LCP:    MagicNumber 0x3271E5EF (0x05063271E5EF)
000659: *Dec 11 16:29:57.542 GMT: Vp1 LCP: O CONFNAK [REQsent] id 242 len 8
000660: *Dec 11 16:29:57.542 GMT: Vp1 LCP:    MRU 1500 (0x010405DC)
000661: *Dec 11 16:29:57.542 GMT: Vp1 LCP: Event[Receive ConfReq-] State[REQsent to REQsent]
000662: *Dec 11 16:29:59.315 GMT: Vp1 LCP: O CONFREQ [REQsent] id 8 len 10
000663: *Dec 11 16:29:59.315 GMT: Vp1 LCP:    MagicNumber 0x942C13F6 (0x0506942C13F6)
000664: *Dec 11 16:29:59.315 GMT: Vp1 LCP: Event[Timeout+] State[REQsent to REQsent]
000665: *Dec 11 16:30:00.541 GMT: Vp1 LCP: I CONFREQ [REQsent] id 242 len 19
000666: *Dec 11 16:30:00.542 GMT: Vp1 LCP:    MRU 1300 (0x01040514)
000667: *Dec 11 16:30:00.542 GMT: Vp1 LCP:    AuthProto CHAP (0x0305C22305)
000668: *Dec 11 16:30:00.542 GMT: Vp1 LCP:    MagicNumber 0x3271E5EF (0x05063271E5EF)
000669: *Dec 11 16:30:00.542 GMT: Vp1 LCP: Sent too many CONFNAKs.  Switch to CONFREJ
000670: *Dec 11 16:30:00.542 GMT: Vp1 LCP: O CONFREJ [REQsent] id 242 len 8
000671: *Dec 11 16:30:00.542 GMT: Vp1 LCP:    MRU 1300 (0x01040514)
000672: *Dec 11 16:30:00.542 GMT: Vp1 LCP: Event[Receive ConfReq-] State[REQsent to REQsent]
000673: *Dec 11 16:30:01.334 GMT: Vp1 LCP: O CONFREQ [REQsent] id 9 len 10
000674: *Dec 11 16:30:01.334 GMT: Vp1 LCP:    MagicNumber 0x942C13F6 (0x0506942C13F6)
000675: *Dec 11 16:30:01.334 GMT: Vp1 LCP: Event[Timeout+] State[REQsent to REQsent]
000676: *Dec 11 16:30:03.349 GMT: Vp1 LCP: O CONFREQ [REQsent] id 10 len 10
000677: *Dec 11 16:30:03.349 GMT: Vp1 LCP:    MagicNumber 0x942C13F6 (0x0506942C13F6)
000678: *Dec 11 16:30:03.349 GMT: Vp1 LCP: Event[Timeout+] State[REQsent to REQsent]
000679: *Dec 11 16:30:03.741 GMT: Vp1 LCP: I CONFREQ [REQsent] id 242 len 19
000680: *Dec 11 16:30:03.741 GMT: Vp1 LCP:    MRU 1300 (0x01040514)
000681: *Dec 11 16:30:03.742 GMT: Vp1 LCP:    AuthProto CHAP (0x0305C22305)
000682: *Dec 11 16:30:03.742 GMT: Vp1 LCP:    MagicNumber 0x3271E5EF (0x05063271E5EF)
000683: *Dec 11 16:30:03.742 GMT: Vp1 LCP: Sent too many CONFNAKs.  Switch to CONFREJ
000684: *Dec 11 16:30:03.742 GMT: Vp1 LCP: O CONFREJ [REQsent] id 242 len 8
000685: *Dec 11 16:30:03.742 GMT: Vp1 LCP:    MRU 1300 (0x01040514)
000686: *Dec 11 16:30:03.742 GMT: Vp1 LCP: Event[Receive ConfReq-] State[REQsent to REQsent]
000687: *Dec 11 16:30:05.364 GMT: Vp1 PPP DISC: LCP failed to negotiate
000688: *Dec 11 16:30:05.364 GMT: Vp1 PPP: Sending Acct Event[Down] id[26]
000689: *Dec 11 16:30:05.364 GMT: PPP: NET STOP send to AAA.
000690: *Dec 11 16:30:05.365 GMT: Vp1 LCP: Event[Timeout-] State[REQsent to Stopped]
000691: *Dec 11 16:30:05.365 GMT: Vp1 LCP: Event[DOWN] State[Stopped to Starting]
000692: *Dec 11 16:30:05.365 GMT: Vp1 PPP: Phase is DOWN
000693: *Dec 11 16:30:10.099 GMT: PPP: Alloc Context [7F5AB5B680]
000694: *Dec 11 16:30:10.099 GMT: ppp0 PPP: Phase is ESTABLISHING
000695: *Dec 11 16:30:10.100 GMT: Vp1 PPP: Using default call direction
000696: *Dec 11 16:30:10.100 GMT: Vp1 PPP: Treating connection as a dedicated line
000697: *Dec 11 16:30:10.100 GMT: Vp1 PPP: Session handle[1900001B] Session id[0]
000698: *Dec 11 16:30:10.100 GMT: Vp1 LCP: Event[OPEN] State[Initial to Starting]
000699: *Dec 11 16:30:10.100 GMT: Vp1 LCP: O CONFREQ [Starting] id 1 len 10
000700: *Dec 11 16:30:10.100 GMT: Vp1 LCP:    MagicNumber 0x942C7522 (0x0506942C7522)
000701: *Dec 11 16:30:10.101 GMT: Vp1 LCP: Event[UP] State[Starting to REQsent]
000702: *Dec 11 16:30:10.141 GMT: Vp1 LCP: I CONFREQ [REQsent] id 161 len 19
000703: *Dec 11 16:30:10.141 GMT: Vp1 LCP:    MRU 1300 (0x01040514)
000704: *Dec 11 16:30:10.141 GMT: Vp1 LCP:    AuthProto CHAP (0x0305C22305)
000705: *Dec 11 16:30:10.141 GMT: Vp1 LCP:    MagicNumber 0x5F32F19E (0x05065F32F19E)
000706: *Dec 11 16:30:10.142 GMT: Vp1 LCP: O CONFNAK [REQsent] id 161 len 8
000707: *Dec 11 16:30:10.142 GMT: Vp1 LCP:    MRU 1500 (0x010405DC)
000708: *Dec 11 16:30:10.142 GMT: Vp1 LCP: Event[Receive ConfReq-] State[REQsent to REQsent]
000709: *Dec 11 16:30:12.118 GMT: Vp1 LCP: O CONFREQ [REQsent] id 2 len 10
000710: *Dec 11 16:30:12.118 GMT: Vp1 LCP:    MagicNumber 0x942C7522 (0x0506942C7522)
000711: *Dec 11 16:30:12.118 GMT: Vp1 LCP: Event[Timeout+] State[REQsent to REQsent]
000712: *Dec 11 16:30:14.135 GMT: Vp1 LCP: O CONFREQ [REQsent] id 3 len 10
000713: *Dec 11 16:30:14.135 GMT: Vp1 LCP:    MagicNumber 0x942C7522 (0x0506942C7522)

thank you for your help

Hello Mustapha

After consulting with @ReneMolenaar on this, I have the following answer to give you. This process has to do with the PPP negotiation itself. You can use this Cisco documentation to help you in understanding the PPP messages you see here:

Understanding debug ppp negotiation Output

Now from your output you can see that the local router receives a configure request (CONFREQ) message requesting specific configuration options:

000619: *Dec 11 16:29:48.142 GMT: Vp1 LCP: I CONFREQ [REQsent] id 242 len 19
000620: *Dec 11 16:29:48.142 GMT: Vp1 LCP: MRU 1300 (0x01040514)
000621: *Dec 11 16:29:48.142 GMT: Vp1 LCP: AuthProto CHAP (0x0305C22305)

The “I” in the first line indicates that this line is INPUT (incoming request) and the two lines below are the options the remote router wants to use. It is using an MRU of 1300 and CHAP for authentication.

Now we see this router responding like so:

000623: *Dec 11 16:29:48.142 GMT: Vp1 LCP: O CONFNAK [REQsent] id 242 len 8 Carriere02.1.005#
000624: *Dec 11 16:29:48.142 GMT: Vp1 LCP: MRU 1500 (0x010405DC)
000625: *Dec 11 16:29:48.142 GMT: Vp1 LCP: Event[Receive ConfReq-] State[REQsent to REQsent]

The “O” in the first line shows that it is OUTPUT (an outgoing response) and it is sending a CONFNAK (acknowledgement) with some more information below. Specifically, it says it has an MRU of 1500. This is a mismatch.

So this happens several times, and then the routers give up, and the negotiation fails.

Looking over the above document will help you to more readily identify the relevant debug output.

I hope this has been helpful!

Laz