Introduction to Redistribution

Hi,
What does it mean “Redistribution happens outbound.”
Thanks

Hi Sims,

This means that when you configure redistribution on a router, it doesn’t change the routing table of router itself. The only thing that changes are the routing updates that the router sends to its neighbors.

Rene

Redistribution also adds another problem. If you “import” routing information from one routing protocol into another it’s possible to create routing loops.
could you pls provide insight about routing loops in case of above sceanrio?

Hello Prem.

Although it is possible to create a routing loop in the topology described in Rene’s lesson, let’s look at a simpler scenario to understand how a routing look can occur with redistribution.

Let’s say that we have two different routing protocols running on a network. One region of the network is using OSPF and the other RIP. Let’s say that there are two redistribution points, that is, two connections between the OSPF area and the RIP domain (for lack of a better term). So let’s say we have mutual redistribution (in both directions) at both redistribution points. If you left the network like this, you would create a routing loop, since both redistribution points will have multiple routes for the same networks, and install the OSPF route in the routing table since it has the lower AD. So if RP1 wants to send a packet to the RIP network, it will look in its routing table, and obviously choose the OSPF External route since it should be the only one installed in the routing
table (because OSPF has a lower AD than RIP), and forward it to RP2. RP2 would do the same, and forward it back to RP1, hence creating a routing loop.

In order to resolve such issues, we have to tweak the Administrative Distance in such a way so that loops would be eliminated.

I hope this has been helpful!

Laz

Hi Lazaros,
When we do redistribution from Eigrp to OSPF vice versa, which exactly routes are advertised, the best routes in routing table it self OR all routes of EIGRP (or OSPF) before comparing the Admin Distance between different Protocols in routing table.?

Hello Mahmoud

This is a very good question and it shows that you’re thinking analytically about routing and redistribution in particular!

First of all it is important to note that the routing table is itself a compilation of the best route to each destination. The routing table does not have more than one route for each destination unless the metric is exactly the same. So in essence, there is no such thing as “the best routes in the routing table” since by definition, the best route for each destination is listed there.

Secondly, when redistribution between one routing protocol and another occurs, say from EIGRP to OSPF, it occurs within one device, that is, the router which has one interface participating in EIGRP and another interface participating in OSPF. Within this router, EIGRP informs OSPF how network A.B.C.0 can be reached. The OSPF process informs other routers in the OSPF area using the OSPF mechanisms and indicates that this router was learned from an external source with the appropriate code in the routing table. The OSPF routers create their routing tables accordingly.

Now if there is a case where one destination can be reached using two different routing protocols, and thus using two different administrative distances, then the route with the smallest administrative distance will be intalled into the routing table. The other will be rejected.

I hope this has been helpful!

Laz

Lazaros,
Many thanks for your usual support

1 Like

Hello! I have a question. How to need redistribution connected networks in OSPF “best practices”? Across

network X.X.X.X X.X.X.X area 0

or

redistribute connected subnets

Hello Aleksandr

If I have understood your question correctly, you are asking what is the best practice to redistribute connected networks in OSPF to other AS’s that are running different routing protocols.

The two commands that you mention in your post provide two different functionalities and are not two different ways of achieving the same thing.

The first command network X.X.X.X. X.X.X.X area 0 is a command that just indicates that you want the specific network, which is directly connected to one of the interfaces of the router, to participate in OSPF. The information concerning this network will be shared within the OSPF AS. Without additional configurations, Information about this network will NOT be shared with other routing protocols in other AS’s.

In order to share this information with routers in other AS’s that are running other routing protocols, it is necessary to indicate this using the redistribute command. Specifically, using the command you stated in your post, the following would occur:

* The router redistributes all connected routes that are subnetted to external AS’s
* The connected keyword refers to routes that are established automatically by virtue of having enabled IP on an interface.

I hope this has been helpful!

Laz

Thanks for the answer. But I had in mind the situation when i redistribute to inter network area0. And I can redistribute whith command

network x.x.x.x x.x.x.x area0

or

redistribute connected subnets

But how more correctly?

Hello Aleksandr

The term redistribution is used to describe the mechanism by which network routes are distributed from one dynamic routing protocol to another. Redistribution is not when OSPF routes are learned from one OSPF area to another. Routes from one OSPF area to another are handled by the ABR by using LSA Type 3 packets which are summaries of networks found within each area. These summaries get advertised by default without any additional configuration.

Having said that, again, the two commands you mention about have two different functions.

The first command network X.X.X.X. X.X.X.X area 0 is a command that just indicates that you want the specific network, which is directly connected to one of the interfaces of the router, to participate in OSPF. The information concerning this network will be shared within the OSPF area. This will also automatically be shared with other OSPF areas via the ABRs that exist between OSPF areas using Type 3 LSAs but not with any other routing protocol.

The second command redistributes routes that are directly connected to router to other routing protocols.

Again, specifically using the command you stated in your post, the following would occur:

* The router redistributes all connected routes that are subnetted to external AS’s
* The connected keyword refers to routes that are established automatically by virtue of having enabled IP on an interface.

I hope this has been helpful!

Laz

Hi Sir,

i think i found one more typo error, R2 rip info must be sent to R1.

R2 will redistribute EIGRP routing information into RIP and advertise it to R3.
R2 will redistribute RIP routing information into EIGRP and advertise it to R3.

Regards
Subrahmanya

Hello Subbu

Yes you are correct, that should read “and advertise it to R1.” not R3.

I will let @ReneMolenaar know to change it.

Thanks very much!

Laz

Thanks for letting me know, just fixed this typo.

Hi Rene,

Would it be correct to say that we should only redistribute between 2 routing protocols in a given network at only 1 router in order to avoid creating loops?

Hi Waleed,

That would prevent routes from looping around but it also means you have a single point of failure. Redistribution on two routers is no problem but you have to understand and deal with potential issues. For example, take a look at route tagging:

Rene

1 Like

Hello Rene/Laz,
I have a question and I am going to use the below topology as a reference of my question.

As you see in the topology, Two different routing protocols are running in this network(EIGRP & BGP). R2 is running both protocols as it is shown in the diagram. If mutual redistribution is done at R2 between EIGRP and BGP, R2 will take all the routes from EIGRP and inject it in BGP and also take all the routes from BGP and inject it into EIGRP. Based upon this statement, R1 is not supposed to see any routing entry for 10.10.10.0 /24. In another words, R2 is not supposed to inject 10.10.10.0 /24 route into BGP because R2 does not have 10.10.10.0 /24 route listed as EIGRP route in its routing table. Instead, R2 will have a routing entry for 10.10.10.0 /24 as a directly connected link. Now R1’s routing table does have a routing entry for 10.10.10.0 /24 that it is learning from BGP which means R2 is indeed injecting 10.10.10.0 /24 network into BGP. Would you please let me know why R2 is injecting 10.10.10.0 /24 into BGP even though it is not an EIGRP route?

Thanks a lot.

Azm

Hello Azm

I don’t see why this statement is true. Actually, R1 will see the 10.10.10.0/24 network in it’s routing table. This is because, as you stated, R2 redistributes all of its BGP routes into EIGRP, so R2 will share this route with R1 through redistribution.

It is true that R2’s interface on the 10.10.10.0/24 network does not participate in EIGRP, but it is being redistributed into EIGRP. Remember that BGP will place in the BGP table any route that already exists in the routing table. This is a prerequisite for BGP. Since 10.10.10.0/24 is a directly connected route, it is in the routing table, thus it will be in the BGP table, and will be redistributed to EIGRP and thus it will reach R1.

I hope this has been helpful!

Laz

Good Evening

NetworkLessons team,

I have a big question and I was reviewing all the material related to it, but I could not find my answer, I am assuming that is related to TTL (EIGRP/RIP)

Example :
I have 3 EIGRP AS and I want to redistribute all of them in ONLY one (EIGRP AS 100) to make it like main and needs to redistributed all the routes learned from each AS and Its static route as well like you can see below.

Router1:

 router eigrp 200
 network 2.2.2.1 0.0.0.0
 redistribute static

Router2:

 router eigrp 300
 network 3.3.3.1 0.0.0.0
 redistribute static

Router3:---------------------------------> MAIN (BACKBONE)

router eigrp 100 
 network 1.1.1.2 0.0.0.0
 redistribute eigrp 200
 redistribute eigrp 300
 redistribute static
!
 router eigrp 200
 network 2.2.2.2 0.0.0.0
 redistribute eigrp 100
!
 router eigrp 300
 network 3.3.3.2 0.0.0.0
 redistribute eigrp 100

Router4:

 router eigrp 100
 network 1.1.1.1 0.0.0.0
 redistribute static

in conclusion router4 can see all the routes from router1, router2 and router3, but router1 and router2 can’t see the static routes redistributed in AS100

Thanks

Hello Ricardo

I tried labbing up your topology and I found that with your configurations, R4 is able to see the directly connected networks on R1 and R2, and both R1 and R2 are able to see the directly connected networks on R4. What I did find was that R2 was not able to see R1’s directly connected routes until the redistribute static command was also applied to the EIGRP 100 configuration in R3, and visa versa for R1.

I suggest you troubleshoot by looking at the EIGRP topologies in each router, and perform a debug to see what EIGRP routes are being exchanged, in order to determine why you don’t see the routes appearing in R1 and R2.

I hope this has been helpful!

Laz