IS-IS Redistribution

(Rene Molenaar) #1

This topic is to discuss the following lesson:

1 Like

(Mohammad Hasanuz Zaman) #3

Hi Rene,
Is there any rule to connected other Routing protocol or we can do redistribution any where suppose L1/L2 or L1-L2 Router?? Thanks

br//zaman

0 Likes

(Rene Molenaar) #4

Hi Zaman,

Not really, when you redistribute something into IS-IS you can do it on any router and redistribute into L1, L2 or both L1 and L2.

Rene

0 Likes

(Mohammad Hasanuz Zaman) #5

Hi Rene,
I have set up a LAB with multiple ISIS Instance/TAG . Then Redistribute those Instances with each other using Route-Map matching Loopback IP’s and TAG value. But I am not getting 2.2.2.2/32 prefix from R1 and 4.4.4.4/32, 44.44.44.44/32 prefix from R3 whether I configured Instance Redistribution on R2 and R4 .Please check the topology & Configuration attached.ISIS config !!.txt (3.5 KB)
ISIS%20Topo%20!! Thanks

BR//ZAMAN

0 Likes

(Rene Molenaar) #6

Hello Zaman,

If you lab up something like this, first try the basic redistribution commands without route-maps or tags (maybe you did).

I labbed up redistribution between IS-IS processes on IOSv (Cisco VIRL) but whatever I tried, it was impossible to redistribute routes from one process into another. Maybe it’s related to Cisco IOS or the version that I used. The commands are accepted but it doesn’t redistribute anything.

On IOS XR, it works. Here’s a working configuration for three routers connected like this:

R1-R2-R3

hostname R1
!
interface GigabitEthernet0/0/0/0
 ipv4 address 192.168.12.1 255.255.255.0
!
router isis AREA12
 is-type level-2-only
 net 49.0012.0000.0000.0001.00
 log adjacency changes
 interface GigabitEthernet0/0/0/0
  address-family ipv4 unicast
  !
end
hostname R2
!
interface GigabitEthernet0/0/0/0
 ipv4 address 192.168.12.2 255.255.255.0
!
interface GigabitEthernet0/0/0/1
 ipv4 address 192.168.23.2 255.255.255.0
!
router isis AREA12
 is-type level-2-only
 net 49.0012.0000.0000.0002.00
 log adjacency changes
 address-family ipv4 unicast
  redistribute isis AREA23 metric 10
 !
 interface GigabitEthernet0/0/0/0
  address-family ipv4 unicast
!
router isis AREA23
 is-type level-2-only
 net 49.0023.0000.0000.0002.00
 log adjacency changes
 interface GigabitEthernet0/0/0/1
  address-family ipv4 unicast
!
end
hostname R3
interface Loopback0
 ipv4 address 3.3.3.3 255.255.255.255
!
interface GigabitEthernet0/0/0/0
 ipv4 address 192.168.23.3 255.255.255.0
!
router isis AREA23
 is-type level-2-only
 net 49.0023.0000.0000.003.00
 log adjacency changes
 interface Loopback0
  address-family ipv4 unicast
 !
 interface GigabitEthernet0/0/0/0
  address-family ipv4 unicast
  !
end

This redistributes the 3.3.3.3/32 and 192.168.23.0/24 prefixes from one process into another on R2.

RP/0/0/CPU0:R1#show ip route isis
Fri Mar  1 09:22:17.082 UTC

i L2 3.3.3.3/32 [115/20] via 192.168.12.2, 00:04:41, GigabitEthernet0/0/0/0
i L2 192.168.23.0/24 [115/20] via 192.168.12.2, 00:04:41, GigabitEthernet0/0/0/0

Hope this helps. You can add the route-maps / tags to this if needed.

Rene

0 Likes

(Mohammad Hasanuz Zaman) #7

Hi,
Thanks Rene for your valuable input . In My LAB Only local connected (Loopback) prefix will not distributed But others prefix distributed fine . In R2 , when redistributed (24 to AREA12) to AREA12 , only 2.2.2.2/32 prefix not come to AREA12 but all others prefix (3.3.3.3/32 ; 4.4.4.4/32) redistributed fine . See the output below :

R1#show ip route 
Gateway of last resort is not set

 1.0.0.0/32 is subnetted, 1 subnets
C        1.1.1.1 is directly connected, Loopback0
      3.0.0.0/32 is subnetted, 1 subnets
**i L2     3.3.3.3 [115/30] via 192.168.12.2, 00:00:48, FastEthernet0/0**
      4.0.0.0/32 is subnetted, 1 subnets
**i L2     4.4.4.4 [115/30] via 192.168.12.2, 00:00:48, FastEthernet0/0**
      192.168.12.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.12.0/24 is directly connected, FastEthernet0/0
L        192.168.12.1/32 is directly connected, FastEthernet0/0 

Only 2.2.2.2/32 not coming .

As per your observation Multi process ISIS , redistribution with Route-map between Process will works fine , right ??

One More query , A process must have One NET address and NET address should be Unique . Here In your configuration on R2 you used net 49.0012.0000.0000.0002.00 & net 49.0023.0000.0000.0002.00 for two process (24 & area23) but In both the sysID (0000.0000.0002) is same . When I tried to configure like this I am getting a error and can’t configure …
%CLNS: Duplicate system ID configured in ip vrf with router isis 24

Please help to know about the issue .Thanks

BR//ZAMAN

0 Likes

(Rene Molenaar) #8

Hi Zaman,

That’s interesting. What IOS version did you use? Whatever I did on IOS 15 in VIRL, I couldn’t get anything distributed :grin:

If you remove the route-maps and redistribute everything, does your 2.2.2.2/32 prefix show up? Is 2.2.2.2/32 in the IS-IS database on R2?

I had the same error on IOS but on IOS XR this is accepted. It seems the implementation of IS-IS on IOS and IOS XR is slightly different.

0 Likes