Thank you. I review my configuration. I did not use two ports that are close to each other (ex:gi1/1 gi1/2). I used gi1/1 and gi0/2. Will that make a difference on real equipment? I am using EVE-NG
Hello David
There is no restriction in using interfaces that are non-sequential. As long as the interfaces are on the same physical device, youâre fine. If the interfaces belong to different physical switches that are stacked or are using some other redundancy feature such as VSS, then you will have to make sure that the platform supports multi-chassis etherchannel.
I hope this has been helpful!
Laz
I have tried the L3 Etherchannel lab on EVE-ng. verified configs on both switches I canât ping between the 2 switches
Cisco IOS Software, vios_l2 Software (vios_l2-ADVENTERPRISEK9-M), Version 15.2(4.0.55)E, TEST ENGINEERING ESTG_WEEKLY BUILD, synced to END_OF_FLO_ISP
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2015 by Cisco Systems, Inc.
Compiled Tue 28-Jul-15 18:52 by sasyamal.
But the same configs work fine on Catalyst 3750-X.
Sometimes these network emulators donât work as intended
Current configuration : 2875 bytes
!
! Last configuration change at 14:48:45 UTC Mon Sep 27 2021
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname sw1
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
ip cef
no ipv6 cef
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
!
interface Port-channel1
no switchport
ip address 192.168.1.1 255.255.255.0
!
interface GigabitEthernet0/2
media-type rj45
negotiation auto
!
interface GigabitEthernet0/3
media-type rj45
negotiation auto
!
interface GigabitEthernet0/0
no switchport
no ip address
negotiation auto
channel-group 1 mode on
!
interface GigabitEthernet0/1
no switchport
no ip address
negotiation auto
channel-group 1 mode on
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end
sw1#sh etherchannel port-channel
Channel-group listing:
----------------------
Group: 1
----------
Port-channels in the group:
---------------------------
Port-channel: Po1
------------
Age of the Port-channel = 0d:00h:03m:05s
Logical slot/port = 16/0 Number of ports = 2
GC = 0x00000000 HotStandBy port = null
Passive port list = Gi0/0 Gi0/1
Port state = Port-channel L3-Ag Ag-Inuse
Protocol = -
Port security = Disabled
Ports in the Port-channel:
Index Load Port EC state No of bits
------+------+------+------------------+-----------
0 00 Gi0/0 On 0
0 00 Gi0/1 On 0
Time since last port bundled: 0d:00h:03m:04s Gi0/1
sw1#sh ip int br
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/2 unassigned YES unset up up
GigabitEthernet0/3 unassigned YES unset up up
GigabitEthernet0/0 unassigned YES manual up up
GigabitEthernet0/1 unassigned YES manual up up
Port-channel1 192.168.1.1 YES NVRAM up up
sw1#ping 192.168.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
///////////////////////////////////////////////////////////////////////////////
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname sw2
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
ip cef
no ipv6 cef
!
!
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
interface Port-channel1
no switchport
ip address 192.168.1.2 255.255.255.0
!
interface GigabitEthernet0/2
media-type rj45
negotiation auto
!
interface GigabitEthernet0/3
media-type rj45
negotiation auto
!
interface GigabitEthernet0/0
no switchport
no ip address
negotiation auto
channel-group 1 mode on
!
interface GigabitEthernet0/1
no switchport
no ip address
negotiation auto
channel-group 1 mode on
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end
sw2#sh etherchannel port-channel
Channel-group listing:
----------------------
Group: 1
----------
Port-channels in the group:
---------------------------
Port-channel: Po1
------------
Age of the Port-channel = 0d:00h:06m:28s
Logical slot/port = 16/0 Number of ports = 2
GC = 0x00000000 HotStandBy port = null
Passive port list = Gi0/0 Gi0/1
Port state = Port-channel L3-Ag Ag-Inuse
Protocol = -
Port security = Disabled
Ports in the Port-channel:
Index Load Port EC state No of bits
------+------+------+------------------+-----------
0 00 Gi0/0 On 0
0 00 Gi0/1 On 0
Time since last port bundled: 0d:00h:06m:27s Gi0/1
sw2#sh etherchannel port-channel
Channel-group listing:
----------------------
Group: 1
----------
Port-channels in the group:
---------------------------
Port-channel: Po1
------------
Age of the Port-channel = 0d:00h:06m:28s
Logical slot/port = 16/0 Number of ports = 2
GC = 0x00000000 HotStandBy port = null
Passive port list = Gi0/0 Gi0/1
Port state = Port-channel L3-Ag Ag-Inuse
Protocol = -
Port security = Disabled
Ports in the Port-channel:
Index Load Port EC state No of bits
------+------+------+------------------+-----------
0 00 Gi0/0 On 0
0 00 Gi0/1 On 0
Time since last port bundled: 0d:00h:06m:27s Gi0/1
sw2#sh ip int br
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/2 unassigned YES unset up up
GigabitEthernet0/3 unassigned YES unset up up
GigabitEthernet0/0 unassigned YES manual up up
GigabitEthernet0/1 unassigned YES manual up up
Port-channel1 192.168.1.2 YES NVRAM up up
sw2#ping 192.168.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
Thanks Laz.
What is the benefits of using PAgP or LACP vs. Manual?
Hello Richard
It is true that emulators can be somewhat troublesome in their configurations and operation, however, this is not the case in this scenario. The vios_l2 Software (vios_l2-ADVENTERPRISEK9-M), Version 15.2(4.0.55)E image does not support L3 Etherchannel. It is a Layer 2 image and primarily focuses on switch functionality. According to some GNS3 forum threads, there is a newer version that does support L3 Etherchannel. I suggest you use a different image and check the features that are covered.
I hope this has been helpful!
Laz
Hello David
Using PAgP or LACP will allow you to dynamically form EtherChannel bundles if the correct configurations are created on either end. This is especially useful if you are connecting a server with multiple network cards to a switch. The multiple links will automatically form an EtherChannel bundle. Most servers support LACP which is an IEEE standard, while PAgP is generally used more often between switches since it is Cisco proprietary.
The advantage of using LACP or PAgP is that they negotiate the link. In the case of LACP, LACPDUs are exchanged resulting in a âkeepaliveâ mechanism. This allows for any changes to be detected, and load balancing procedures to be adjusted as needed.
PAgP and LACP also include several additional features that can be further investigated here:
Manually configuring the EtherChannel will eliminate any negotiation between the devices in question, since they are hardwired to function using port channels. In this case, load balancing is statically defined, and if a link fails, the other links in the bundle will simply take the extra traffic load evenly.
Personally, I prefer the static configuration between switches and the use of LACP between a switch and a server.
I hope this has been helpful!
Laz
Interesting, usually L2 images will not allow the command NO SWITCH and will not allow you to assign IP address on any interface except VLAN interfaces.
I will look for new image that support L3 functions
Thanks
Hello Richard
Yep, I understand, it doesnât make sense. Since you can issue the no switchport
command, it means that you can configure a port to function as a routed port or a Layer 3 port. However, it seems that the problem is not that it is a strictly Layer 2 switch image, but that it simply doesnât support the specific L3 EtherChannel feature.
Let us know how you get along!
Laz
Hello Rene,
Can we configure L3 Ethernet between:
- 2 Routers.
- a Router and a switch.
If so, is there any additional configuration required?
Hello Visham
The quick answer is yes, Cisco routers are capable of employing L3 Etherchannel.
Now the long answer includes some more details. Not all platforms support Etherchannel, and you must check the features of that particular platform and the IOS version. The ISR 4000 series does support it for example.
Secondly, you must take a look at the particular platform to determine the configuration commands. For 1900, 2900, and 3900 series routers, the configuration is similar to that of a switch. You can find more info here:
I hope this has been helpful!
Laz
No Switchport Command not working on:
below switch model
Switch Ports Model SW Version SW Image
- 2 52 WS-C2960S-48TS-L 12.2(55)SE5 C2960S-UNIVERSALK9-M
The 2960S is a L2 switch. You need a L3 switch.
i think you should mentioned in post this work with L3 Switches , because some of them will try to try with L2 switches
Hello Barakat
Indeed, I understand your point! Although it does say âLayer 3 Etherchannelâ it doesnât explicitly state that this is a feature supported on Layer 3 switches only. Iâll tell Rene and he can consider adding that information.
Thanks for the heads up!
Laz
Hello Team,
i have made this simple P2P links to create a L3 etherchannel, config seems fine but i cant ping.
SW3 Config:-
SW3#sh etherchannel 1 summary
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
M - not in use, minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port
Number of channel-groups in use: 1
Number of aggregators: 1
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(RU) - Et0/0(P) Et0/1(P)
SW3#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.10.10.0/30 is directly connected, Port-channel1
L 10.10.10.1/32 is directly connected, Port-channel1
SW3#
SW4:-
SW4#show etherchannel 1 summary
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
M - not in use, minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port
Number of channel-groups in use: 1
Number of aggregators: 1
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(RU) - Et0/0(P) Et0/1(P)
SW4#sh ip rou
SW4#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.10.10.0/30 is directly connected, Port-channel1
L 10.10.10.2/32 is directly connected, Port-channel1
SW4#
Hello Sathish
From the output you shared, it looks like your portchannel is up, and your routing shows the directly connected networks. However, it would be a good idea to check the output of the following commands on both devices and compare the output:
show etherchannel 1 detail
show running-config interface po1
show running-config interface et0/0
show running-configinterface et0/1
More details about these commands and troubleshooting approaches for EtherChannel can be found at this lesson:
I suggest you look it over. If youâre still having problems, share with us the output of the commands I mentioned before so we can help you further.
I hope this has been helpful!
Laz
Hello, everyone.
When I configure a layer 2 etherchannel and then issue the no switchport
command on it, the etherchannel completely resets? The interfaces get shutdown and removed from the PO for some reason.
L3-SW1(config)#interface po1
L3-SW1(config-if)#no switchport
*Aug 27 11:45:18.962: %LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to administratively down
*Aug 27 11:45:18.969: %LINK-5-CHANGED: Interface GigabitEthernet0/1, changed state to administratively down
*Aug 27 11:45:19.962: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to down
*Aug 27 11:45:19.969: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to down
*Aug 27 11:45:20.012: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed state to down
Is this how it should work or is it a CML bug?
David
Hello David
The behavior you are observing is expected. When you configured your L2 EtherChannel, you bundled your physical interfaces into one logical interface. When you issue the no switchport
command on your portchannel interface, you are effectively setting the EtherChannel to Layer 3. The problem is that the underlying physical interfaces are still configured as Layer 2 interfaces. This inconsistency will cause the physical interfaces to go down and be removed as they are no longer part of a Layer 2 EtherChannel.
In the lesson, you can see that the interfaces are configured as Layer 3 interfaces using the no switchport
command before being added to the logical portchannel. This order of operations helps to ensure that you donât get the inconsistencies that you observed. Does that make sense?
I hope this has been helpful!
Laz
Hello Laz.
Thank you! I have one more question.
I have a quick question about LACP Fast Switchover. From my understanding, this can be configured if we have two links in an EtherChannel bundle configured under LACP where one link will be active while the other link will be in hot standby mode.
Although I am not sure what exactly does this do? From what Iâve seen, if the main link goes down, the standby link is immediately used without bringing down the PO?
Now, I understand that there is a NetworkLessons note for it, so I am just confirming.
The real question is, Why exactly does the EC go down and then up without the fast switchover? What happens in the background? And what prevents fast switchover from just being enabled by default and fast-switch all the time?
David
Hello David
In a ânormalâ EtherChannel configuration using LACP, all links are active and share the load. If a single link fails, LACP must renegotiate which links are part of the bundle. During this renegotiation, the EtherChannel goes down temporarily. Once the negotiation is complete, the EtherChannel comes back up. This means that there will be downtime, even if it is for a split second.
However, when you enable LACP Fast Switchover, the logic behind the functionality changes: one link becomes the primary (active) link and the other becomes the standby link. When the primary link fails, the standby link takes over instantaneously ensuring virtually no disruption to the network. From a logical perspective, the EtherChannel bundle remains active because the standby link steps in.
Fast switchover isnât enabled by default because not all scenarios require or benefit from it. It is very specialized and should be used when you have two physical links in your bundle, as you suggested in your post. It should be deployed in high-availability environments such as data centers. It is less efficient than normal LACP because one of the links simply remains idle until it is needed, whereas normal LACP uses all links.
In many non-critical cases, the brief downtime during LACP renegotiation isnât an issue. Fast switchover requires more resources (CPU, memory) from the switch, which could be a concern in some networks.
I will update the NetworkLessons note to include this information.
I hope this has been helpful!
Laz