Multicast Anycast RP Configuration on Cisco IOS

(system) #12

Thanks for sharing this well written article. Don’t forget to manually set your router-id for OSPF (just like you did for MSDP) or the routing protocol might pick the anycast address as the router-id and break your unicast routing!

0 Likes

(Rene Molenaar) #13

That’s a good idea Tristan, thanks for sharing!

0 Likes

(system) #14

Great work Rene. You have a great way of explaining the different technologies.

Your website is one of my go-to’s while studying.

0 Likes

(Rene Molenaar) #15

Thanks Keith!

0 Likes

(system) #16

Thanks a lot Rene for your very easy to understand explanations. I just stumbled on your website and I use it as reference for my ccie study. Thanks for sharing.

0 Likes

(Sameer B) #17

Hi Rene,

I am not able to ping the mcast address 239.1.1.1 from R1 after all configs are done.
Below are the o/p for msdp

R2#sh ip msdp peer 
MSDP Peer 3.3.3.3 (?), AS ?
  Connection status:
    State: Up, Resets: 0, Connection source: Loopback1 (2.2.2.2)
    Uptime(Downtime): 00:02:30, Messages sent/received: 4/3
    Output messages discarded: 0
    Connection and counters cleared 00:08:30 ago
  SA Filtering:
    Input (S,G) filter: none, route-map: none
    Input RP filter: none, route-map: none
    Output (S,G) filter: none, route-map: none
    Output RP filter: none, route-map: none
  SA-Requests: 
    Input filter: none
  Peer ttl threshold: 0
  SAs learned from this peer: 0
  Input queue size: 0, Output queue size: 0

-

R3#sh ip msdp peer 
MSDP Peer 2.2.2.2 (?), AS ?
  Connection status:
    State: Up, Resets: 0, Connection source: Loopback1 (3.3.3.3)
    Uptime(Downtime): 00:02:35, Messages sent/received: 3/4
    Output messages discarded: 0
    Connection and counters cleared 00:08:35 ago
  SA Filtering:
    Input (S,G) filter: none, route-map: none
    Input RP filter: none, route-map: none
    Output (S,G) filter: none, route-map: none
    Output RP filter: none, route-map: none
  SA-Requests: 
    Input filter: none
  Peer ttl threshold: 0
  SAs learned from this peer: 1
  Input queue size: 0, Output queue size: 0
0 Likes

(Rene Molenaar) #18

Hi Sameer,

MSDP looks ok to me but did you check all the other stuff? Do you have PIM neighbors? Do you see entries in the mroute table? There’s a lot that could be wrong here.

Rene

0 Likes

(Sameer B) #19
R3#sh ip mroute 239.1.1.1
(*, 239.1.1.1), 00:00:58/00:02:04, RP 23.23.23.23, flags: SP
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list: Null

-

R2#
(*, 239.1.1.1), 00:00:05/stopped, RP 23.23.23.23, flags: SP
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list: Null

(192.168.12.1, 239.1.1.1), 00:00:05/00:02:54, flags: PTA
  Incoming interface: FastEthernet1/0, RPF nbr 0.0.0.0
  Outgoing interface list: Null

-

R3#sh ip pim neighbor    
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
192.168.23.2      FastEthernet1/0          00:03:46/00:01:26 v2    1 / S
192.168.34.4      FastEthernet1/1          00:03:46/00:01:25 v2    1 / DR S

-

R2#sh ip pim neighbor 
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
192.168.12.1      FastEthernet1/0          00:02:59/00:01:41 v2    1 / S
192.168.23.3      FastEthernet1/1          00:03:00/00:01:41 v2    1 / DR S

Weird thing is i don’t see any outgoing interface.

0 Likes

(Rene Molenaar) #20

Did you use IGMP join group on R4? As soon as you do this, R3 should show the outgoing interface for the group that you joined.

1 Like

(Sameer B) #21

I found out that 239.1.1.1 is not a working group not sure why. I changed the group to 239.10.10.10 and it works :slight_smile:

0 Likes

(Rene Molenaar) #22

That is strange but good to hear it works :slight_smile:

0 Likes

(jeffrey w) #23

super write up thanks

0 Likes

(sergio c) #24

Very Easy to understand!

0 Likes

(Davis W) #25

You are the best!

Davis

0 Likes

(Sean P) #26

Your MSDP config is referring to loopback0 ? This won’t bring up MSDP as loopback0 on bough R2 and R3 are 23.23.23.23

0 Likes

(FETHI E) #27

Hi rene,

good article, i just noticed some mismatch :

  1. your show msdp peer is
R2#show ip msdp peer 
MSDP Peer 3.3.3.3 (?), AS ?
  Connection status:
    State: Up, Resets: 0, Connection source: Loopback1 (2.2.2.2)

and your config is

R2(config)#ip msdp originator-id Loopback 0
R2(config)#ip msdp peer 3.3.3.3 connect-source Loopback 0

it should be

R2(config)#ip msdp originator-id Loopback 0
R2(config)#ip msdp peer 3.3.3.3 connect-source Loopback 1

I think you forgot to mention that ip pim sparse-mode should be enabled in the interface loopback0

  1. your picture is showing
    R2 loopback 0 = 2.2.2.2 instead 23.23.23.23
    R3 loopback 0 = 3.3.3.3 instead 23.23.23.23
    so normally 2.2.2.2 and 3.3.3.3 should be configured in loopack 1 as loopback 0 has already its IP address.

I think we can guess it easely as your show command is correct meaning the original configuration is correct.

thank you again for this article that is very instructive

1 Like

(Nagender K) #28

Hello Rene,

I was trying to lab this topology. For some reason, I am seeing that MSDP is not coming up between the neighbors and is stuck in listening state. Any idea?

0 Likes

(Nagender K) #29

Hi Rene,

I found the problem, I think there is a typo in the command above “in connect-source section, it should be lo1 instead of lo0”. Overall, very good post

0 Likes

(Rene Molenaar) #30

Hi all,

Just edited this post. The MSDP peering should be between the loopback 1 interfaces of R2/R3, not loopback 0.

Rene

1 Like

(Shantel - Networklessons.com) split this topic #31

19 posts were merged into an existing topic: Multicast Anycast RP Configuration on Cisco IOS

0 Likes