VLAN Trunking In and Out of ASA5516X


(Wes S) #1

Hello,

I need some help with trunking VLANs through an ASA5516X.

I have one interface with two sub-interfaces/two vlans. OSPF routing is turned on for inter-vlan routing. This interface is connected to a dot1q trunk from a 6506. I can ping both ip addresses associated with the ASA sub-interfaces from the 6506.

I have another interface on the ASA that I need to trunk to a 3750. Not sure what to do here.

The 3750 is trunked to the ASA port described in the last paragraph. Just not sure what to do on the ASA side of it.

Thanks


(Rene Molenaar) #2

Hi Wes,

Do you need the same VLANs as to the 6506 or new VLANs? If you have new VLANs, you can just use the sub-interfaces like this:

interface GigabitEthernet1/1.10
 description SERVERS
 vlan 10
 nameif SERVERS
 security-level 100
 ip address 192.168.10.254 255.255.255.0 
!
interface GigabitEthernet1/1.20
 description DESKTOPS
 vlan 20
 nameif DESKTOPS
 security-level 100
 ip address 192.168.20.254 255.255.255.0

If you need to use the same VLANs, you’ll have to make sure the interfaces are bridged. When the new ASAs (5506, 5516, etc.) were launched, all interfaces were L3 interfaces and there was no way to bridge them (like the ASA 5505 worked). With ASA version > 9.7 this is now possible.

Rene