Hi all,
Obviously I’m missing something here. I created this lab in GNS3 using 3725’s. I want to advertise the 11.1.1.1/24 router from ibgp R1 to ebgp R3. I added route reflector command on R2 to reflect R1’s route to R3 since I’m not using a static route. Below is my configuration:
===================================================================
R1//////////////////////////////////////////////////////////
interface Loopback1
ip address 11.1.1.1 255.255.255.0
!
router bgp 1
no synchronization
bgp log-neighbor-changes
network 11.1.1.0 mask 255.255.255.0
neighbor 2.2.2.2 remote-as 1
neighbor 2.2.2.2 update-source Loopback0
no auto-summary
!
ip forward-protocol nd
ip route 2.2.2.2 255.255.255.255 172.16.10.2
!
R2////////////////////////////////////////////////////////
router bgp 1
no synchronization
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 1
neighbor 1.1.1.1 update-source Loopback0
neighbor 1.1.1.1 route-reflector-client
neighbor 3.3.3.3 remote-as 2
neighbor 3.3.3.3 ebgp-multihop 2
neighbor 3.3.3.3 update-source Loopback0
no auto-summary
!
ip forward-protocol nd
ip route 1.1.1.1 255.255.255.255 172.16.10.1
ip route 3.3.3.3 255.255.255.255 172.16.20.3
!R3/////////////////////////////////////////////////////
router bgp 2
no synchronization
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 1
neighbor 2.2.2.2 ebgp-multihop 2
neighbor 2.2.2.2 update-source Loopback0
no auto-summary
!
ip forward-protocol nd
ip route 2.2.2.2 255.255.255.255 172.16.20.2
=========================================================================================
So if I do a “show ip bgp” I see this:
R3#sh ip bgp
BGP table version is 4, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incompleteNetwork Next Hop Metric LocPrf Weight Path
*> 11.1.1.0/24 2.2.2.2 0 1 i
Also additional commands:
R3#sh ip bgp 11.1.1.0
BGP routing table entry for 11.1.1.0/24, version 4
Paths: (1 available, best #1, table Default-IP-Routing-Table)
Not advertised to any peer
1
2.2.2.2 from 2.2.2.2 (2.2.2.2)
Origin IGP, localpref 100, valid, external, bestR3#sh ip route bgp
11.0.0.0/24 is subnetted, 1 subnets
B 11.1.1.0 [20/0] via 2.2.2.2, 00:36:23
However if I try to ping it won’t complete.
R3#ping 11.1.1.1 source 172.16.20.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.1.1.1, timeout is 2 seconds:
Packet sent with a source address of 172.16.20.3
…
Can anyone help please?
Thanks!!!
Mike