BGP RouteReflector (Next hop issue)

Sir, im having problem with BGP Route Reflector next hop issue, heres my diagram

 

R1—R2—R3

 

R2 is the RouteReflector

(The last octet of the ip address is the number of router)

R1–R2 = 12.0.0.0/24

R2–R3 = 23.0.0.0/24

 

R1 i have loopback 0 = 1.1.1.1/32

R3 i have Loopback 0 = 3.3.3.3/32

 

My iBGP relationship is R1 to R2 && R2 to R3. no iBGP relationship with R1 to R3.

so in R1 and R3, i advertise the loopback address on BGP by using “network 1.1.1.1 mask 255.255.255.255” and “network 3.3.3.3 mask 255.255.255.255”

On R2, i make the R1 and R3 my RR client and i also issue a next-hop-self command.

Thats all my configuration, no IGP routing protocol.

On R1, i saw the loopback of R3 in Show Ip Bgp, but it is not valid, because it says inaccessible. the next hop is 23.0.0.3

same on R3, i saw the loopback of R1 in Show Ip Bgp, but its not valid, inaccessible, next hop is 12.0.0.1

 

So the route reflector was working because R2 was able to advertise the Loopback of R1 to R3 and vice versa, but the issue is the reachability, even though i typed on R2 the next hop self command on both R1 and R3, its not seeing itself as the next hop.

 

Thank you!

interface Loopback1
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 ip address 12.0.0.1 255.255.255.0
 speed auto
 duplex auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 speed auto
 duplex auto
!
router bgp 123
 bgp log-neighbor-changes
 network 1.1.1.1 mask 255.255.255.255
 neighbor 12.0.0.2 remote-as 123

-

interface FastEthernet0/0
 ip address 12.0.0.2 255.255.255.0
 speed auto
 duplex auto
!
interface FastEthernet0/1
 ip address 23.0.0.2 255.255.255.0
 speed auto
 duplex auto
!
router bgp 123
 bgp log-neighbor-changes
 neighbor 12.0.0.1 remote-as 123
 neighbor 12.0.0.1 route-reflector-client
 neighbor 12.0.0.1 next-hop-self
 neighbor 23.0.0.3 remote-as 123
 neighbor 23.0.0.3 route-reflector-client
 neighbor 23.0.0.3 next-hop-self

-

interface Loopback1
 ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 shutdown
 speed auto
 duplex auto
!
interface FastEthernet0/1
 ip address 23.0.0.3 255.255.255.0
 speed auto
 duplex auto
!
router bgp 123
 bgp log-neighbor-changes
 network 3.3.3.3 mask 255.255.255.255
 neighbor 23.0.0.2 remote-as 123

Hi John,

I just checked, the next-hop-self command on a route reflector will not change iBGP routes. It only changes the next hop for routes learned from eBGP neighbors.

There is a method to get around this though, you can use a route-map:

R2(config)#route-map CHANGE_NEXT_HOP permit 10
R2(config-route-map)#set ip next-hop 23.0.0.2
R2(config)#router bgp 123
R2(config-router)#neighbor 23.0.0.3 route-map CHANGE_NEXT_HOP out

Now check R3:

R3#show ip bgp
BGP table version is 3, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
*>i1.1.1.1/32 23.0.0.2 0 100 0 i
*> 3.3.3.3/32 0.0.0.0 0 32768 i

You also need to apply a similar route-map on R2 towards R1.

Thanks for the info! i’ll try to inject some eBGP prefix!

Hi Rene,

On R3, it is not installing 1.1.1.0/24 to the BGP table due to the next-hop being in-accessible. My understanding following all your previous chapters are, we will be running IBGP on top of an IGP in practical situations as IGP is meant to pass on routes between different AS. So in this particular example, John is not running an IGP and that is the reason it is failing to install in the RIB. Rather than changing the next hop with a route-map ,running an IGP to fix the reachability to the next-hop is a preferred solution? Please share your thoughts.

Thanks,
M.

Hello Madhu

I would concur with your train of thought. Within an AS, it is best practice to run an IGP so that all internal routing of the AS takes place using that IGP. This also allows iBGP to correctly share routes within that AS.

I hope this has been helpful!

Laz

1 Like

Thanks Laz for clarifying, Appreciate it.

Thanks,
Madhu

1 Like