Both switches thinks they are root


I have 2 S3048-ON configured with VLT (virtual link trunk), and a Dell 5548 connected to one of the S3048-ON (tried both one and two cables).

All switches are configured with RSTP, and have configured priorities.

But both S3048-ON and Dell 5548 thinks they’re root.

I can’t seem to trigger Dell 5548 to “surrender” and not be root bridge.

Haven’t seen this behavior before. Any insights ?

Attached some screenshots.

Hi Lars Erik,

That is surprising :slight_smile: Are you able to verify if both switches do receive BPDUs from each other? That’s the first thing I would check.

I’m not too familiar with the Dell switches but do they perhaps have any filtering enabled by default? Something similar like Cisco’s STP root guard?


Hi Rene

It seems that BPDUs aren’t received at all by the 5548 switch, on the S3048-ONs I see both sent/received (I guess this is between the 2 S3048-ONs this is happening). There’s no guarding of any kind enabled (see screenshot) on 5548. Tried changing BPDU global setting on 5548 to flooding instead of filtering but with no results.

I’ll try changing cables and if that’s not working I’ll try to find another switch to test with (which is not 5548).

BTW: If there’s no normal traffic from attached devices/servers and it’s only switches that is interconnected. Could this tricker no received BPDUs on 5548 ? (or would it always adapt no matter if any traffic occur?)

The 5548 switch needed to be configured with LAG/LACP and connect through this to S3048-ONs for RSTP to work as expected. Once this is configured all seems fine, attached screenshot!

Hi Lars Erik,

Good to hear you figured it out!