Cisco 6500 VSS Configuration Example


(Rene Molenaar) #21

Hi Joe,

You would have to use “regular” port-channels for this. You can create a VSS pair with the 6500s on the distribution layer and you can do the same thing for the access layer. The VSL is only used between two switches running VSS.

Rene


(Mohamed R) #22

How we can revert back VSS to stand alone switches.


(Rene Molenaar) #23

Hmm I can’t test this right now but I think the process is like this:

  1. Use "convert standalone mode switch" on the active switch.
  2. Save config and reload switch.
  3. Second switch be active now, also use "convert standalone mode switch" on this switch.
  4. Save config and reload switch.
  5. Both switches should now be in standalone mode and then you can clean up the remaining of the config.

(Mohamed R) #24

Thank you so much for your update…

Do we need to shutdown the VSL link before applying the command convert standalone mode switch ?

what about the configuration of stand alone switch before converting to VSS ? configuration also will be there in the stand alone ?

Regards

Raffi.


(Rene Molenaar) #25

Hi Raffi,

It’s been a long time since I had to do this so I’m not sure. I don’t think it will make much of a difference if the VSL link is still up or not. What do you mean exactly with the configuration? If the original config is still there if you convert it from standalone > vss > standalone?

Rene


(Ali N) #26

Rene:

I am a little bit confused about the way you created etherchannel.

SW1-VSS(config)#interface port-channel 1
SW1-VSS(config-if)#no shutdown
SW1-VSS(config-if)#switch virtual link 1
SW1-VSS(config-if)#exit
SW1-VSS(config)#int range ten 1/4 - 5
SW1-VSS(config-if-range)#channel-group 1 mode on
SW1-VSS(config-if-range)#no shut
SW2-VSS(config)#interface port-channel 2
SW2-VSS(config-if)#no shutdown
SW2-VSS(config-if)#switch virtual link 2
SW2-VSS(config-if)#exit
SW2-VSS(config)#int range ten 1/4 - 5
SW2-VSS(config-if-range)#channel-group 2 mode on
SW2-VSS(config-if-range)#no shutdown

Shouldn’t “channel-group 1 mode on” be entered on bot switches. How come channel-group is 1 on SW1 and 2 on SW2? Thank you.


(Rene Molenaar) #27

Hi Ali,

The channel-group is a local number, you can pick whatever you like. I do have to say that it would have been easier to pick another number…perhaps 12 on both switches :slight_smile:

Rene


(Abdool Y) #28

Thank you again Rene for a great article.

How is the control, data and management plane affected? Are the functions shared between the switches?


(Andrew P) #29

Abdool,
In VSS, there is one control plane and one management plane that is shared between the switches (each switch has its own data plane).

By the way, this is the key distinction between VSS and vPC (virtual Port Channel) for the Nexus platform. In vPC, there are two independent control and management planes, whereas with VSS there is just one shared.


(Abdool Y) #30

Great! Thank you. I appreciate your response.


(Kesav A) #31

Hi Rene,

I see that you have created two port channels (Po1 and Po2) & two virtual links (Vlink1 and vlink2).

Require some clarification on below queries as i’m trying to understand regarding this subject:-

a) Why two virtual links need to be created? Is it that one virtual link is used for data traffic and one for management traffic? What is the benefit / use case of having two virtual links?
b) Also you had responded to Ali’s question that we can use single port channel (Po12) and bind all interfaces in both the switches under this Po12. If so, can we have two virtual links binded under one Po12?
c) Does the VSL link need to be trunk ? If it’s access port, how can it differentiate data traffic from multiple VLAN’s and management traffic?
d) Does VSL link have to be only L2? Can we have L3 interface as well for VSL?
e) There is no configuration mentioned regarding SSO? Do we have to configure SSO mode under redundancy or is that setup by default ?
f) Finally, do you have any reference post in your forum for understanding Quad SUP SSO feature & In - Chassis redundancy?


(Kesav A) #32

Hi Rene,

I’ve been going through your other posts and it’s really great. Also i was searching for VPC related links in google and it ended up 404 page.

Can you share me new links where i can go through regarding VPC member ports, peer link and traffic flow with an example ?


(Lazaros Agapides) #33

Hello Kesav!

I’ll try to answer your questions one by one below:

a) Why two virtual links need to be created? Is it that one virtual link is used for data traffic and one for management traffic? What is the benefit / use case of having two virtual links?

Actually, Rene has created only one virtual link and one port channel. It just happens that he named the port channel on SW1-VSS Po1 and the port channel on SW2-VSS Po2. They’re just two ends of the same set of physical links that form the port channel. The same occurs for the Virtual link. The end of the link on SW1 is called virtual link 1 and the other end of the same virtual link on SW2 is called virtual link 2.

b) Also you had responded to Ali’s question that we can use single port channel (Po12) and bind all interfaces in both the switches under this Po12. If so, can we have two virtual links binded under one Po12?

Rene clarifies this in his answer. The labels “1” and “2” can be anything on each end of the etherchannel (or of the virtual link for that matter). He suggested using Po12 on both ends. You can use whatever you like. If it makes more sense to you, use the same number on both ends.

c) Does the VSL link need to be trunk ? If it’s access port, how can it differentiate data traffic from multiple VLAN’s and management traffic?

This is a very good question. Actually, the answer is “it depends on the platform being used.” The good thing is however, that when you issue the switch virtual link command, the proper configuration for the platform is implemented, so you don’t actually have to configure the corresponding switchport command. For more information, check out this Cisco Support Community post: https://supportforums.cisco.com/discussion/12987876/vss-vsls-port-channel-interface-switchport-or-no-switchport

d) Does VSL link have to be only L2? Can we have L3 interface as well for VSL?

Again, this is automatically configured by the switch virtual link command. See the following quote from the above link:

The 4500x works as switchportand the 6800 works only as no switchport.

e) There is no configuration mentioned regarding SSO? Do we have to configure SSO mode under redundancy or is that setup by default ?

SSO is not something you need to configure, it is the technology, or the method by which the VSL will operate when/if the active switch goes down.

f) Finally, do you have any reference post in your forum for understanding Quad SUP SSO feature & In – Chassis redundancy?

As far as I know, Quad SUP SSO is not yet included in the forum, but we’re working on it! In the meantime, you can take a look at this Cisco reference: http://www.cisco.com/c/en/us/products/collateral/switches/mgx-8800-series-switches/white_paper_c11-729039.html

I hope this has been helpful!

Laz


(PALANIAPPAN M) #34

Hi Rene

I am looking for Nexu material on this site but could not find the course link. Can you please help me with finding the course material for Nexus.
Do you have tips for how to practically do labs for Nexus, like GNS3 lab or do you have to any virtual lab specific to Nexus?

Thanks
Palani


(Rene Molenaar) #35

Hi Palani,

Right now we don’t have any Nexus material. This is something I’d like to add in the future.

It’s difficult to do Nexus labs at the moment. Cisco VIRL has NX-OS but it only supports L3 features, not all the awesome L2 stuff that you want to learn. Nexus equipment is expensive to buy.

Cisco does have some resources however that you might be able to use:

https://dcloud.cisco.com/
http://www.nexus-demo.labgear.net/Home.asp
Cisco PEC (Partned Education) Gold Labs

Rene


(PALANIAPPAN M) #36

Thanks, Rene!.


(arun v) #37

@Rene- Does this procedure is same for 6800 series switches ?


(Lazaros Agapides) #38

Hello Arun.

I have never implemented VSS myself on a 6800 series switch but based on my research, as long as you have a Supervisor 2T that supports VSS and the proper IOS, you can configure VSS in the same manner on both the 6500 and the 6800.

I hope this has been helpful!

Laz


(Networklessons Admin) split this topic #39

19 posts were merged into an existing topic: Cisco 6500 VSS Configuration Example


(sims) #40

Hi,

Rene If a switch is connected to VSS enable switch ( redundant connectivity switch 1 and switch 2 ) and RSTP is running in this case
who will be the root bridge ?

Thanks