According to Cisco, IPv6 is not supported on an EVN trunk, except on vnet global. This is a predefined EVN which refers to the global routing contect and corresponds to the default RIB. For more information about EVN and it’s support or IPv6, take a look at this documentation:
EVN is still useful especially when running multiple isolated networks end-to-end over the same L3 infrastructure. Many of the benefits of this technology can be found at the following Cisco documentation.
Hi Rene,
Very interesting topic…I enjoyed it. My question is , what will the configuration look like if I want to use EIGRP instead of OSPF? I tried using EIGRP but could not find the vrf commands. Thank you.
When configuring VRFs with EIGRP, the commands used are somewhat different than those for OSPF. In OSPF, you issue the command per OSPF process. This means that the VRF is actually appended as a keyword to the router command like so:
ISP1(config)#router ospf 1 vrf Blue
ISP1(config)#router ospf 2 vrf Red
So there is a one to one correspondence between OSPF processes (1 and 2 in the above commands) and the VRFs.
With EIGRP on the other hand, you configure the VRFs on a per address-family basis. This means that the command for specifying the VRF is placed in the address-family command like so:
ISP1(config)# router eigrp 1
ISP1(config-router)# address-family ipv4 vrf Blue
ISP(config-router-af)# network 172.16.0.0
ISP1(config-router)# address-family ipv4 vrf Red
ISP(config-router-af)# network 172.17.0.0
If you want to configure this without EVN, then you must create two subinterfaces on each of the Gi3 interfaces of the ISP routers, and connect them with separate subnets. If you look at the lesson, the vnet trunk command actually works as a macro to create the actual configuration you need. So the configuration on the Gi3 interface that you are looking for is already in the lesson:
HI ;
I created sub interfaces but ı cannot ping . İf Iconfigurate mpls ip under interface e0/2 , I can ping. İs there anything i need to add for pinging ?
TK-1#ping 10.10.20.20 source 172.29.10.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.20.20, timeout is 2 seconds:
Packet sent with a source address of 172.29.10.1
.....
Success rate is 0 percent (0/5)
TK-1#tra
TK-1#traceroute 10.10.20.20
Type escape sequence to abort.
Tracing the route to 10.10.20.20
VRF info: (vrf in name/id, vrf out name/id)
1 172.29.10.254 1 msec 0 msec 1 msec
2 * * *
3 * * *
4 * * *
ISP-1(config-subif)#
interface Ethernet0/2
ip address 192.168.12.1 255.255.255.0
end
!
interface Ethernet0/2.10
description subinterface for TK
encapsulation dot1Q 10
ip vrf forwarding TK
ip address 192.168.12.1 255.255.255.0
end
!
interface Ethernet0/2.20
encapsulation dot1Q 20
ip vrf forwarding TEKNIK
ip address 192.168.12.1 255.255.255.0
end
ISP-2(config-subif)#
interface Ethernet0/2
ip address 192.168.12.2 255.255.255.0
end
!
interface Ethernet0/2.10
description subinterface for TK
encapsulation dot1Q 10
ip vrf forwarding TK
ip address 192.168.12.2 255.255.255.0
!
interface Ethernet0/2.20
encapsulation dot1Q 20
ip vrf forwarding TEKNIK
ip address 192.168.12.2 255.255.255.0
end
TK-1#show ip route ospf
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O IA 10.10.20.20/32 [110/21] via 172.29.10.254, 02:56:49, Ethernet0/0
20.0.0.0/24 is subnetted, 1 subnets
O E2 20.20.10.0 [110/1] via 172.29.10.254, 03:19:50, Ethernet0/0
172.29.0.0/16 is variably subnetted, 3 subnets, 2 masks
O IA 172.29.20.0/24 [110/11] via 172.29.10.254, 02:56:49, Ethernet0/0
Yes you are correct. In the configuration that the EVN command produces, there is an additional command that you are unable to implement on your system due to the limitations of EVE, and that is the vnet trunk command that is found within the physical interface configuration. This command actually allows the single IP address on the trunk interface of the router. This results in the same trunk interface being identified by the same IP address in different EVN contexts. As described in the following Cisco documentation, each EVN has a unique routing and forwarding table, enabling support for overlapping IP addresses across multiple EVNs.
Without the vnet trunk command in the physical interface, this is not possible. So you must create subinterfaces with different IP subnets for each subinterface link.
Great lesson, I`ve been following the lab on my simulator with c7200 router and it works!!!, my question is, EVN can be implemented only on Cisco routers, or it can be integrated with other brands?, in other words EVN is cisco propietary feature?
The second one is if you are following a design with Routers using EIGRP as well as EVN, and the other side of the design is using OSPF as well as EVN, you can redistribute the routes between each other?, or it is not necessary to do that kind of combination?
EVN is not Cisco proprietary. It’s simply VRF-lite over VLAN point-to-point subinterfaces. The EVN name is Cisco’s naming of the feature, but you can easily connect a Juniper or HP device on the other end of the link and it will work fine, as long as it is configured correctly on its end.
As for your second question, in order to perform redistribution between EIGRP and OSPF, you need to choose which router on which end will perform the redistribution. You can’t have OSPF on one end and EIGRP on the other, but you must have a single router with at least one interface in the OSPF domain and another in the EIGRP domain. Such a configuration is independent of the EVN configuration, but you can implement EVN and this kind of redistribution on the same device…
Hello Laz ,
my Question is about this Command : redistribute vrf Green ospf 3 subnets . How does Router recognize this replicated Route as Ospf 3 Route although this Route (5.5.5.0 ) is as directly connected replicated Route inside VRF Red , Blue ?
Thanks
Notice that on ISP1, when VRF Green was created, an OSPF process was also initiated on the Green VRF:
ISP1(config)#router ospf 3 vrf Green
ISP1(config-router)#network 5.5.5.0 0.0.0.255 area 0
These commands initiated an OSPF process to share these specific subnets. Yes, the subnet itself is directly connected to ISP1, but you’re telling the router to advertise it.
As we have seen until now, by default routing protocols will not share routing information between VRFs unless you redistribute them. So by issuing the following commands:
ISP1(config)#router ospf 1 vrf Blue
ISP1(config-router)#redistribute vrf Green ospf 3 subnets
ISP1(config)#router ospf 2 vrf Red
ISP1(config-router)#redistribute vrf Green ospf 3 subnets
…you are stating that you want to share all networks advertised within OSPF process 3 (which is the network off of L0). Thus, the 5.5.5.0/24 subnet is successfully redistributed into Red and Blue.