Configuration of route reflector and changing next with route map

Hello everybody,

i am trying to configure a route reflector and i’ve to come to problem where a network won’t be installed at the ip table because of a wrong next hop.
Here is the part of the topology that i am refering to. R8 is the reflector with R11 the only client. The problem is that R9 and R10 learns from R8 about R15 but with next hop 190.160.118.11 (the same problem occurs with R11), when they sould save R15 and R11 networks from an interface of R8.

I’ve tried using next-hop-self command but as i find out it works only with ebgp connections. Next i tried using route maps but with no success.

Here is the configuration is used:

R8(config)#router bgp 300
R8(config-router)#no synchronization
R8(config-router)#neighbor 190.160.38.3 remote-as 100
R8(config-router)#neighbor 190.160.89.9 remote-as 300
R8(config-router)#neighbor 190.160.108.10 remote-as 300
R8(config-router)#neighbor 190.160.118.11 remote-as 300
R8(config-router)#neighbor 190.160.118.11 route-reflector-client
R8(config-router)#network 8.8.8.8 mask 255.255.255.255
R8(config-router)#exit

R8(config)#access-list 20 permit 15.15.15.15 0.0.0.0
R8(config)#access-list 20 deny any
R8(config)#route-map nxthp permit 10
R8(config-route-map)#match ip address 20
R8(config-route-map)#set ip next-hop 190.160.89.9
R8(config-route-map)#exit

R8(config)#router bgp 300
R8(config-router)#neighbor 190.160.89.9 route-map nxthp in
R8(config-route-map)#end

And here is the result show ip bgp command at R9

R9#sh ip bgp
BGP table version is 23, local router ID is 9.9.9.9
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

    Network                        Next Hop            Metric LocPrf Weight Path
    *i15.15.15.15/32             190.160.118                0    100      0 600 i

Can somebody tell me what i am doing wrong or point me at the right direction?

Thank you in advance,
George

What are you using as your IGP in AS 300? R9 and R10 should be able to recursively look up that next hop. Ex: if you are using EIGRP, then R9/R10 should have EIGRP routes to 190.160.118.11 pointing to R8, which they can use for 15.15.15.15/32.

1 Like

Hello George

Good call @nicholas.williams2. Take a look at your IGP and let us know what you come up with.

Laz

Hello, sorry for the late response and thank you for the answers!
Yes IGP solves the problem. I used OSPF.
However i was wondering for the sake curiosity if i could manually change next-hop in this example and make it work the same way. Also if route-maps works what is the reason to choose IGP over them except convenience?
George

Hi George,

Your route reflector “reflects” the routes, but that’s all it does. R9 and R10 shouldn’t use R8 as the next hop for a network behind R15. In your example, R8 is in the traffic path but that’s not a requirement or always the case.

When R11 advertises a route from R15, the next hop will be the IP address of R15. To fix this, you can use next hop self on R11 so it becomes the IP address from R11 (190.160.118.11).

R9 and R10 still need to know how to reach 190.160.118.0/24. You can advertise this network in your IGP to solve this problem. The advantage of a route-map is that you can be specific in the changes you want to make. In this case, using your IGP and next hop self is the most simple solution. If you have a topology with multiple networks and you only want to influence some, you can use route-maps.

Rene