Configuring a switch in packet tracer

(David C) #1

I’m trying to configure a 2950T-24 in packet tracer and when I try to assign fa0/1 an ip address I keep gettting:

North_Switch(config-if)#ip address 192.168.4.3 255.255.255.0
                           ^
% Invalid input detected at '^' marker.

The config is below. Any ideas? I’ve tried “ip routing” no switch port (in config mode, per google) no luck.

North_Switch#sh run
Building configuration...

Current configuration : 1447 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname North_Switch
!
enable secret 5 $1$mERr$.mZUxVw4tp.fz.HSTl9q3/
enable password 7 08314D5D1A0E0A05165A
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
 description connection to north_host1
 duplex half
 speed 10
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4

North_Switch#config t
Enter configuration commands, one per line.  End with CNTL/Z.
North_Switch(config)#int fa0/1
North_Switch(config-if)#ip address 192.168.4.3 255.255.255.0
                           ^
% Invalid input detected at '^' marker.
(David C) #2

I think it may not be possible to configure a fastEthernet port on the switch as the ports are part of a vlan and it has a default gateway so the traffic is forwarded to the next hop, is that right?

Thanks. I’m a newbie obviously.

(David C) #3

Never mind. I figured some things out and it’s working now. Whew!

(Lazaros Agapides) split this topic #4

A post was merged into an existing topic: Modes of a Switch Port