Convert VMWare ESXi Thick Provisioned Disk to Thin

This topic is to discuss the following lesson:

This worked like a charm thanks!
One note though; to delete the old hard disk you prob have to delete all previous snapshots, I had to.

vmkfstools -K /vmfs/volumes/pathto/thickdisk.vmdk also should do this in place conversion. Would you like to give a try and update ?

I’ll give it a try.

Hi, why is it that i get this error when i enter the vmkfstools command?
DiskLib_Check() failed for source disk The system cannot find the file specified (25).


Your example is using the *-flat.vmdk file as the source which I think is wrong. It should be using the other *.vmdk file.
Its just my 2 cents. Maybe it worked in your machine.

Hi Lonewolf,

You saved my day. Thanks.


I had the same issue. Perhaps it’s the version of ESXi? I use 5.1 and I had to use the file without *-flat.vmdk at the the end. When I specified the *-flat.vmdk file to convert it said the file wasn’t a virtual disk. I then looked in datastore in vSphere client and saw the file didn’t have -flat in it so I omitted ‘-flat’ and it worked.

I have ESXi 5.5 and this is how I did it:

1- Consolidated/deleted all snapshots.

2- vmkfstools -i MyVirtualDiskName-flat.vmdk -d thin MyVirtualDiskName-thin.vmdk
However, I got the error: DiskLib_Check() failed for source disk The file specified is not a virtual disk (15).

Therefore I did this instead:
vmkfstools -i MyVirtualDiskName.vmdk -d thin MyVirtualDiskName-thin.vmdk
This command cloned the vmdk successfully to thin format.

3- In the ESXi client GUI I went to the VM settings and removed the virtual hard disk without deleting it.

4- Added a new virtual hard disk and pointed it to the thin vmdk I just created.

5- Booted up the VM and checked it was ok. Shut down the VM.

6- Using the Datastore browser in the GUI, I moved the old THICK vmdk out of the folder to its parent folder and booted up the VM again to verify it was still OK. It should boot fine because it is now using the THIN vmdk and should not need the THICK one anymore.

7- After shutting down the VM, I created a snapshot and then booted the VM one more time to verify, then shut down.

8- Finally, I deleted the old THICK vmdk that I had moved to the parent folder and then booted the VM to verify once again.

Thanks for sharing this Mario, it’ll be helpful for others.