EIGRP Configuration for CCNA Students

Hi Heng,

In this case, it has to be at least 3 but any higher number will also work.

Hi Rene,

May I know why can’t I make an unequal load balancing (no second route item for 4.4.4.0 network) after I configured variance to 3? I have uploaded my running config below.
question

Thanks.

Hi Rocky,

The FD of your successor is 158720 and the FD of your feasible successor is 2300416.

To make unequal load balancing work, the FD of your feasible successor has to be smaller than the FD of the successor multiplied with the variance.

2300416 / 158720 = 14,59

So if you set your variance to 15, you should be good to go :slight_smile:

2 Likes

Thanks for your help.

Hi Rene,
I have a doubt with this line: network 172.16.0.0 0.0.3.255
I don´t understand how it works the wildcard. Can you help me with this one?.. thanks.

R2(config)#router eigrp 12
R2(config-router)#no auto-summary
R2(config-router)#network 192.168.12.0
R2(config-router)#network 172.16.0.0 0.0.3.255

Hello Cesar,

A wildcard is a reverse subnet mask. You can find some more info here:

Let’s take a look at 0.0.3.255. In binary, it looks like this:

Wildcard: 00000000 00000000 00000011 11111111
Subnet mask: 11111111 11111111 11111100 000000000

So your subnet mask is 255.255.252.0

192.168.12.0 with subnet mask 255.255.252.0 matches the following networks:

  • 192.168.12.0
  • 192.168.13.0
  • 192.168.14.0
  • 192.168.15.0

This gives you the answer but it takes time. Once you feel familiar with these calculations in binary, take a look at this lesson:

I hope this helps!

Rene

Hello Rene,
i was able to put the LAB together and one thing I noticed is this.
I wanted to remove the variance 3 from the eigrp config and see the original distances value

R1#conf t
R1#conf terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#router eigrp 1
R1(config-router)#no variance 3

image

I noticed that I do not see different value on the distances
maybe something I did wrong?

hum nobody replied to my post…

This page needs to be updated. The paragraph after the basic eigrp config says classful is the default, but this has changed since iOS 15.

Hello Regis

First of all, your topology is slightly different than that in the lab. In the lab, the connection between R1 and R2 is an Ethernet connection (10 Mbps) as opposed to your FastEthernet connection (100 Mbps). In the lab, this results in having only a single route entered into the routing table for the destination network of 4.4.4.0/24, specifically, the route via R3. This is due to the fact that bandwidth is included in the metric of EIGRP. The bandwidth available via R3 is better than that available via R2, so the route via R3 is preferred.

In your topology, both routes have the same bandwidth and thus have the same metric. EIGRP by default will install both routes in the routing table when the metric is the same. Notice the metric in your sh ip route eigrp output for both routes.

Now this means that the variance command in your case will make no difference, whether it is implemented or not. Variance essentially allows unequal load balancing. If the metric is equal as is the case in your topology, no change will be seen.

In order to recreate the lab identically, you can change the speed of the FastEthernet 0/1 interface on your R1 router to 10. The lab should then work as shown in the lesson.

For more information about the variance feature of EIGRP, take a look at this lesson:

https://networklessons.com/eigrp/eigrp-variance-command-example

I hope this has been helpful, and I apologize for the late reply. We’ll do our best!

Laz

1 Like

Hello Shaun

Thanks for the update. I’ll let Rene know to make the change…

Laz

I really like the time you took to explain this to me.
Thank you!!

1 Like

Thanks for letting me know, just fixed this.

I think it should say “No auto-summary is the default”

1 Like

Hello Everyone,

I have configured 2 Routers with 4 parallel links. Each router has a loopback address. I have advertised loopback addresses of the loopbacks in EIGRP. The FD is equal on all the links. I see 4 paths in the routing table of each router for a given loopback address. According to my understanding there should be load balancing between all the 4 links. But I see load balancing between only 2 links. All 4 are not participating in the load balancing.

I have captured the packets on all the 4 links. I see packets are transferred through only 2 links. I am using ping to send the traffic.

Configuration on R1:

router eigrp 1
 maximum-paths 6
 network 1.1.1.1 0.0.0.0
 network 100.10.10.0 0.0.0.255
 network 100.10.20.0 0.0.0.255
 network 100.20.10.0 0.0.0.255
 network 100.100.100.0 0.0.0.255

Configuration on R2.

router eigrp 1
 maximum-paths 6
 network 2.2.2.2 0.0.0.0
 network 100.10.10.0 0.0.0.255
 network 100.10.20.0 0.0.0.255
 network 100.20.10.0 0.0.0.255
 network 100.100.100.0 0.0.0.255

Thanks,
Sachin

Hello Sachin

EIGRP by default supports four equal cost load balancing routes when the metrics are the same. Your configuration should be showing traffic going over all four links. However, keep in mind that depending on how it is configured, the algorithm for load balancing may vary. If process switching is enabled, load balancing is on a per-packet basis. If fast switching is enabled, load balancing is on a per destination basis. This process is described in more detail in the following Cisco documentation which describes load balancing for various dynamic routing protocols:

Some commands that might help you further troubleshoot the issue include the show ip route X.X.X.X Y.Y.Y.Y command where the X and Y placeholders indicate the destination subnet of the load balanced route. The output of this command will show information in the form of:

Route metric is N, traffic share count is M

where N is the metric of the route, and M is the number of packets that have been routed via this particular route. Check out the value of M for each of the routes indicated in the output, and see if the numbers are going up evenly over time.

Also, using ping to test load balancing may not be the best. Ping sends very few packets, so unless you are pinging thousands of packets, the load balancing may not be very efficient. I suggest you try to send some FTP traffic over the links to see if you get a more evenly distributed load balancing.

I hope this has been helpful!

Laz

Hello sir ! let me know about EIGRP protocol what routes will be selected if both routes have same metric value to get the destination.

Hello Fargham

EIGRP is a protocol that can perform Equal Cost Load Balancing (ECLB). If a particular destination has two routes that are learned via EIGRP, both routes will be placed within the routing table, and load balancing will be performed between those two paths by default. EIGRP will load balance up to four equal cost paths by default, but can be configured to load balance between up to 16 equal cost paths.

By default, the load balancing algorithm that will be used works on a per destination basis. This means that one destination IP will be always be routed via the same route. The more destination IP addresses contained within the sum of traffic traversing the router at any one time will result in more effective load balancing. These algorithms can be changed however, to function on a per-packet algorithm if you choose to. More about such load balancing algorithms can be found here:

With EIGRP, it is also possible to load balance between routes that have a different metric value. This is called unequal cost load balancing, and you can find out more about it at the following lesson:

I hope this has been helpful!

Laz

Hi Rene/Laz

In order to set the speed of the R1-R2 link to 10Mb/s I used the bandwidth 10000 command under the interface configuration. A show interface f0/0 on the router then shows BW 10000 Kbit and Full-Duplex, 100Mb/s. My questions are:

  1. Does this mean the interface is actually running at 100Mb/s
  2. in its metric calculation, does EIGRP use the BW figure or the speed (in this case 100) figure?

Thanks,
Phil

Hello Philip

On each interface you can configure speed and bandwidth.

The speed parameter is used to configure an Ethernet interface to function at a particular compatible speed that corresponds to the various types of Ethernet. Specifically, Ethernet, FastEthernet, GigabitEthernet, 10GigEthernet, 40GigEthernet and so on. So the options available for this command depend on the port itself. If it is a GigabitEthernet port, then the options are 10, 100, or 1000 Mbps, as seen below:

Router(config-if)#speed ?
  10    Force 10 Mbps operation
  100   Force 100 Mbps operation
  1000  Force 1000 Mbps operation
  auto  Enable AUTO speed configuration

You also have the option of auto which negotiates the highest commonly supported speed. Now these commands change the actual speed at which a port will function. This in turn will also change the default value of the bandwidth (BW) to the value which corresponds to that speed. Notice below the output of a GigabitEthernet port that has been configured with a speed of 100:

image

The BW, which is in Kbps, is at 100000 which corresponds to 100 Mbps.

Now the BW can be changed from the default value to anything you want within the available range (the range depends on the platform), but such a change will not affect the actual speed of the interface. The BW value only affects the cost that a particular routing protocol will assign to that link.

So to summarize, changing the speed will change the actual physical throughput of an interface, and will also change the default BW value. The BW value can be adjusted to any value, but will not affect the actual throughput of the interface. It will however affect the metric calculation of the routing protocol in operation.

I hope this has been helpful!

Laz