EIGRP Default Network Route


(Rene Molenaar) #1

This topic is to discuss the following lesson:


(Frades) #2

thanks for this lesson rene. yeah i tried the ip default network command on ios 15 and it didnt work.
the one that work is creating a default route and advertise it with 0.0.0.0. but the problem is, it acts like advertise all the directly connected networks i have, R1 learn the network between R2 and ISP. i also try to add a loopback interface on R2 and suddenly R1 learns it.
is this the normal behavior of network 0.0.0.0? eventhough i have static route?


(Rene Molenaar) #3

Hi John,

That’s the normal behavior of the network command yes, I’ve explained it here:

Probably the best way to advertise a default route is to redistribute it into EIGRP:

ip route 0.0.0.0 0.0.0.0 null0 (if you don’t have a static route)

router eigrp 1
redistribute static metric 1 1 1 1 1

This will always work.

Rene


(Robert G) #4

Hi Rene,

Is there a tutorial on EIGRP default routes using redistribution?

Cheers
Rob


(Rene Molenaar) #5

Hi Rob,

I don’t have a separate tutorial for it but I can explain how to do it here:

R1(config)#ip route 0.0.0.0 0.0.0.0 null0

R1(config)#router eigrp 1
R1(config-router)#redistribute static metric 1 1 1 1 1 route-map DEFAULT_ONLY

R1(config)#route-map DEFAULT_ONLY permit 10
R1(config-route-map)#match ip address prefix-list DEFAULT_ROUTE

R1(config)#ip prefix-list DEFAULT_ROUTE permit 0.0.0.0/0

The default route to the null0 interface is only needed if you don’t have a default route in your routing table. The route-map with prefix-list is used to make sure that only the default route gets redistributed.

Rene


(Shashank D) #6

hi Rene,
In the case of ip default network as u explained above, I don’t understand why we need to configure a default route on R2 for the network 192.168.23.3 as in R1 it already shows * next to the “D” for this EIGRP entry.

Shashank


(Rene Molenaar) #7

Hi Shashank,

The 192.168.23.0 /24 network is used as the default network which means R1 will send packets with an unknown destination there. However, R2 still has to know where to forward packets to…it has no clue how to reach 3.3.3.0 /24 so that’s why we need the default route.

Rene


(Tim W) #8

As an EIGRP default routing alternative, why not this?:

R2(config)#int fa1/0

R2(config-if)#ip summary-address eigrp 12 0.0.0.0 0.0.0.0

Wouldn’t that work?


(Rene Molenaar) #9

Hi Tim,

Yep that’s a perfect example. The only downside is that you have to do it on the interface level but it will work :slight_smile:

Rene


(Hussein Samir) #10

Hi Rene,

What is the benefit of redistribute connected network ?

I noticed in your answer to John you have used “redistribute connected metric 1 1 1 1 1” command to redistribute the static route that you have configured it beforehand, but I did not understand why you used “connected” keyword instead of “static” keyword ? and when we redistribute connected network ?

thanks.

Hussein Sameer


(Rene Molenaar) #11

Hi Hussein,

I see I made an error there, it should be “redistribute static” (just edited it).

Redistribute connected only redistributes directly connected interfaces into EIGRP.

Rene


(Kay A) #12

I enjoy your site very much! Thank you for all the great information!

Regarding this statement -

"In EIGRP we can use the network 0.0.0.0 command to advertise this. This might sound strange but it works, normally you can only use the network command to advertise networks on interfaces but EIGRP wil [sic] make an exception for this default route."
Rather than an exception, isn't this the equivalent of "network 0.0.0.0 255.255.255.255"? EIGRP will use a classful wildcard if none is provided, so 0.0.0.0 will count as a class A.

Testing on IOS 15.2(4), “network 0.0.0.0” enables EIGRP for all interfaces. If you have any static routes to Null0 (default or not), these count as a directly connected interface (this can be confirmed by “sh ip route”) and thus are also advertised. Likewise, “redistribute connected” should also work for Null0 static routes, though they will count as EIGRP external routes.


(Rene Molenaar) #13

Hi Kay,

This has been awhile so I just had to check it again. You are correct, if you use network 0.0.0.0 then it will advertise a default route + activates EIGRP on all interfaces with a subnet on it.

I think that this behavior is different though on the older IOS versions but I’d have to check it. I thought that on older versions it would only advertise the interfaces, not the default route (even if you have one)…would have to check to confirm this though.

Rene


(Mohammad R) #14

Hi Rene

The ip default-network command works on IOS 12.4 but it doesn’t work on IOS 15 anymore.

I tested and did not work!!

what should i do in new version

and why change version 12

Thanks

 


(Rene Molenaar) #15

Hmm I should try that. The command is still accepted right?

The easiest method is probably advertising a default route through redistribution or by using the summary-address command on an interface. I never really liked the ip default-network command.


(Philipp K) #16

Rene you should give this section a rewrite - you suggest 2 methods which are both not mentioned by cisco and are partly legacy.

Default-route injection into eigrp should be done via redistribution (prefered) or via summarization on the interface:

We should be aware of all possible methods but always prefer the best practices from cisco.


(Rene Molenaar) #17

Hi Philipp,

I’ll take another look, might be a good idea to edit this one.

Rene


(aravind c) #18

Hi Rene,

I am trying to emulate this scenario in GNS 3 but strangely, eigrp adjacency is not forming b/w R1 and R2.

R1#sh run | b router eigrp
router eigrp 1
 network 192.168.12.0
 no auto-summary

R2#sh run | b router eigrp
router eigrp 1
 network 192.168.12.0
 network 192.168.23.0
 no auto-summary

R1#sh ip ei nei
IP-EIGRP neighbors for process 1

R2#sh ip ei nei
IP-EIGRP neighbors for process 1

R1#sh ip prot
Routing Protocol is "eigrp 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
  Redistributing: eigrp 1
  EIGRP NSF-aware route hold timer is 240s
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    192.168.12.0
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: internal 90 external 170

R2#sh ip proto
Routing Protocol is "eigrp 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
  Redistributing: eigrp 1
  EIGRP NSF-aware route hold timer is 240s
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    192.168.12.0
    192.168.23.0
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: internal 90 external 170

R1#sh ip ei to
IP-EIGRP Topology Table for AS(1)/ID(192.168.12.1)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 192.168.12.0/24, 1 successors, FD is 281600
        via Connected, FastEthernet0/0

R2#sh ip ei to
IP-EIGRP Topology Table for AS(1)/ID(192.168.23.2)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 192.168.12.0/24, 1 successors, FD is 281600
        via Connected, FastEthernet0/1
P 192.168.23.0/24, 1 successors, FD is 28160
        via Connected, FastEthernet1/0

Please advise as to why the neighborship is not forming. Have I done anything wrong in configs?

Thanks

Aravind


(Andrew P) #19

I can tell by your output that you are using 12.x code :slight_smile: (that doesn’t matter–just an observation).

I don’t see anything obviously wrong here. Obviously, you have done the basics like ensuring your interfaces are “no shut” and that R1 and R2 have connectivity?

Maybe put paste in a show run so we can see everything.


(aravind c) #20

Hi Andrew,

I am using c3725-adventerprisek9-mz.124-15.T10.bin as IOS image file.

I have attached running configs from R1, R2 & ISP for your review.

Thanks

Aravind