EIGRP Offset list

Hi

I have configured EIGRP offset list letting R-1 to learn routes from Serial0/1/0 instead of Fastethernet. But does not seem to work.

Please help me

Thanks
Ahmed

R-1#sho ip int brief
Interface                  IP-Address      OK? Method Status                Prol
FastEthernet0/0            192.168.11.1    YES manual up                    up
FastEthernet0/1            unassigned      YES unset  administratively down dow
Serial0/0/0                      unassigned      YES unset  administratively down dow
Serial0/1/0                    192.168.13.1    YES manual up                    up
Loopback200                172.22.200.1    YES manual up                    up
Loopback201                172.22.201.1    YES manual up                    up
R-1#

interface Loopback200
 ip address 172.22.200.1 255.255.255.0
!
interface Loopback201
 ip address 172.22.201.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.168.11.1 255.255.255.0
 duplex auto
 speed auto


interface Serial0/1/0
 description 2_R-3
 ip address 192.168.13.1 255.255.255.0
!
!
router eigrp 123
 network 172.22.200.0 0.0.0.255
 network 172.22.201.0 0.0.0.255
 network 192.168.11.0 0.0.0.255
 network 192.168.13.0 0.0.0.255
 offset-list 12 in 659000 Serial0/1/0

!
access-list 12 permit 10.10.8.0 0.0.7.255

R-1#sho ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/24 is subnetted, 5 subnets
D        10.10.11.0 [90/156160] via 192.168.11.2, 00:14:28, FastEthernet0/0
D        10.10.12.0 [90/156160] via 192.168.11.2, 00:14:28, FastEthernet0/0
D        10.10.13.0 [90/156160] via 192.168.11.2, 00:14:28, FastEthernet0/0
D        10.10.14.0 [90/156160] via 192.168.11.2, 00:14:28, FastEthernet0/0
D        10.10.15.0 [90/156160] via 192.168.11.2, 00:14:28, FastEthernet0/0
D     192.168.31.0/24 [90/30720] via 192.168.11.2, 00:14:28, FastEthernet0/0

-

R-3#sho ip int brief
Interface                  IP-Address      OK? Method Status                Prol
FastEthernet0/0            192.168.31.3    YES manual up                    up
FastEthernet0/1            unassigned      YES unset  administratively down dow
Serial0/0/0                      192.168.13.3    YES manual up                    up
Serial0/0/1                      unassigned      YES unset  administratively down dow
Serial0/1/0                     unassigned      YES unset  administratively down dow
Serial0/1/1                     unassigned      YES unset  administratively down dow

interface FastEthernet0/0
 ip address 192.168.31.3 255.255.255.0
 duplex auto
 speed auto

interface Serial0/0/0
 ip address 192.168.13.3 255.255.255.0
 clock rate 2000000

router eigrp 123
 network 192.168.13.0
 network 192.168.31.0

R-3#sho ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/24 is subnetted, 5 subnets
D        10.10.11.0 [90/156160] via 192.168.31.2, 00:22:30, FastEthernet0/0
D        10.10.12.0 [90/156160] via 192.168.31.2, 00:22:25, FastEthernet0/0
D        10.10.13.0 [90/156160] via 192.168.31.2, 00:22:21, FastEthernet0/0
D        10.10.14.0 [90/156160] via 192.168.31.2, 00:22:17, FastEthernet0/0
D        10.10.15.0 [90/156160] via 192.168.31.2, 00:22:12, FastEthernet0/0
      172.22.0.0/24 is subnetted, 2 subnets
D        172.22.200.0 [90/158720] via 192.168.31.2, 00:18:22, FastEthernet0/0
D        172.22.201.0 [90/158720] via 192.168.31.2, 00:18:22, FastEthernet0/0
D     192.168.11.0/24 [90/30720] via 192.168.31.2, 00:18:22, FastEthernet0/0

L3-3560

L3-3560#sho ip int brief
Interface              IP-Address      OK? Method Status                Protocol
Vlan1                  unassigned      YES unset  administratively down down
FastEthernet0/1        192.168.11.2    YES manual up                    up
FastEthernet0/2           unassigned      YES unset  up                    up
FastEthernet0/3        192.168.31.2    YES manual up                    up

Loopback10             10.10.10.1      YES manual up                    up
Loopback11             10.10.11.1      YES manual up                    up
Loopback12             10.10.12.1      YES manual up                    up
Loopback13             10.10.13.1      YES manual up                    up
Loopback14             10.10.14.1      YES manual up                    up
Loopback15             10.10.15.1      YES manual up                    up
L3-3560#

L3-3560#Show run
interface Loopback10
 ip address 10.10.10.1 255.255.255.0
!
interface Loopback11
 ip address 10.10.11.1 255.255.255.0
!
interface Loopback12
 ip address 10.10.12.1 255.255.255.0
!
interface Loopback13
 ip address 10.10.13.1 255.255.255.0
!
interface Loopback14
 ip address 10.10.14.1 255.255.255.0
!
interface Loopback15
 ip address 10.10.15.1 255.255.255.0
!
interface FastEthernet0/1
 no switchport
 ip address 192.168.11.2 255.255.255.0

interface FastEthernet0/3
 no switchport
 ip address 192.168.31.2 255.255.255.0

router eigrp 123
 no auto-summary
 network 10.10.11.0 0.0.0.255
 network 10.10.12.0 0.0.0.255
 network 10.10.13.0 0.0.0.255
 network 10.10.14.0 0.0.0.255
 network 10.10.15.0 0.0.0.255
 network 192.168.11.0 0.0.0.255
 network 192.168.31.0 0.0.0.255

no aaa new-model
ip subnet-zero
ip routing
no ip domain-lookup


L3-3560#sho ip route eigrp
D    192.168.13.0/24 [90/2172416] via 192.168.31.3, 00:28:12, FastEthernet0/3
                     [90/2172416] via 192.168.11.1, 00:28:12, FastEthernet0/1
     172.22.0.0/24 is subnetted, 2 subnets
D       172.22.200.0 [90/156160] via 192.168.11.1, 00:28:12, FastEthernet0/1
D       172.22.201.0 [90/156160] via 192.168.11.1, 00:28:12, FastEthernet0/1
L3-3560#

Ahmed,
Technically, speaking it should already be learning those routes from the Serial0/1/0, but it is just not selecting it as the best route and installing it in the RIB. You can confirm this by issuing the following on R1
#show ip eigrp topology all-links

This output will be important to you because it will tell you R1’s feasible distance (the first number in the XXX/YYY value next to a route) for both R3 and the MLS. In order for R1 to install the routes via R3 (over the serial), will like have to keep raising the Offset value until the number via the serial interface is less than the number via the MLS.

Here’s a sample output:

R1#sh ip eigrp top all
EIGRP-IPv4 Topology Table for AS(1)/ID(1.1.1.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status 

P 10.10.15.0/24, 1 successors, FD is 156160, serno 106
        via 13.13.13.3 (156160/128256), FastEthernet0/0
        via 12.12.12.2 (2300416/156160), Serial1/0

In the example above, if you want R1 to use the route towards 12.12.12.2, you will have to keep increasing the Offset until the number which is currently “156160” is higher than “2300416”.

One additional consideration:
EIGRP offset lists work by manipulating the “Delay” K value, and EIGRP expects this value to be the default of “1”. If, for some reason, you have changed the Delay K value to zero, the offset list will break. If you have set the K value to any value higher than 1, you will get a multiple of the offset value you have specified, rather than the actual value.