How to configure BGP neighborship behind firewall

Despite the fact that tcp 179 has been allowed through the ASA firewall, BGP neighborship is still not establishing. Is there a reason? There is still no connection between both BGP neighbors. What could the reason be? What is the solution?

Hello Patrice

The first thing that comes to mind is that if you are trying to establish an eBGP connection through a firewall, you must enable ebgp multihop, since you are adding a hop between the two devices. I’m assuming the devices for which you are creating the BGP neighbor adjacency are one behind the firewall and one in front of it… Take a look at this lesson:

Try this out, and if that’s not it, give us some more information about your topology so that we can help you investigate further.

I hope this has been helpful!