How to configure Frame-Relay Point-to-Point

Hi Rene ,

Why don’t we use the frame-relay map command for point-to-point sub-interfaces ? what will happen if we turn off IARP .? what about the keyword broadcast ?

can you have lesson how to configure frame relay back to back? I have two Cisco routers 2800 each with a T1 card.

Thank you

Hi Hoan,

Here’s an example:

R1#show run int s0/0/0
Building configuration...

Current configuration : 141 bytes
!
interface Serial0/0/0
 ip address 192.168.12.1 255.255.255.0
 encapsulation frame-relay
 no keepalive
 frame-relay interface-dlci 201
end
R2#show run int s0/0/0
Building configuration...

Current configuration : 159 bytes
!
interface Serial0/0/0
 ip address 192.168.12.2 255.255.255.0
 encapsulation frame-relay
 no keepalive
 clock rate 64000
 frame-relay interface-dlci 201
end
R1#show frame-relay pvc | include PVC
PVC Statistics for interface Serial0/0/0 (Frame Relay DTE)
DLCI = 201, DLCI USAGE = LOCAL, PVC STATUS = STATIC, INTERFACE = Serial0/0/0
R2#show frame-relay pvc | include PVC
PVC Statistics for interface Serial0/0/0 (Frame Relay DTE)
DLCI = 201, DLCI USAGE = LOCAL, PVC STATUS = STATIC, INTERFACE = Serial0/0/0
R1#ping 192.168.12.2                 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.12.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/32 ms

Rene

19 posts were merged into an existing topic: How to configure Frame-Relay Point-to-Point

Hi,
We are using the same topology with one difference. Point-to-point links require an IP Subnet per PVC:
Why is that one subnet per pvc ?
Thanks

Hello Sims

There are a couple of options for creating a frame relay topology.

If you have multiple sites, you can place all routers from all the sites on one subnet like so:

Notice that all serial interfaces are on the same subnet of 10.1.1.0/24. This topology does not require a separate subnet for each link, but one subnet for all routers. This requires the employment of a static frame relay map to map between a next hop protocol address and a DLCI destination address. This is done using the frame-relay map protocol protocol-address dlci [broadcast] command. Notice the broadcast keyword at the end of the command which indicates that this is a pseudo-broadcast implementation because frame-relay does not natively support broadcasts.

Concerning point to point links in frame relay, each link MUST have a separate subnet. This is the case in the following diagram:

In this case, one subinterface is created for each point to point link and each link between two subinterfaces has a separate subnet. The advantage of this is that routing protocols such as OSPF can function without the need for specialised commands such as removing split-horizon rules and such.

I hope this has been helpful!

Laz

why we need IGP protocols like eigrp and ospf in Frame relay ?

Hi Shiva,

By default, routers will only know networks on their directly connected interfaces so if you want to reach any other network, you’ll need routing.

For example, let’s say we have a hub and two spoke routers that use a serial 0/0 interface and the 192.168.123.0/24 network.

On the spoke1 router, we also have a Gigabit 0/0 interface with network 192.168.1.0/24. If you want the hub or spoke2 router to reach this network, they’ll need to know how to get there. You can achieve this by configuring a static route on the hub and spoke2 router or you configure a routing protocol to advertise the network.

Rene

Hello Rene, I am having issue to set up ospf on my frame relay in GNS3. Below is my configs and topology:

HQ#show run int s2/0
Building configuration...

Current configuration : 263 bytes
!
interface Serial2/0
 ip address 192.168.123.1 255.255.255.0
 encapsulation frame-relay
 ip ospf 1 area 0
 serial restart-delay 0
 frame-relay map ip 192.168.123.3 103 broadcast
 frame-relay map ip 192.168.123.2 102 broadcast
 no frame-relay inverse-arp
 !
end

HQ#show ip protocols
Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 192.168.123.1
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
  Routing on Interfaces Configured Explicitly (Area 0):
    Serial2/0
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 110)

HQ#ping 192.168.123.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.123.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/44/52 ms

Site_2#show run int s2/2
Building configuration...

Current configuration : 215 bytes
!
interface Serial2/2
 ip address 192.168.123.3 255.255.255.0
 encapsulation frame-relay
 ip ospf 1 area 0
 serial restart-delay 0
 frame-relay map ip 192.168.123.1 301 broadcast
 no frame-relay inverse-arp
 !
end

Site_2#show ip protocols
Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 192.168.123.3
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
  Routing on Interfaces Configured Explicitly (Area 0):
    Serial2/2
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 110)

Site_2#ping 192.168.123.1
Sending 5, 100-byte ICMP Echos to 192.168.123.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/51/80 ms

Hello sales2161

Frame-relay can be tricky when implemented with OSPF. Can you tell us a little bit more about your configuration? Please specify in more detail the problem that you’re facing so that we can address it more effectively.

Thanks!

Laz

1 Like

@lagapides - HQ and Site_2 can’t form adjacencies.

Can you please reply to my query? I am still having issues with forming adjacency. Thanks

Hello sales2161

If you look at this lesson, you will find information concerning the implementation of OSPF in a frame relay environment:

Now based on your configuration, what I do see immediately is that in your frame relay interfaces, you are missing the ip ospf network broadcast command. This changes the default OSPF network type to allow for broadcasts to be sent over non broadcast topologies such as frame relay and to allow them to create OSPF adjacencies.

Take a look at the lesson and see if this command solves your problem.

I hope this has been helpful!

Laz

1 Like

Hello @lagapides, it worked thanks! but I was thinking when we add the “broadcast” keyword at the end of frame-relay mapping, it was going to do the same thing as “ip ospf network broadcast command”?

Hello sales2161

In order for OSPF to function, you require the broadcast keyword for both the frame-relay map command and the ip ospf network command. If you don’t do this, you can always make OSPF work by manually configuring the neighbors.

I hope this has been helpful!

Laz

1 Like

Hello NetworkLessoms Team.
Which statement below about Frame-Relay Point-to-Point connections is true?

  1. they use two DLCIs to communicate with multiple endpoints over Frame Relay cloud;
  2. they can operate normally without DLCI map.

It seems both answers are true. But I think the best answer is 2. What does it mean “multiple endpoints” in 1st answer? Help please.

Thanks.

Hello Boris

You’re right, answer 1. is not very clear. However, if you have multiple endpoints in a point to point configuration, you will require a pair of DLCIs for each point to point link. Let’s say you have one hub and four spokes. You will need four pairs of DLCIs to communicate with all four spokes, so 1. seems incorrect.

The second statement is definitely true as you don’t need to configure DLCI mappings in order for point to point frame-relay to function.

I hope this has been helpful!

Laz

1 Like

Thank you very much.

1 Like

I’m still confused about Frame-Relay point-to-point and point-to-multipoint.
The article stated that the difference for Point-to-point is the IP subnet per PVC.
From my understanding, point-to-multipoint is for one same subnet. On the other hand, point-to-point is for different subnets. Is that correct?
I’ve compared two configurations and noticed two different things.

  1. In Point-to-multipoint, it’s using frame-relay map ip IP DLCI broadcast whereas in point-to-point, it’s using sub-interface. Is this just for personal preference as I thought we can config sub-interface in point-to-multipoint too.
  2. In Point-to-Point, there is a setting for RIP. Is that just for testing?

Thank you in advance.

Hello Po

Yes, this is correct. You’ll notice that point to point has two PVCs, and for each PVC, you have a different subnet. So for Hub to Spoke 1, you’re using 192.168.12.0/24 subnet and for Spoke 2 you’re using 192.168.13.0/24 subnet. Each one of those subnets corresponds to a different subinterface on the S0/0 interface of the Hub.

For point to multipoint on the other hand, all three devices are in the 192.168.123.0/24 subnet as if they are on the same broadcast domain or network segment.

Now in order to make this work, because Frame-Relay doesn’t intrinsically support all related features, additional configurations must be made, as you correctly pointed out. For example:

  1. Point to multipoint must have inverse ARP enabled by default. This allows Frame-relay to dynamically learn the DLCI of the spoke that belongs to the IP address we’re looking for. Point to point doesn’t need this to function. Alternatively, Frame-relay mappings of IP addresses to DLCIs must be manually configured.
  2. Similarly, the broadcast must be included in order to tell Frame-Relay to simulate broadcasts and multicast so that all devices in the subnet will receive them. When inverse ARP is enabled, this too is enabled by default. If inverse ARP is removed, then the broadcast keyword must be used when creating the frame-relay mappings.
  3. For point to multipoint, subinterfaces are used on the hub simply because only a single serial connection comes into the premises. Subinterfaces eliminate the need for multiple physical channels. Both point to point and point to multipoint can easily use subinterfaces, or physical interfaces to function, as long as there are enough physical circuits to accommodate the requirements in each case.

In the lesson this is simply demonstrating how you can enable a routing protocol over the topology so that you can route traffic between the subnets that each of the routers serves. One of these is represented by the loopback address on Spoke 1. This RIP configuration could be implemented on the point to multipoint topology as well.

I hope this has been helpful!

Laz