How to configure IPv6 EIGRP on Cisco IOS Router


(Rene Molenaar) #1

This topic is to discuss the following lesson:


(Rene Molenaar) #2

Very helpful and easy to learn!


(Frades) #3

easy to understand! thanks!
just fyi, i simulate it on GNS3, using 7200 15.2ios. under ipv6 router eigrp 1, theres no “router-id” command, you need to go “eigrp router-id 1.1.1.1”


(Pavithra V) #4

The neighbor of futura router is FE80::C00F:1AFF:FEA7:0, But this IP doesnot show in output of Destiny#show ipv6 interface brief. Is there some output error of show ipv6 interface brief of both the routers??


(Rene Molenaar) #5

Hi Pavithra,

I think I had a copy/paste error here. Just fixed the show commands, they are showing the correct addresses now.

Rene


(Brian C) #6

I also did this lab and just as the first poster stated there is no Router-ID command.

note I tested this on the newest cisco VIRL IOS that I have imported into GNS3 and I also tested on the 7200 model. So neither of the routers can use this command. this means it must be something legacy or a typo. also the 7200 gns3 image is quite a bit older than the newer cisco VIRL image that both did not work says this has probably not been an option for a while.

===================================EDITED==================================================

I did go back and just type it in though and it worked… so it cannot use the help command but If you type it in that seems to take.

see below:


(Rohan H) #7

EIGRP was sending HELLOs only on my Loopback0 interface despite “ipv6 enable” on my FastEthernet interface. Neighbor adjacency was formed only after adding a global unicast IP on my FastEthernet interface connecting my routers.

Rohan


(Lazaros Agapides) #8

Hello Rohan

I tried to replicate your description, however I was able to get a neighbor adjacency without global unicast addresses on the interfaces. You might want to try to restart the EIGRP process or try bouncing the interfaces to get the adjacency to form.

Try it out again and let us know your results.

I hope this has been helpful!

Laz


(Samer A) #9

Hi,
It would be great to add EIGRP v6 in named mode in here as well…thanks.


(Rene Molenaar) #10

Hi Samer,

I do have an example for IPv4 EIGRP named mode:

I’ll see if I can update it for IPv6.

Rene