How to configure trunk on Cisco Catalyst Switch

This topic is to discuss the following lesson:

You have a very unique way of explaining, Clear and direct to the point. I am very grateful.
Thank you

I really appreciate your efforts :slight_smile:

Hi ,
Im following you LAB but i would like to know how to change the Operational Mode
status .
Every times i would like to change it , it doesn’t work .

#sh int Fa0/21 switchport
Name: Fa0/21
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: down <—
Administrative Trunking Encapsulation: dot1q
Negotiation of Trunking: Off
Access Mode VLAN: 50 (TesteIMO(NOTOUCH))
Trunking Native Mode VLAN: 1 (default)
Voice VLAN: none

Thanks for your help .

Can u check whether u made it no shut?

Please clarify how to interpret the table you listed in the page below with different modes

The horizontal values are for “switch 1” and the vertical values for “switch 2”.

For example, if you use “dynamic auto” on switch 1 and 2 then the result will be access mode.

Hi Rene,
Network operators knows which ports are connected to switch and hosts. They can configure access mode or trunk mode accordingly.
Why do we need Dynamic access and Dynamic auto ? In what scenario we use it in
production network?

Thanks,
SV

Hi SV,

I can’t think of any good reason to use dynamic auto or desirable. It’s best always to use static access or trunk mode.

Rene

Hi Rene,
Thanks for your quick reply!

-SV

Rene, question, on your last compare example, its static access and static trunk, the result was trunk on both sides, so its a working trunk port? but on your table that you created, the Static Trunk and Static Access has a “Limited” value. care to explain why its Limited? and what does it do on the switch?

Hi John,

When you mix access and trunk mode, we get to see this message:

SwitchA#
%SPANTREE-7-RECV_1Q_NON_TRUNK: Received 802.1Q BPDU on non trunk FastEthernet0/14 VLAN1.
%SPANTREE-7-BLOCK_PORT_TYPE: Blocking FastEthernet0/14 on VLAN0001. Inconsistent port type.
%SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking FastEthernet0/14 on VLAN0001. Port consistency restored.

The trunk will send BPDUs for each VLAN, our access mode interface only sends one BPDU so that’s why CDP reports this error. This won’t be a working trunk but I think the access mode VLAN (VLAN1) will work.

I’d have to give this a try to see if it works.

Rene

Thanks .

It’s awesome.

Rene

how do you turn trunk negotiation back on?

Hi Donald,

“switchport nonegotiate” disabled it and “no switchport nonegotiate” enables it again.

Rene

Hi Rene

Please can you advise what I can do, I am trying to create vlan 50 on this switch and keep getting following

SW1(config)#vlan 50
VTP VLAN configuration not allowed when device is not the primary server for vlan database.
SW1#sh vtp status
VTP Version : 3 (capable)
VTP version running : 3
VTP Domain Name : CCIE-domain
VTP Pruning Mode : Disabled (Operationally Disabled)
VTP Traps Generation : Disabled
Device ID : aabb.cc00.0700

Feature VLAN:
&#45;&#45;&#45;&#45;&#45;---------
VTP Operating Mode : Server
Number of existing VLANs : 8
Number of existing extended VLANs : 0
Configuration Revision : 0
Primary ID : 0000.0000.0000
Primary Description :
MD5 digest : 0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00
0x00 0x00 0x00 0x00 0x00 0x00 0x00 0x00
Feature MST:
&#45;&#45;&#45;&#45;&#45;---------
VTP Operating Mode : Transparent
Feature UNKNOWN:
&#45;&#45;&#45;&#45;&#45;---------
VTP Operating Mode : Transparent

 

I tried deleting vlan.dat but to no avail

 

Thanks

 

 

 

You are running VTP version 3 but it seems this switch is not the primary switch so you can’t make any changes to the VLAN database. Here’s an example how to configure VTPv3:

Or you can switch back to VTP version 2.

Dear Rene

i’m new here i finished before some week from CCNA I want to study CCNP with you the explanation is very good.this command:

switchport trunk encapsulation dot1q

Is not working in my packet tracer how can I make a switching lab ??

Hi Mohamed,

There are two trunking protocols, 802.1q and ISL. Some newer switches only support 802.1Q and in that case this command will be unavailable.

It’s also possible that packet tracer doesn’t support it, it’s a simulator after all. It doesn’t matter too much though…when this command doesn’t work then the switch will use 802.1Q when you configure the interface as a trunk.

Rene

what type of switches are you suggesting we use