I am having difficulty uploading new IOS to Cisco 2901

The IOS that was shipped with of our Cisco 2901 was some how deleted.

I got another IOS (c2900-universalk9-mz.SPA.157-3.M4a) but I am not able to upload.

I tried XMODEM, but it was not transferred.

I tried using a good USB(4GB FAT file system), but the router would not recognize the USB.

I tired using tftpd64, I did not make a headway.

I removed the flash and put it in a Cisco 1901 , but I still cannot upload IOS to the flash.

Kindly help.Thanks

Hello Samuel

If you have a router that has no IOS, then the options you have are limited to you. The methods are essentially the ones you mentioned above including XMODEM, USB or tftpd64. In each case, if your attempt failed, then you must look at the reasons it failed, the error messages that you may have recieved, and the result of the attempt in order to further troubleshoot and resolve the problem. It could simply be that the flash is corrupt, but you will determine this from the error messages you get upon failure.

I hope this has been helpful!


Hello Lazarus,

Thank you for your response. Concerning the USB option, the router does not recognize the USB at all.
Do you know if there is any special USB that Cisco recommends? Thanks

Hello Samuel

The USB drive should be formatted using FAT32 and not NTFS. Also, if you find that it is still not working, try FAT16 as the format. Sometimes it’s just a matter of compatibility between the USB drive and the device. Can you try a couple of other USB sticks to see if they work?

Secondly, if you do end up getting your USB drive recognised, you can make your router boot up from the USB drive directly using the following ROMMON command:

boot usbflash0:ios_file_name.bin

Once the router is booted, you can then copy the file as you normally would using IOS commands.

Hopefully it’s just a USB stick compatibility issue. Try these out and let us know your results.

I hope this has been helpful!