iBGP cant reach eBGP, but eBGP can reach the iBGP

Hi Guys,

I’m labbing out trying to modify path attributes. However, I can’t seem to get past the issue being this:

My loopback from an iBGP router(1.1.1.1) can reach the eBGP loopback and physical interface IPs from a different AS(200).

Here is my simple diagram below:

Here are my configurations:
R1

router ospf 100
 network 0.0.0.0 255.255.255.255 area 0
!
router bgp 100
 bgp router-id 1.1.1.1
 bgp log-neighbor-changes
 network 1.1.1.0 mask 255.255.255.0
 neighbor 2.2.2.2 remote-as 100
 neighbor 2.2.2.2 update-source Loopback0
 neighbor 3.3.3.3 remote-as 100
 neighbor 3.3.3.3 update-source Loopback0
!

=======================================
R2

router ospf 100
 network 0.0.0.0 255.255.255.255 area 0
!
router bgp 100
 bgp router-id 2.2.2.2
 bgp log-neighbor-changes
 neighbor 1.1.1.1 remote-as 100
 neighbor 1.1.1.1 update-source Loopback0
 neighbor 1.1.1.1 next-hop-self
 neighbor 3.3.3.3 remote-as 100
 neighbor 3.3.3.3 update-source Loopback0
 neighbor 4.4.4.4 remote-as 200
 neighbor 4.4.4.4 ebgp-multihop 2
!
ip route 4.4.4.0 255.255.255.0 192.168.1.2
!

==========================================
R3

router ospf 100
 network 0.0.0.0 255.255.255.255 area 0
!
router bgp 100
 bgp router-id 3.3.3.3
 bgp log-neighbor-changes
 neighbor 1.1.1.1 remote-as 100
 neighbor 1.1.1.1 update-source Loopback0
 neighbor 1.1.1.1 next-hop-self
 neighbor 2.2.2.2 remote-as 100
 neighbor 2.2.2.2 update-source Loopback0
 neighbor 4.4.4.4 remote-as 200
 neighbor 4.4.4.4 ebgp-multihop 2
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip route 4.4.4.0 255.255.255.0 172.16.1.2
!

=============================================
R4

router bgp 200
 bgp router-id 4.4.4.4
 bgp log-neighbor-changes
 network 8.8.8.0 mask 255.255.255.0
 network 9.9.9.0 mask 255.255.255.0
 neighbor 2.2.2.2 remote-as 100
 neighbor 2.2.2.2 ebgp-multihop 2
 neighbor 2.2.2.2 update-source Loopback0
 neighbor 3.3.3.3 remote-as 100
 neighbor 3.3.3.3 ebgp-multihop 2
 neighbor 3.3.3.3 update-source Loopback0
!
ip route 2.2.2.0 255.255.255.0 192.168.1.1
ip route 3.3.3.0 255.255.255.0 172.16.1.1
!

Here are my traceroute results from R1 trying to get to R4’s interface IP as well as the loopbacks:

Is the iBGP split horizon the culprit?

Any help will be greatly appreciated!

KB

Hello Kyle

At first, I thought it may have to do with the next-hop-self feature, but I see that you’ve configured it. I also see in your traceroutes that the correct next-hop router is being reached for each particular trace. However, I think I’ve found the problem.

You’ve advertised looback 1.1.1.1 using BGP so R4 should have a route to 1.1.1.1. However, when you traceroute, the source interface from which the traceroute takes place is from “the closest interface to the destination.” That would be either 10.0.1.1 or 203.0.113.1. So any return traffic from R4 would have to have one of those two addresses as the destination address.

However, R4 has no route to those addresses, therefore the communication fails. I suggest you ping from R1 to one of the destination addresses at R4 using the source address of 1.1.1.1. You should be successful if you try. Let us know your results!

I hope this has been helpful!

Laz

Hi Laz,

Yeah, I goofed it there. Turns out I can reach end to end connection, I just have to add a source IP of 1.1.1.1 when pinging from R1 for it to work. Might had too much BGP for one day, lol.

Thanks!

1 Like