Inter-VLAN routing - Can't ping between VLANs

I have a network with no routers but 25 layer 3 IE3000 switches with no Internet access. I’m unable to ping between VLANs and get “Destination unreachable” most times. But able to ping between devices on VLAN 1 on all parts of the network. I think I’m missing an ip route statement but not sure what to point it to if there is no router. I am running Layer 3 on all switches via ip routing statement.

  • I can ping from a host to the default GW of the VLAN that they belong to.
  • I know the trunks are working because I can ping VLAN 1 from any part of the network.
  • Sho IP route only shows those VLANs with hosts connected to them - which is usually normal.
  • Port-Channel 1 will be applied to port 0/7 and 0/8 when this problem is remedied. Port-channels will not be applied on all switches.
  • VLAN 111 and VLAN 112 are supposed to be L3 trunk interfaces between the switches.

Thanks for your help …

version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch2
!
!
!
!
!
!
!
ip routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode rapid-pvst
!
!
!
!
!
!
interface Port-channel 1
 description *** SW01-SW02 LAG ***
 switchport trunk native vlan 99
 switchport trunk allowed vlan 101-103,111-112
!
interface FastEthernet0/1
 switchport access vlan 101
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/2
 switchport access vlan 102
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/3
 switchport access vlan 103
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
 switchport trunk native vlan 99
 switchport trunk allowed vlan 100-101,111-112
!
interface FastEthernet0/8
 switchport trunk native vlan 99
 switchport trunk allowed vlan 100-101,111-112
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
 description *** L3 LINK TO SW02-Gi1/1 ***
 switchport trunk native vlan 99
 switchport trunk allowed vlan 100-101,111-112
!
interface GigabitEthernet0/2
 switchport trunk native vlan 99
 switchport trunk allowed vlan 100-101,111-112
!
interface Vlan1
 ip address 10.1.1.26 255.255.255.0
!
interface Vlan101
 ip address 10.30.1.2 255.255.255.240
!
interface Vlan102
 ip address 10.30.2.2 255.255.255.240
!
interface Vlan103
 ip address 10.30.3.2 255.255.255.240
!
interface Vlan112
 ip address 10.30.0.5 255.255.255.252
!
ip default-gateway 10.1.1.1
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
end

Hello Roy,

When you try to ping an IP address from a host where the destination is outside of its local subnet, then you will need a default gateway.

If your IE3000 switches have the correct image then you should be able to use them for routing. There’s a couple of things you need:

  • First you should enable ip routing. It will now build a routing table.
  • Now you need to configure an IP address on an SVI or L3 interface. This IP address can be used as the default gateway for your hosts.

Take a look at this example:

InterVLAN Routing

Look for the “SVI (Switch Virtual Interface)” and “Routed Port” examples.

In your configuration, you can see the SVI interfaces:

interface Vlan101
 ip address 10.30.1.2 255.255.255.240
!
interface Vlan102
 ip address 10.30.2.2 255.255.255.240

If IP routing is enabled then a host in VLAN 101 can use 10.30.1.2 as its default gateway and a host in VLAN102 can use 10.30.2.2 as the default gateway. This allows the hosts to communicate from VLAN 101 to 102.

When IP routing is enabled, you can remove this command:

ip default-gateway 10.1.1.1

This is only used when IP routing is disabled.

Hope this helps.

Rene