So I have a nexus 3k and a nexus 7k. Both I’m setting up a vlan interface and/or a management interface for the RPs. The router on the network is an ASR 1001. I’m trying something rather simple that works on every other device except the 3k and 7k devices and that is router discovery over IPv6 from the ASR to the interfaces connecting. The configs are this simple:
interface TenGigabitEthernet0/1/0.198
encapsulation dot1Q 198
vrf forwarding relay_admin
ipv6 address 2600:2100:ae0:13b::1/64
ipv6 address FE80::FEED:198:1 link-local
ipv6 enable
ipv6 nd router-preference High
And the N3K interface look like the following:
interface Vlan198
ipv6 address 2600:2100:ae0:13b:0:acc5:88:4/64
no shutdown
interface Ethernet1/1
switchport mode trunk
switchport trunk allowed vlan 98,198,298
When I look at the routing table on the N3k, I get the following:
IPv6 Routing Table for VRF "default"
'*' denotes best ucast next-hop
'**' denotes best mcast next-hop
'[x/y]' denotes [preference/metric]
2600:2100:ae0:13b::/64, ubest/mbest: 1/0, attached
*via 2600:2100:ae0:13b:0:acc5:88:4, Vlan198, [0/0], 2w1d, direct,
2600:2100:ae0:13b:0:acc5:88:4/128, ubest/mbest: 1/0, attached
*via 2600:2100:ae0:13b:0:acc5:88:4, Vlan198, [0/0], 2w1d, local
Looking at IOS/IOS-XR based switches and RPi’s, I do see the default route:
ND ::/0 [2/0]
via FE80::FEED:198:1, Vlan198
Debugging shows the RD’s being transmitted (also demonstrated by other devices picking them up) but none of the NXOS based devices are inserting the route in their tables. Is there something on the NXOS device that I’m missing?