L2TPv3 (Layer 2 Tunnel Protocol Version 3)

This topic is to discuss the following lesson:

Hi, could someone tell me if multicast traffic can be trasmited over L2tpv3 tunnel.

Hi Rafael,

That is no problem. Here’s a quick example where I run OSPF on hosts in the topology I used to test L2TPv3:

H1 & H2
(config)#router ospf 1
(config-router)#network 192.168.1.0 0.0.0.255 area 0

And we get neighbors:

H1#show ip ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.1.102     1   FULL/DR         00:00:38    192.168.1.102   GigabitEthernet0/1

Hope this helps!

Rene

Hi Rene, thanks for your answer.

regards

I have an interesting question - what happens if you have multiple VLANs running and you want to trunk all of them instead of just 1 VLAN? :crab:

Hi Chris,

This is no problem.

H1:

H1#
interface GigabitEthernet0/1.100
 encapsulation dot1Q 100
 ip address 192.168.100.101 255.255.255.0

H2:

H2#
interface GigabitEthernet0/1.100
 encapsulation dot1Q 100
 ip address 192.168.100.102 255.255.255.0

And a ping:

H1#ping 192.168.100.102  
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.100.102, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/9/12 ms

Rene

Can only use just Point-to-Point? How about Point-to-Multipoint ?

Hello Kyi

Unfortunately L2TPv3 is a point to point technology. However, you can create multiple point to point L2TPv3 connections to achieve a similar result.

I hope this has been helpful!

Laz

Hello Rene

was going to CCIE written blue print…not able to find this 2 topic in l3vpn tunneling section
please can you help or i am missing …
4.1.h (i) MPLS-VPLS general principals
4.1.h (ii) OTV general principals

Hi Prashant,

I just added something that explains MPLS/VPLS basics to 4.1.h.

About OTV, In the Cisco Press book, there are only about 9 lines about it so it’s a minor topic for R&S written. That makes sense since it’s a DC topic. I don’t have a full lesson for this yet.

OTV (Overlay Transport Virtualization) is an overlay network where we transport L2 Ethernet over an L3 network. OTV uses IS-IS for adjacencies and to exchange MAC info on the control plane.

It is supported on IOS XE so I’ll see if I can lab this up.

Rene

Hi, in this scenario, is necessary to adjust ip mtu and mss?. As i know, l2tpv3 generate a virtual tunnel that add 4 bytes, this can overeade the maximum MTU that can support an Ethernet of 1500 bytes… i’m right?

Hello Max

Yes, it may be necessary in some implementations to tune the MTU for the operation of the tunnel. A detailed look at MTU related issues with L2TPv3 can be found at this Cisco documentation:

I hope this has been helpful!

Laz

1 Like

Hi,
What if pc1 and pc2 are in different vlan
Thanks

Hello Sims

The purpose of L2TPv3 is to connect two devices that are on the same VLAN through a network that has one ore more routers in it. If the two PCs were not on the same VLAN, then L2TPv3 could not be used. There would need to be a router somewhere to employ routing. In such a case, you may have a router as one of the endpoints of the L2TPv3 tunnel which would then route to the destination PC in a different VLAN.

I hope this has been helpful!

Laz

Hi,
But I saw isps are providing two differnet vlan for wifi’s
Thanks

Hello Sims

If this is the case, then there will be a router somewhere between the two endpoints. However, if routing does take place, then the router must be one of the two endpoints of the L2TPv3 tunnel.

I hope this has been helpful!

Laz

Hi,
Thanks for the reply . It would be great if you clarify little bit .
Here is the topology . I would like how it works ( this is already running solution) .
I did not understand how it working .

Thanks

Hello Sims

I’m not sure where the tunnel is on this diagram. Can you please clarify:

  1. the tunnel endpoints, that is, the devices that are terminating the L2TPv3 tunnel
  2. Which interface of the routers has the IP address indicated? The subinterfaces connecting to the cloud?

If I make the assumption that the L2TPv3 tunnel is between the two routers over the cloud, then this is functioning correctly, since these two interfaces are on the same subnet, which is to be expected between two L2TPv3 endpoints.

Please clarify and let us know more so we can answer more precisely.

I hope this has been helpful!

Laz

Rene; We are moving buildings in the Cardiff area. I need to extend some vlans across a private ehternet connection. we have a private ethernet connection in place now between two of the locations, but I need to extend to a third location. Is this possible or is l2tpv3 just a point to point only method of doing so. I tried to upload a pdf of what I am trying to accomplish but I was not allowed as it said i am a newbie and newbie’s are not allowed. thanks

Hello Gerald

L2TPv3 can only be configured in a P2P scenario. However if you have the option of using MPLS, you can always use MPLS Point-to-Multipoint Traffic Engineering: Support for Static Pseudowires

In this way you can configure a point to multipoint pseudowire.

I hope this has been helpful!

Laz