L3 Etherchannel (Multilayer Switch): Routing Problem

Hello

I’m learning for CCNA R&S. I like to build a network with a L3-etherchannel.

Unfortunatelly I get a routing problem. PC0 can’t ping PC1 192.168.44.1 or L3-virtual Interface 192.168.12.2 -> Pinging 192.168.44.11 with 32 bytes of data: Reply from 192.168.2.1: Destination host unreachable.

I am very confused about the command ip routing.
ip route shows only the network of vlan20 and vlan10 but NOT etherchannel 12 or the static route
ip route 192.168.44.0 255.255.255.0 GigabitEthernet0/1. Why?

Switch#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route
Gateway of last resort is not set
C    192.168.2.0/24 is directly connected, Vlan10
C    192.168.3.0/24 is directly connected, Vlan20

Can anybody help me?
Best regards
Felix

Switch3:

Switch#show run
Building configuration...

Current configuration : 1678 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
!
!
ip routing
!
!
!
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface Port-channel 12
 no switchport
 ip address 192.168.12.1 255.255.255.0
!
interface FastEthernet0/1
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/2
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
 no switchport
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 no switchport
 no ip address
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan10
 mac-address 00d0.5834.5901
 ip address 192.168.2.1 255.255.255.0
!
interface Vlan20
 mac-address 00d0.5834.5902
 ip address 192.168.3.1 255.255.255.0
!
ip classless
ip route 192.168.44.0 255.255.255.0 GigabitEthernet0/1 
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

-

Switch# 
Switch#show run
Building configuration...

Current configuration : 1678 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
!
!
ip routing
!
!
!
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface Port-channel 12
 no switchport
 ip address 192.168.12.1 255.255.255.0
!
interface FastEthernet0/1
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/2
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
 no switchport
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 no switchport
 no ip address
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan10
 mac-address 00d0.5834.5901
 ip address 192.168.2.1 255.255.255.0
!
interface Vlan20
 mac-address 00d0.5834.5902
 ip address 192.168.3.1 255.255.255.0
!
ip classless
ip route 192.168.44.0 255.255.255.0 GigabitEthernet0/1 
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

It looks like you are pointing the static routes out of named interfaces which do not have IP addresses. The IP addresses are set on the eitehr channel port channel interfaces and you will either need to point the route out of that interface or directly to the IP address. try changing the commands to:

SW3:

ip route 192.168.44.0 255.255.255.0 192.168.2.1

and similar on the other switches and see what happens.

Hello Felix

The first thing that comes to mind is that since the directly connected port channel interface subnet does not show up in the routing table as a connected route, the port channel interface must be down. Do a show ip interface brief to check the state of the portchannel interface and if it has successfully obtained its IP address . If not, try doing a no shutdown on the interface.

The subnets of the IP addresses assigned to interfaces MUST show up in the routing table if the interface is active and has been configured corrrectly.

I hope this has been hepful!

Laz