Link Flapping


(Adam M) #1

Hello All,

I have a link that is flapping too fast for the 4G LTE (back-up) connection to take affect. When this happens there’s no way to access the router remotely. Is there any way to configure the fail over to happen faster ? Are there timers that can be increased/decreased or would an EEM script be a possible solution. I’ve included the 4G LTE config below.

Thanks

template Tunnel434
!
!
chat-script lte "" "AT!CALL" TIMEOUT 60 "OK"!
!
!
controller Cellular 0/1
 lte modem link-recovery rssi onset-threshold -110
 lte modem link-recovery monitor-timer 20
 lte modem link-recovery wait-timer 10
 lte modem link-recovery debounce-count 6
track timer ip route 1
!
track 434 ip route 0.0.0.0 0.0.0.0 reachability
!
ip tcp path-mtu-discovery
!
!
interface Loopback0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip flow ingress
!
interface Loopback1234
 ip address 1.2.3.4 255.255.255.255
!
interface Tunnel434
 no ip address
!
!
interface Cellular0/1/0
 description Mobile Number
 ip address negotiated
 ip mobile router-service roam
 ip mobile router-service collocated ccoa-only
 encapsulation slip
 load-interval 30
 dialer in-band
 dialer idle-timeout 0
 dialer enable-timeout 6
 dialer string lte
 dialer watch-group 1
 async mode interactive
!
interface vlan1
ip tcp adjust-mss 1390
 ip policy route-map clear-df
!
!
!
!
router mobile

no ip forward-protocol nd
!
ip mobile secure home-agent 66.174.113.1 spi decimal 256 key ascii VzWNeMo algorithm hmac-md5
ip mobile router
 address 1.2.3.4 255.255.255.0
 collocated single-tunnel
 home-agent 172.16.2.5
 mobile-network Loopback0
 mobile-network vlan1
 template Tunnel434
 register extend expire 10 retry 3 interval 5
 reverse-tunnel
 tunnel mode gre
!
dialer watch-list 1 ip 5.6.7.8 0.0.0.0
dialer watch-list 1 delay route-check initial 30
dialer watch-list 1 delay connect 1
!
route-map clear-df permit 10
 set ip df 0
!
!
line 0/1/0 
 exec-timeout 5 0
 script dialer lte
 modem InOut
 exec
 transport input ssh
 !
event manager applet NEMO-BACKUP
 event track 434 state down
 action 10 cli command "enable"
 action 20 cli command "clear ip mobile router registration" pattern "confirm"
 action 40 cli command "y"
!
!
ip route 0.0.0.0 0.0.0.0 192.168.1.2 track 434
!
ip route 0.0.0.0 0.0.0.0 10.10.10.10 2 track 434
!

(Lazaros Agapides) #2

Hello Adam

There may be several reasons for flapping to occur on backup cellular connections. Before we look at your config, keep in mind that some cellular companies will disconnect a cellular connection if the source IP addresses in the packets being sent on the 4G interface use a different source address than the one that has been negotiated with the provider. One way to solve this issue is to configure NAT so that all internal addresses will be translated to the IP address that is “allowed” by the provider.

Now looking at your config, I see you have a tracking object 434 that is tracking the reachability of the default route. If the default route goes down, you are also initiating an event manager applet that will clear the mobile router registration, which causes the “keepalives” from the router to the cellular connection to cease, essentially tearing down the connection. What this will do is any time the default route is not reachable, the cellular connection will be torn down, even if the default route in question at the time is your primary connection. So when it attempts to go to backup, the cellular connection, the very connection you want to use as a backup, will be torn down. Also, you are tracking both default route options that you installed whereas you should track only the primary (wired) one and have a higher administrative distance on the backup (cellular) default route.

My suggestion would be to review the following Cisco documentation on 4G configurations especially for backup.


Section 5.6 details the best practice for such configurations.

I hope this has been helpful!

Laz


(Adam M) #3

Hello Lazaros,

Thank you for the information !

-Adam