Multicast over SVI Nightmare

I have two switches each with 2 SVI’s.
Firmware: ess3x00-universalk9.17.09.01.SPA.Cupirtino
Hardware: Cisco Catalyst IE3x00 Rugged Series Switches

Switch 1 Config:

interface Loopback0
 ip address 1.0.0.1 255.255.255.0
 ip pim sparse-mode
 
!
interface Vlan100
 ip address 192.168.0.2 255.255.255.0
  ip pim sparse-mode
 ip pim dr-priority 4
 standby version 2
 standby 1 ip 192.168.0.5
 standby 1 priority 254
 standby 1 preempt
!
interface Vlan200
 ip address 192.168.16.2 255.255.255.0
 ip helper-address 10.255.255.255
 ip pim dr-priority 6
 ip pim sparse-mode
 standby version 2
 standby 2 ip 192.168.16.5
 standby 2 priority 254
 standby 2 preempt

router eigrp 100
 network 1.0.0.1 0.0.0.255
 network 192.168.0.0 0.0.0.255
 network 192.168.16.0 0.0.0.255
 redistribute static metric 1000 1 255 1 1500
 eigrp router-id 192.168.16.2
ip pim rp-address 1.0.0.1
ip pim rp-candidate Loopback0 priority 253
ip pim send-rp-announce loopback 0 scope 5
ip pim send-rp-discovery loopback 0 scope 5

Switch 2

interface Loopback1
 ip address 2.2.2.1 255.255.255.0
 ip pim sparse-mode
!
interface Vlan100
 ip address 192.168.0.4 255.255.255.0
  ip pim sparse-mode
 ip pim dr-priority 4
 standby version 2
 standby 1 ip 192.168.0.5
 standby 1 priority 254
 standby 1 preempt
!
interface Vlan200
 ip address 192.168.16.4 255.255.255.0
 ip helper-address 10.255.255.255
 ip pim dr-priority 7
 ip pim sparse-mode
 standby version 2
 standby 2 ip 192.168.16.5
 standby 2 priority 254
 standby 2 preempt

router eigrp 100
 network 2.2.2.1 0.0.0.255
 network 10.0.0.0
 network 192.168.0.0 0.0.0.255
 network 192.168.16.0 0.0.0.255
 redistribute static metric 1000 1 255 1 1500
 eigrp router-id 192.168.16.4
ip pim send-rp-discovery loopback 1 scope 10

I’ve played around with the RP settings and I can ping the RP from all SVI’s on Switch 1 and Switch2. I don’t know where to have the DR since I’m sourcing traffic from Switch 1 and Switch 2.
The firmware doesn’t allow me to do static mroutes or pim sparse-dense. Only dense or sparse.
Is this design even possible without bidir. I feel like I need to set the RP between the two switches since I have Senders on both switches. Any high level advice would be appreciated. Do I need to enable multiple RP’s? The only problem with that is I have an ESXi server on each switch sending the same multicast group address. Should I remove all the SVI’s on one of the switches ? I need to route multicast to different VLAN’s.

Hello Adam

I believe that the confusion here comes from the fact that you are using HSRP. So the SVIs on the switches are not acting simply to route traffic, but they are also acting as backup to each other.

When you have an HSRP arrangement, it would be helpful to take a look at HSRP-aware PIM. As this Cisco documentation describes:

Protocol Independent Multicast (PIM) has no inherent redundancy capabilities and its operation is completely independent of Hot Standby Router Protocol (HSRP) group states. As a result, IP multicast traffic is forwarded not necessarily by the same device as is elected by HSRP. The HSRP Aware PIM feature provides consistent IP multicast forwarding in a redundant network with virtual routing groups enabled.

Ideally, we want the multicast traffic to be forwarded by the HSRP active router for any particular VLAN. This allows PIM to leverage HSRP redundancy and avoid duplicate traffic. In this way, the DR is the same as the active router.

As for the RP, it is considered best practice to use Anycast RP, which allows for redundant RPs, which you can configure as the addresses of the SVIs themselves, rather than the virtual IP. Take a look at this Cisco Community thread for more info on this. For more info on Anycast RP configurations, take a look at the following lesson.

Now having said all of this, you haven’t told us what the behavior of your topology is. Is multicast working with your setup? What malfunctions or deficiencies do you see? Let us know how you get along!

I hope this has been helpful!

Laz

Thanks for the reply @lagapides.

I got off the phone with Cisco TAC for for 13 hours today. They are puzzled why this isn’t working. We’ve changed having SVI’s only on one swtich, enable PIM on only one switch. I tried the Anycast RP setup with no luck. The issue is I can Send from from Switch 1 (VLAN 100) and Receive on Switch 2 (VLAN 200) but not the other way around unless I add a static igmp join to attract traffic on the WAN side of the Senders router. Example: If I’m trying to receive on Switch 2 on VLAN 200 I need to add a “static igmp join” on VLAN 200 on Switch 1. However, now everyone in the VLAN recives the group address which is unwanted. The mroute shows a *,G and a source G. The show ip igmp group address shows a request from the interface. Works fine on the same switch. I’ll keep you posted on our progress tomorrow.

Hello Adam

Thanks for sharing your progress. It will be interesting to see the solution you come up with, and the possible workaround that TAC will suggest. It is indeed strange behavior. Looking forward to hearing your progress.

Laz

@lagapides
I’ve been able to replicate the issue and showed Cisco my findings.
A restart of the VLAN to route traffic to the same switch but different VLAN’s. (issue 1)
Restarting both ports on each switch that participate in the port channel. Etherchannel and LACP have the same issue. (issue 2)

Issue 1: Not sending multicast between VLAN’s same switch:

Step1: Find the source device that is finding multicast.
Step 2: What VLAN is it in
Step 3: Console into the switch where the multicast is sourcing.

configure terminal <enter>
Int vlan 500 <enter>
Shut <enter>
No shut <enter>

Issue 2: Routing Multicast traffic between switches on different VLAN’s.
Step 1: Console into Switch1

Configure terminal <enter>
int range gigabitEthernet 1/6, gigabitEthernet 2/11  <enter>  //example 
no channel-group 1 mode active  <enter>
channel-group 1 mode active  <enter>

Step 2: Console into Switch 2
Configure terminal

int range gigabitEthernet 2/7-8  <enter>
no channel-group 1 mode active  <enter>
channel-group 1 mode active  <enter>

Multicast restored until next reboot.
Waiting on Cisco to release an update to 17.09.01 Cupertino

1 Like