Multicast PIM Accept Register

This topic is to discuss the following lesson:

https://networklessons.com/multicast/multicast-pim-accept-register/

Hi Rene,

I setup up lab for 4 routers to allow one router and block other router, it’s not working, but for two routers like your lab its working.
PIM Accept-Register LAB

in this LAB I want to filter R1 as source to R4 which is configured group address 239.9.9…9, but its allowing all sources.

Configuration

R1

interface GigabitEthernet1/0
 ip address 12.12.12.1 255.255.255.0
 ip pim sparse-mode
 negotiation auto
end
!
ip pim rp-add 2.2.2.2

R2

interface GigabitEthernet1/0
 ip address 12.12.12.2 255.255.255.0
 ip pim sparse-mode
 negotiation auto
!
interface GigabitEthernet2/0
 ip address 24.24.24.2 255.255.255.0
 ip pim sparse-mode
 negotiation auto
!
interface FastEthernet0/0
 ip address 23.23.23.2 255.255.255.0
 ip pim sparse-mode
 duplex half
!
ip pim rp-address 2.2.2.2
ip pim accept-register list Source
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
 ip pim sparse-mode
!
ip access-list extended Source
 deny   ip host 12.12.12.1 host 239.9.9.9
 permit ip any any

Hi Rene,

I setup same LAB in VIRL, the previous LAB was GNS3, right now its showing this debug message

Aug 22 05:13:25.023: %PIM-4-INVALID_SRC_REG: Received Register from 2.2.2.2 for (12.12.12.1, 239.9.9.9), not willing to be RP

from R2 (Which is the RP), but even though I’m receiing INVALID-Source address its still allowing to ping the group address and even setting up in multicast routing.

(12.12.12.1, 239.9.9.9), 00:02:26/00:00:33, flags: FT
 
 Incoming interface: GigabitEthernet0/1, RPF nbr 12.12.12.1
  Outgoing interface list:
    GigabitEthernet0/2, Forward/Sparse, 00:02:26/00:02:04

Regards
Jama

Hi Rene

I changed topology this way its working without Issue

image

Why its accepting R1 as source and not accepting Source Router as Source ?

the difference between the Source router and R1 is that the Source router isn’t running any PIM mode, I just enabled ip multicast-routing. (and sure I modified the Access-list)

is this means that if the DR it self generates multicast traffic as source, the Pim Accept Register will not effect it?.

Regards
Jama

Hi Jama,

It’s probably because the pings are sent from the G1/0 interface on the R1 router. When R2 doesn’t accept 12.12.12.1 as a source, it sends a prune message to R1 so that it doesn’t forward this multicast traffic anymore. R1 however, is sourcing the traffic from its G1/0 interface so it’s not “multicast routed”.

If you source the multicast traffic from a loopback interface on R1 that isn’t permitted on the access-list of R2, you’ll see that R1 no longer forwards it on its G1/0 interface because of the pruning.

Rene

1 Like