OER (Optimized Edge Routing) Basic Configuration

This topic is to discuss the following lesson:

Hi Rene,
first of all a very many thanks for such a beautiful explanation of OER.

But I got a problem that after getting that log message:
%OER_MC-5-NOTICE: Prefix Learning WRITING DATA

i’ve changed OER mode from observe to route control ……But still its not building any information to the routing table and not doing any load balancing as u have shown in the above……Plz help

Hmm couple of things that could go wrong. Do you have a parent route for both links?

yea i had checked that twice…it was there in running-config and i also have done a lot of debugging. anyways i am starting over again with a fresh topology…if it doen’t solve i will let u know…well …thanks for replying

i am using c3660-ik9o3s-mz.124-6.T is that any extra configuration do i have to do with that…

OER is kinda buggy anyway, it’s much more mature on IOS 15 as Pfr (performance routing). I used the 3725 12.4(15)T14 image to do this. You might want to try that one…

hi,

i have tried it again but same result now im copy paste mu running config of R3

R3#sh running-config 
Building configuration...

Current configuration : 1404 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
ip domain name lab.local
!
!
!         
!
key chain OER
 key 1
   key-string sukhjit
oer master
 !
 border 192.168.123.3 key-chain OER
  interface Serial1/0 external
  interface Serial1/1 external
  interface FastEthernet0/0 internal
 !
 learn
  throughput
  delay
 mode route control
!
oer border
 local FastEthernet0/0
 master 192.168.123.3 key-chain OER
!
!
!
!         
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.123.3 255.255.255.0
 duplex auto
 speed auto
!
interface Serial1/0
 bandwidth 1024
 ip address 192.168.34.3 255.255.255.0
 serial restart-delay 0
!
interface Serial1/1
 bandwidth 64
 ip address 192.168.35.3 255.255.255.0
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 192.168.35.5
ip route 0.0.0.0 0.0.0.0 192.168.34.4 5
!         
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end
R3#show oer master border detail 
Border           Status   UP/DOWN             AuthFail
192.168.123.3    ACTIVE   UP       00:10:17          0
 Se1/0           EXTERNAL UP             
 Se1/1           EXTERNAL UP             
 Fa0/0           INTERNAL UP             

 External         Capacity      Max BW   BW Used Tx Load Status          Exit Id
 Interface         (kbps)       (kbps)    (kbps)    (%)                         
 ---------        --------      ------   ------- ------- ------           ------
 Se1/0                1024         768         0       0 UP                    4
 Se1/1                  64          48       224      98 UP                    3
R3#

and i have also checked if extra spaces with key-chain OER

but dosn’t work for me

Hi , did anyone found the solution , it not work fopr 12.4(16)

Hi Roman,

I would highly recommend to try OER / Pfr on IOS 15.x. Many issues / bugs in 12.4 have been fixed.

Rene

Hi Rene

I ran through this lab and it all seems pretty straightforward, so I decided to expand on this to use an MC and two seperate BR’s as that is what we will be using at one of our new offices we are moving to shortly.
Everything seems to be ok, I am using static routes and can route out either BR, tested by simply shutting an externa interface on a BR and leaving a ping runing and it fails over.

A few problems (besides it not working)
When it discovers routes it only discovers exit routes out of onew of the BR’s:

%PFR_MC-6-ROUTE_EVENT_INFO: Discovered exit BR 59.0.0.9, i/f Gi1/0 for traffic class Prefix 10.6.6.6/32
%PFR_MC-6-ROUTE_EVENT_INFO: Discovered exit BR 59.0.0.9, i/f Gi1/0 for traffic class Prefix 10.7.7.7/32

It claims to change the route to tthe second BR, however traffic continues to flow thorugh the first BR and after a while I get a message telling me no Egress bw:
%OER_MC-5-NOTICE: Passive Unreachable OOP Prefix 10.7.7.7/32, No Egress bw for 59.0.0.4, intf Gi1/0

Like I say I have tested the routing and I can route out either BR but I have to physically shut the interface down on the first BR for the second BR to be used as an exit path

I am runing Cisco 7200 15.2(4)S3 in GNS3

Any ideas as to what could be wrong, where I should look or even links to documentation that may be useful?

for those guys who are sayign that it doesnt work, try to wait for about 10-15 mins, it will start balancing and you will see everything, i had the same issue, it wont come up straight away

1 Like

Any chance you could provide the configs at the end?

Hello Chris

I’ll talk to Rene and see what he can do about this. Thanks for mentioning it.

Laz

Hi Chris,

It’s been a long time since I labbed this up. OER is a mess and pain to configure :sweat_smile:

I have to lab up Pfr (the successor of OER) and once I have done that, I’ll add the configs here.

Rene

Yeah it is!

I used these examples in the end:

http://docwiki.cisco.com/wiki/PfR:Solutions:BasicLoadBalancing

https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/pfr/configuration/15-mt/pfr-15-mt-book/pfr-voice-traffic.html#GUID-53000C91-4FDA-4211-836E-489354B616A2 (Voice specific, required for CCIE)

I’ll take a look at those examples.

What I really dislike about OER/Pfr is that you sometimes have to wait for things to happen :smile: It’s a bit like NTP, you configure something and then you have to use some show/debug commands to wait for the magic to happen.

It seems like PFR is mainly used to control egress traffic from the CE perspective. Can it also be used to control ingress traffic?

think I may have found an answer to my question. I believe it can use inbound bgp optimization to do this.

1 Like