OSPF adjacency fail on NBMA network using point-to-multipoint Frame Relay

I tried to configure OSPF on an NBMA network using a point-to-multipoint Frame Relay, as below:

Configuration on R1:

!
interface Serial1/0
 ip address 192.168.123.1 255.255.255.0
 encapsulation frame-relay
 ip ospf network non-broadcast
 serial restart-delay 0
 clock rate 2016000
 frame-relay map ip 192.168.123.2 102 broadcast
 frame-relay map ip 192.168.123.3 103 broadcast
!

!
router ospf 1
 network 192.168.123.0 0.0.0.255 area 1
 neighbor 192.168.123.3
 neighbor 192.168.123.2
!

Configuration on R2:

!
interface Serial1/0
 ip address 192.168.123.2 255.255.255.0
 encapsulation frame-relay
 ip ospf network non-broadcast
 ip ospf priority 0
 serial restart-delay 0
 clock rate 2016000
 frame-relay map ip 192.168.123.1 201 broadcast
!
!
router ospf 1
 network 192.168.123.0 0.0.0.255 area 1
!

Configuration on R3:

!
interface Serial1/0
 ip address 192.168.123.3 255.255.255.0
 encapsulation frame-relay
 ip ospf network non-broadcast
 ip ospf priority 0
 serial restart-delay 0
 clock rate 2016000
 frame-relay map ip 192.168.123.1 301 broadcast
!
!
router ospf 1
 network 192.168.123.0 0.0.0.255 area 1
!

But when I check the neighbors on R2 and R3, I don’t see a neighbor establised, and in R1 I see the below:

R1#sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
N/A               0   ATTEMPT/DROTHER    -        192.168.123.3   Serial1/0
N/A               0   ATTEMPT/DROTHER    -        192.168.123.2   Serial1/0

What exactly am I missing ?

Think this is what happens:
* statically defining a neighbour only on one side would result in that side sending a unicast hello to the defined neighbour.
* The sending neighbour would go to the ATTEMPT state (so far so good)
* The receiving neighbour would go to the INIT state upon receving the hello (so far so good)
* At this point the receiving neighbour does not respond.

So what you are seeing in the neighbour states matches exactly with the receiving neighbour not responding to a unicast hello.

So first try to look at the unicast paths and make sure that all works

Hi Maikel,

I’m new to Frame Relay setups. Can you please be specific, on what are the points I need to check here on my setup ? What do you exactly mean when you say to check the unicast paths ?

See if you can ping all the network interfaces from each router