OSPF Virtual Link

Hi Rene,
In the scenario specified I am unable to reach from R5 to PC1. Help me
untitled

Hi Mriganksc,

Are you able to reach PC1 from R4?

R5 is in area 4 and not directly connected so you’ll need a virtual link for that. One common mistake that people make when configuring a virtual link is to use the IP address of your neighbor instead of the router ID.

Rene

Please help me with configuration of R5. I have gone through the concepts.

The configuration of R5 is very straight forward, it’s just an OSPF router that sits within area 4. Just make sure you have the correct network command:

R5#
router ospf 1
network 192.168.0.20 0.0.0.255 area 4

The virtual link has to be configured on R3 and R4. Something like this:

R3#
router ospf 1
network 192.168.0.16 0.0.0.255 area 3
area 3 virtual-link <ID of R4>

R4#
router ospf 1
network 192.168.0.16 0.0.0.255 area 3
area 3 virtual-link <ID of R3>

Thanks a lot. I will try to implement the suggested configuration and let you know, whether it works.

Getting following error on R3:

Apr 4 14:31:02.439: %OSPF-4-ERRRCV: Received invalid packet: mismatch area ID, from backbone area must be virtual-link but not found from 192.168.0.18, FastEthernet0/0

Configuration of R3 is as follows:

upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
ip source-route
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
! 
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback3
 ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.0.17 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.0.10 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 192.168.0.14 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet1/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet2/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet2/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 area 3 virtual-link 4.4.4.4
 network 192.168.0.8 0.0.0.3 area 0
 network 192.168.0.12 0.0.0.3 area 0
 network 192.168.0.16 0.0.0.3 area 3
 default-information originate always
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
end

Configuration of R4 is as follows:

upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
ip source-route
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
! 
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback4
 ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.0.18 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.0.21 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet2/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet2/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 area 3 virtual-link 3.3.3.3
 network 192.168.0.16 0.0.0.3 area 3
 network 192.168.0.20 0.0.0.3 area 4
 default-information originate always
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
end

Hi Mriganksc,

The configuration looks OK. Two things you might want to check:

* Are the router IDs correct? If you added those loopbacks after starting OSPF then you will still have the old router ID. Use show ip protocols | include Router ID to verify this.
* Are the links on R3 in area 0 active? If not, your virtual link will not appear.

Rene

R1_i1_startup-config.txt (1.4 KB)
R2_i2_startup-config.txt (1.4 KB)
R3_i3_startup-config.txt (1.4 KB)
R4_i4_startup-config.txt (1.4 KB)
R5_i5_startup-config.txt (1.3 KB)
Hi Rene,
I am able to reach 10.10.60.1 from R5 but getting no reply from PC1 i.e 10.10.60.100. Router configurations are shared.

issue resolved. Replaced Docker Ubuntu Host (PC1) with VPC.
(Y)

Good to hear you found it.

When you are playing with networking protocols, It’s best to keep it simple…if you just want to test connectivity, it’s easier to use a router (with IP routing disabled) as a host and use that to ping from one end to another.

When you use a Windows PC, there’s the firewall that could mess things up…with something like Docker, there are a couple of things that could go wrong. Keep it simple :slight_smile:

A post was merged into an existing topic: OSPF Virtual Link Authentication