Portchannel and sub interfaces

Hi !

I would be nice to have a lesson in Subinterfaces on ASA and also Portchannel with sub interfaces it could be both to lan or to wan…

/Best regards Oskar

Hi Oskar,

Did you see this example for the VLANs?

Cisco ASA VLANs and Trunks

Here’s a quick configuration example for a port-channel. Here are the physical interfaces:

interface GigabitEthernet1/1
 description TO_SWITCH
 channel-group 1 mode active
 no nameif
 no security-level
 no ip address

interface GigabitEthernet1/2
 description TO_SWITCH
 channel-group 1 mode active
 no nameif
 no security-level
 no ip address

We don’t configure anything on the physical interfaces except the “channel-group” command. Here’s the port-channel interface:

 interface Port-channel1
 lacp max-bundle 8
 no nameif
 no security-level
 no ip address

If you don’t want to use VLANs then you can configure everything on this interface. If you do want to use VLANs, don’t add anything on the port-channel interface but create sub-interfaces like these two:

 interface Port-channel1.10
 description SERVERS
 vlan 10
 nameif SERVERS
 security-level 100
 ip address 192.168.1.0 255.255.255.0 

 interface Port-channel1.20
 description DESKTOPS
 vlan 20
 nameif DESKTOPS
 security-level 100
 ip address 192.168.2.0 255.255.255.0

Hope this helps!

Rene