SSH Slow Login Fix

This topic is to discuss the following lesson:

Really useful! Thanks, solve my delay here!

Thanks Rene

I put in all of your advised changes and ssh login is now instant.

It used to take 2 minutes to login to HP Proliant sitting next to me :))

Glad to hear it helped Johan…2 minutes is a long time to wait for a console :slight_smile:

Thanks Rene,
It is very useful to me.
I fixed this problem
For me, Ubuntu12.04, “Authentication” caused problem
Actually, network engineer in our institute failed to fix this problem.

You are welcome!


How did u fixed the issue??
I’m doing labs on GNS3 and I’m not unable to connect in ssh to the asav.
Also I have the same problem with my 3560CG in my home enviroment using Remmina.

Here the verbose log.


Hello Giovanni

Doing some research I have found that you may need to zeroize and recreate your key. If that doesn’t work, you may need to modify the ssh command you’re using to connect. Take a look at this Cisco community post and let us know your results.

I hope this has been helpful!


zerozize and recreate the key not solved the issue.

I was able to connect to the asav and the 3560 specifying the auth algorithm.

$ ssh -l <USERNAME> -oHostKeyAlgorithms=+ssh-dss -oKexAlgorithms=+diffie-hellman-group1-sha1 <HOST>
It worked for Remmina too.


1 Like