Strange issue with home lab switch fun for they who like puzzles!

I have some 3560 Switches I threw in rack and configured up.

Everything was running well and then I installed a different image See below:
System image file is “flash:/c3560-ipservicesk9-mz.122-55.SE11.bin”

For this model this image is suppose to be good and indeed I installed it on both of my 3560 switches named 3560-1 and 3560-2.

When I came home today I could not telnet into 3560-2.

I made sure all my telnet ports where configured with passwords and login and that there was a secret password enabled.

I tested with pings which where fine. However I could still not telnet to the switch. I finally reloaded it but this did not solve the issue either. Next I sit the switch back to its original IOS and that also did not fix it as it had the same error.

Finally I deleted out the vlan.dat and the config.txt files and erased the configuration and installed the IPservice image back on (Which I verified when installing as well as checked hash for corruption) and started it up with no configure and I built it back up and once again everything looked good.

see some tests:

3560-1#ping 192.168.174.20

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.174.20, timeout is 2 seconds:
!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/9 ms
3560-1#telnet 192.168.174.20
Trying 192.168.174.20 …
% Connection refused by remote host

here is the config of the switch cannot telnet to(3560-2):
I removed most of the ports as they just distract.

3560-2#show run
Building configuration…

Current configuration : 2510 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 3560-2
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$HCkf$o7azeEsaX9kpz/EDDgJoo/
!
!
!
no aaa new-model
system mtu routing 1500
ip routing
!
!
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
interface FastEthernet0/1
interface GigabitEthernet0/4
!
interface Vlan1
no ip address
!
interface Vlan500
ip address 192.169.174.20 255.255.255.0
!
ip default-gateway 192.168.174.1
ip classless
ip http server
ip http secure-server
!
!
!
!
!
line con 0
line vty 0 4
exec-timeout 30 0
password cisco
logging synchronous
login
line vty 5 15
exec-timeout 30 0
password cisco
logging synchronous
login
!
end

===================================

3560-2#show vlan brief

VLAN Name Status Ports


1 default active Fa0/1, Fa0/2, Fa0/3, Fa0/4
Fa0/5, Fa0/6, Fa0/7, Fa0/8
Fa0/9, Fa0/10, Fa0/11, Fa0/12
Fa0/13, Fa0/14, Fa0/15, Fa0/16
Fa0/17, Fa0/18, Fa0/19, Fa0/20
Fa0/21, Fa0/22, Fa0/23, Fa0/24
Fa0/25, Fa0/26, Fa0/27, Fa0/28
Fa0/29, Fa0/30, Fa0/31, Fa0/32
Fa0/33, Fa0/34, Fa0/35, Fa0/36
Fa0/37, Fa0/38, Fa0/39, Fa0/40
Gi0/1, Gi0/2, Gi0/3, Gi0/4
500 Management active Fa0/41, Fa0/42, Fa0/43, Fa0/44
Fa0/45, Fa0/46, Fa0/47, Fa0/48

Directory of flash:/

2  -rwx    12750172   Mar 1 1993 03:02:53 +00:00  c3560-ipservicesk9-mz.122-55.SE11.bin
3  -rwx         616   Mar 1 1993 00:01:45 +00:00  vlan.dat
5  drwx         192   Mar 1 1993 00:06:39 +00:00  c3560-ipbase-mz.122-25.SEE2

409 -rwx 2466 Mar 1 1993 00:18:41 +00:00 config.text
410 -rwx 24 Mar 1 1993 00:18:41 +00:00 private-config.text
411 -rwx 2072 Mar 1 1993 00:18:41 +00:00 multiple-fs

32514048 bytes total (11603456 bytes free)
3560-2#

anyway if have some ideas throw it at me.

rack-minue2811s

nm the problem was not that interesting. I just fat fingered an IP address.

There probably was originally an issue when I recorded some of this original stats. However, when I removed the IOS and re-added the IOS and then rebuilt the config that probably fixed it in other words “please restart your PC” lol…

However, I was sick that night when working on this which is one of the reasons I quit and so I re-added back 192.169.174.20 instead of 192.168.174.20

I didn’t find it till just now when I tried to ping again and the ping was not working. Once I changed the int vlan 500 to correct IP and tested ping again it worked.

then when I tested telnet again it worked.