Use Linux Screen for Console Access

This topic is to discuss the following lesson:

Hi Rene
WHy do not you also write about Linux Certification, you have potential and lot of people will be very pleased with you. Think about it.
Mario Rosario

Hi Mario,

Thanks, I might do it in the future but first I have plenty of Cisco material I want to write about :slight_smile:


Hi Rene,

Do you know how in linux is possible to save the output from the console to a file.txt?


Hello Giovanni

In Linux, the command script will do what you are asking for. Take a look at the man page for this command.

In short, you can type script output.txt and all subsequent commands and output will be saved to the output.txt file. Here is an example of the commands you can use:

$ script output.txt
Script started, file is output.txt

$ ls
output.txt  testfile.txt  foo.txt

$ exit
Script done, file is output.txt

You can then read the output.txt file which will have all of the CLI commands and outputs you saw on the terminal.

I hope this has been helpful!


1 Like

This is great, thanks Laz

1 Like


At work I’ve encountered an issue with the connection of my notebook to a cisco switches with the console cable + serial->usb adapter.
I’m not be ablte to find /dev/ttyusb0.

I assume that is not an hw issue because it works well on windows and my system can detect it.

sudo lsusb 
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 0bda:57f3 Realtek Semiconductor Corp. 
Bus 001 Device 002: ID 04ca:3015 Lite-On Technology Corp. 
Bus 001 Device 005: ID 067b:2303 Prolific Technology, Inc. PL2303 Serial Port
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I’ve noticed that if I try the same command with an Usb->MiniUsb console cable for my 3560CG at home I’ve not the problem and so I can connect correctly on my switch.

Can you help me?

Ok I think I solved.

Don’t know why but my Ubuntu not mount /Dev/ttyUSB0 when I plug the console cable.

I’m not sure what is changed but now IF I try to force the connection ( without TAB ) it is correctly mounted and works

Hello Giovanni

I was about to do some research on this one, but it’s good to hear that you’ve solved it. Thanks for posting it and letting us know!