Hello @bansah29 ,
I understand the confusion. Take a look at this picture:
In my network, I have a switch (SW1) that is connected to my ESX server with a trunk. On the switch, I have these SVIs:
SW1#
interface Vlan90
description LAB
ip address 10.65.90.254 255.255.255.0
interface Vlan91
description LAB1
ip address 10.65.91.254 255.255.255.0
interface Vlan92
description LAB2
ip address 10.65.92.254 255.255.255.0
interface Vlan93
description LAB3
ip address 10.65.93.254 255.255.255.0
I also have a DHCP pool for each of these VLANs:
SW1#
ip dhcp pool LAB
network 10.65.90.0 255.255.255.0
default-router 10.65.90.254
dns-server 1.1.1.1
ip dhcp pool LAB1
network 10.65.91.0 255.255.255.0
default-router 10.65.91.254
dns-server 1.1.1.1
!
ip dhcp pool LAB2
network 10.65.92.0 255.255.255.0
default-router 10.65.92.254
dns-server 1.1.1.1
!
ip dhcp pool LAB3
network 10.65.93.0 255.255.255.0
default-router 10.65.93.254
dns-server 1.1.1.1
Is this really needed? It allows me to connect the port groups on the ESX server to the outside world. When using EVE-NG, the “clouds” are connected to the ESX port groups so they can access the outside world:
Lab ↔ VLAN 90
Cloud1 ↔ Lab1 ↔ VLAN 91
Cloud2 ↔ Lab2 ↔ VLAN 92
Cloud3 ↔ Lab3 ↔ VLAN 93
In your case, you only have a single router, no VLANs, and only one subnet. Take a look at this picture:
Your eve-NG server is connected to port group “LAB” with VLAN 0. In other words, no VLAN. This way, it is connected to the outside world and can get an IP address from your router.
You can now access the GUI or SSH of the EVE-NG server. You do have VLAN 91, 92, and 93 because of your port groups, and those are connected to the “Clouds” in EVE-NG. These are isolated, though. They can’t reach the outside world because you don’t have any VLANs on your local network. They end at your ESX vSwitch.
Is this a problem?
Not really, until you try to reach the GUI of your vManage controller. There is no way to get from your computer to one of the port groups in ESX.
To work around this, you could also use port group LAB for Cloud1. It’ll look like this:
Your vEdge routers and controllers will communicate within VLAN 0 (your local subnet). This will work. You could forget about port group LAB1 and use port group LAB. It doesn’t matter. If you want to add a switch with VLAN support in your network, you’ll only have to add the VLAN tags.
The only downside to this solution is that everything communicates in your local network. There is no separation between your lab and “production” traffic. I like to keep things separated, but it won’t matter too much if this is your home network.
I hope this helps you.
Rene