Network Fundamentals Lab 1

This topic is to discuss the following lesson:

2 of the interfaces coming from R1 are labeled Gi0/0.

1 Like

Hello Andrew

Yes, thanks for pointing that out, I’ll let Rene know to make the fix.


Nice Lab, thanks for that.

Regarding Requirement “Each device requires a loopback interface with a /32 IP address. / All loopback interfaces should be reachable.”

For ASW1 / ASW2 : Loopbacks would not be reachable with given solution ?

Hello Markus

Looking over the lab it does seem that the loopbacks assigned to the ASW devices will not be reachable from the rest of the topology. As it stands, OSPF is not configured on the AWS devices. So either OSPF must be enabled, and the loopbacks advertised, or the DSWs must be configured with a static route to those addresses, and those static routes should then be redistributed into OSPF. I will let Rene know so he can make any changes he deems necessary. Thanks for pointing this out!


Hi Markus,

You are right. We need something on ASW1 and ASW2 to make these loopback interfaces reachable. To make this work, we need to run a routing protocol and establish an OSPF neighbor adjacency in VLAN 10, 20, or 30 to advertise the loopback.

I’m making a change to the lab. We’ll add one more VLAN named “MANAGEMENT” that we can use for the L2 switches. We’ll establish OSPF neighbor adjacencies within this VLAN so that we can advertise the ASW1+ASW2 loopback interfaces.

Instead of OSPF, you could also configure a default gateway on ASW1+ASW2 but in that case, you’d have to use their VLAN 200 IP addresses for management since you can’t advertise the loopback interfaces.


The reason you cannot get to the ASW switches is do the fact that you have ip routing turned on. disable IP routing and on the ASW switches specify the gateway for the vlan 40 as the ip default-gateway. Layer3 shouldn’t be turned on at the access layer. You’ll be able to access switches just fine. Use HSRP or VRRP for failover/HA.
Also, I had an issue with the CSW’s IPv6 address on the Po1 was sharing the same link local address for some reason (duplicate). I had to manually set the address on one end and bounce the PO for ospf to come up. I am using Eve-ng with vios_l2-ADVENTERPRISEK9-M image.

Hello Steven

You are indeed correct, strictly speaking, you don’t need to enable routing on the access switches. The configuration of the default gateway should be enough for the ASW switches to achieve reachability to the rest of the network. However, the requirement stated in the lesson was:

Configure the campus network so all VLANs, point-to-point links, and loopback interfaces are reachable.

In order for this to occur, you must either configure default routes on all the devices or somehow advertise the and addresses to the rest of the topology.

Well, that’s not entirely true. Layer 3 shouldn’t be enabled for use by the end devices, yes, but the switch can use Layer 3 (i.e. routing) for the switch itself to achieve connectivity with other devices on the network for management and control plane purposes. The default gateway will suffice, but you can also use OSPF just for this purpose if you choose to. It’s a matter of design preference.

Hmm, that’s interesting. Thanks for sharing that, it’s good for others to keep this in mind to see if they get similar results.

I hope this has been helpful!