Troubleshooting CCNP TSHOOT Lab


(Rene Molenaar) #1

This topic is to discuss the following lesson:


(david a) #2

Hi,
Thanks a lot!!!
It is so clear and helpful!
One question-can I run the Tshoot lab on Packet Tracer ?


(Rene Molenaar) #3

Hi David,

Glad that you like it! I think you should be able to run this in packet tracer but you’ll have to rebuild it. On GNS3Vault.com I added the GNS3 topology with all the startup-configs. You might be able to build the topology in packet tracer and then copy / paste some of my configurations.

Rene


(Diana M) #4

Great Lab!!

I took me two full days to solve it!! I loved it! I hope you can publish some more labs like this!

Thanks!


(ashok G) #5

Hi Rene,

How do i get access to gnsvault.com.

regards,
Ashok


(Lazaros Agapides) #6

Hello Ashok.

You probably mean www.gns3vault.com. You can register by going to this link: https://gns3vault.com/registration/. It was a little hard to find, but the link is available on the right in the login box under the Labs, Blog, FAQ or Contact tabs.

I hope this has been helpful!

Laz


(Vladimir U) #7

Hey guys , I’m trying to find what was the command to show the ip dhcp relay on a Vlan…


(Lazaros Agapides) #8

Hello Vladimir

The command to implement a dhcp relay is the ip helper-address X.X.X.X. If you find that on the interface of the VLAN, then the relay has been configured.

More info about this can be found below:

I hope this has been helpful!

Laz


(James E) #9

EDIT: Solved. There are two sets of links, however as I found the labs via another website I was not aware there were two - so chose the wrong ones.

Hi Guys, I’ve downloaded the gns3vault topology and have started troubleshooting ticket #1 - but nothing is broken. The client can ping successfully, and it automatically gets a DHCP address without any “troubleshooting” required.

I’ve partially read the solution to check I’m not missing anything, and have found that the DHCP pool which should be mis-configured, is already correct. Have corrected versions of the config accidentally been uploaded to link provided at the top of this page?

Thanks


(Michael R) #10

Ever since i updated GNS3 to 2.12 i have had nothing but problems. From it wanting to run a VM instead of opening the IOS images locally on my machine to it complaining that other processes of the application are open to not being able to open files. Very strange but when i first downloaded this file off networklessons.com for the CCNP TSHOOT topology:
https://gns3vault.com/faq/ccnp-tshoot-gns3-topology/

The GNS3 topology file opened perfectly with all the correct coloured shapes on the layout on the file, now it opens with none of that and with only certain links connected and no coloured shapes or writing on it. This is bizarre to try and explain to be honest but i cannot get it to open like it did the very first time i downloaded it, each time i download the file fresh again it looks the same unfinished way. Can anyone explain this, does anyone else have issues with the newer GNS3? I’m only using the same IOS images I’ve ever used and have worked in the past. The 3725-ad.bin and 7200


(Rene Molenaar) #11

Hi Michael,

Did you try this one?

https://gns3vault.com/wp-content/uploads/2011/10/tshoot-topology-2.zip

It’s been awhile since I used GNS3 but since this topology is so popular, I recreated it from scratch in GNS3 2.X. The previous version was a migrated file from the old version to 2.X.

Rene


(Manoj K) #12

One for 1.0.0.0/8 and another for 192.168.1.0 /24. This means that redistribution on R4 has been configured but the keyword “subnets” has been left out.

should be 10.0.0.0/8 , please rectify.


(Rene Molenaar) #13

Thanks Manoj, it has been fixed.


(Manoj K) #14

This shouldn’t be a problem in this topology but it does mean that R3 will send everything that matches 1.0.0.0 /8 and 192.168.1.0 /24 towards R4 if it doesn’t have any more specific routes. ----> should be 10.0.0.0/8 instead of 1.0.0.0/8


(Rene Molenaar) #15

Thanks Manoj, just fixed this!


(Zeko a) #16

please help i can’t open the lab when i opened it it says
The image C3725-AD.BIN is missing
The image C3725-AD.BIN is missing

tho i added it


(Lazaros Agapides) #17

Hello Zeko

Make sure that you’re using the latest version of GNS3 as older versions will not work well with some of the labs in the GNS3Vault. Also, take a look at this thread from the gns3 discussions forum, you might find a solution or workaround there as well.

I hope this has been helpful!

Laz


(Zeko a) #18

i edited the name of the IOS image in notepad + and the version of gns3 and it’s working anyway i’m tryin’ to build ma own topology
Rene please
i have DSW1 and DSW2 running l3 etherchannel and working like a charm but should i activiate ripng on port-channel or SVI for vlan 10 only ?


(Rene Molenaar) #19

Hi Zeko,

If you build your own topology, you can still use my configs:

https://gns3vault.com/wp-content/uploads/2011/10/tshoot-topology-2.zip

Unzip that file and search for *.cfg and you’ll find all my files. Here’s the VLAN 10 config of DSW10:

interface Vlan10
 ip address 10.2.1.1 255.255.255.0
 ip helper-address 10.1.4.5
 ipv6 address FE80::C00B:13FF:FEE1:1 link-local
 ipv6 address 2026::3:1/122
 ipv6 rip RIPNG enable
 standby 10 ip 10.2.1.254
 standby 10 priority 120
 standby 10 preempt

So yes, it does have RIPNG enabled.

Rene


(Zeko a) #20

i got it working i have done on the SVI 10 :blush: . thanks Sir Rene